Jump to content



Photo

Fonts are crappy in Firefox ...

Answered Go to the full post firefox

  • Please log in to reply
16 replies to this topic

#1 Hum

Hum

    totally wAcKed

  • Tech Issues Solved: 10
  • Joined: 05-October 03
  • Location: Odder Space
  • OS: Windows XP, 7

Posted 12 October 2013 - 13:59

This is on a Win XP computer with an Asus hi-def monitor.

 

Picture shows a comparison between IE 8 and Firefox 24.

 

Anything I can do to improve Firefox text ?

 

Thanks ...

Attached Images

  • crap.PNG


Best Answer +LimeMaster , 12 October 2013 - 16:29

Have you enabled ClearType on Windows XP?

Go to the full post



#2 Max Norris

Max Norris

    Neowinian Senior

  • Tech Issues Solved: 17
  • Joined: 20-February 11
  • OS: Windows 8.1, BSD Unix
  • Phone: HTC One (Home) Lumia 1020 (Work)

Posted 12 October 2013 - 14:05

Anything I can do to improve Firefox text ?

There's some settings you can fiddle with to get it to how you like such as adjusting the font rendering mode, etc, don't know them off the top of my head as I haven't had to mess with them in ages, easy Google search. There's a couple addons to do it for you too, such as the one below, might be worth looking at. (I haven't tried it, just first one I found.)
https://addons.mozil...aliasing-tuner/

 

45028.png?modified=1331247702

 

Edit -- never mind the above addon, I see you're still using XP, missed that part, this is only for tuning Direct2D and DirectWrite, won't have access to those.  Will need to do it by hand.



#3 +Zlip792

Zlip792

    Neowinian Senior

  • Tech Issues Solved: 10
  • Joined: 31-October 10
  • Location: Pakistan
  • OS: Windows 8.1 Pro 64-bit
  • Phone: Nokia C3-00 (8.70 firmware) It sucks!!!

Posted 12 October 2013 - 14:08

This might be worth looking: http://www.askvg.com...ing-in-windows/

 

If your GPU support Hardware Acceleration then why not trying using it. I think Firefox does not do HW accelerated font rendering on XP and neither does MS provide it. I could be wrong.

 

Try this MS tool as well: http://www.microsoft...pepowertoy.mspx



#4 kronckew

kronckew

    Neowinian

  • Joined: 12-August 09
  • Location: Glos., UK
  • OS: win7 x64 sp1

Posted 12 October 2013 - 14:42

Firefox versions actually sometimes have trouble with hardware acceleration regarding font rendering. try turning it OFF if it is on. menu path = tools - options - advanced -general. untick H/w accel. box.



#5 +BudMan

BudMan

    Neowinian Senior

  • Tech Issues Solved: 96
  • Joined: 04-July 02
  • Location: Schaumburg, IL
  • OS: Win7, Vista, 2k3, 2k8, XP, Linux, FreeBSD, OSX, etc. etc.

Posted 12 October 2013 - 16:01

Anything I can do to improve Firefox text ?

 

Um use a current OS ;) Not one created 10 some years ago.

 

What hardware are you running on?  Your using a Ancient OS and browser (8) that came out what 4.5 years ago.. Vs a browser version as of last month?

 

Sorry couldn't help my self...



#6 +Frank B.

Frank B.

    Member N° 1,302

  • Tech Issues Solved: 11
  • Joined: 18-September 01
  • Location: Frankfurt, DE
  • OS: OS X 10.10
  • Phone: Sony Xperia Z2

Posted 12 October 2013 - 16:04

Um use a current OS ;) Not one created 10 some years ago.

 

Sorry couldn't help my self...

12 years ago. Were it a child Windows XP would now enter sixth grade.



#7 shozilla

shozilla

    Neowinian Senior

  • Tech Issues Solved: 6
  • Joined: 11-January 09

Posted 12 October 2013 - 16:15

Hum, you might want to put your glasses on when you are using Firefox...  so you will see it clearly..

 

Then take it off for IE. 

 

 

:p



#8 +LimeMaster

LimeMaster

    LippyZillaD Council ( ͡° ͜ʖ ͡°)

  • Tech Issues Solved: 4
  • Joined: 28-August 10
  • OS: Windows 8
  • Phone: Nokia Lumia 920

Posted 12 October 2013 - 16:29   Best Answer

Have you enabled ClearType on Windows XP?



#9 shozilla

shozilla

    Neowinian Senior

  • Tech Issues Solved: 6
  • Joined: 11-January 09

Posted 12 October 2013 - 16:33

Have you enabled ClearType on Windows XP?

 

I forgot about that... It has cleartype on XP.. 

 

Hum, try Lime's suggestion.. and see if it solves your problem.



#10 +LimeMaster

LimeMaster

    LippyZillaD Council ( ͡° ͜ʖ ͡°)

  • Tech Issues Solved: 4
  • Joined: 28-August 10
  • OS: Windows 8
  • Phone: Nokia Lumia 920

Posted 12 October 2013 - 16:37

I forgot about that... It has cleartype on XP..

Yeah, its disabled by default on XP probably because it looked terrible on CRT monitors.



#11 ObiWanToby

ObiWanToby

    Neowinian Senior

  • Joined: 27-April 04
  • Location: Columbus, OH

Posted 12 October 2013 - 16:41

This is the advantage of WDDM and Vista/ 7 / 8. You'll get better rendering with a modern OS. Unsure what to do for XP, as lot of the text smoothing techniques are not available.

 

Use the ClearType Powertoy tuner.



#12 OP Hum

Hum

    totally wAcKed

  • Tech Issues Solved: 10
  • Joined: 05-October 03
  • Location: Odder Space
  • OS: Windows XP, 7

Posted 12 October 2013 - 16:56

Have you enabled ClearType on Windows XP?

This was the only helpful suggestion, and it did help.

 

Thank you. :)

 

right click/Display properties/Appearance tab/Effects button/

Attached Images

  • effects.PNG


#13 shozilla

shozilla

    Neowinian Senior

  • Tech Issues Solved: 6
  • Joined: 11-January 09

Posted 12 October 2013 - 17:00

Congrats, LimeMaster!

 

[pats on your back]



#14 badb0y

badb0y

    I'm Bad!

  • Tech Issues Solved: 1
  • Joined: 10-April 09
  • Location: NY

Posted 12 October 2013 - 17:01

HUM still uses XP? :p



#15 +BudMan

BudMan

    Neowinian Senior

  • Tech Issues Solved: 96
  • Joined: 04-July 02
  • Location: Schaumburg, IL
  • OS: Win7, Vista, 2k3, 2k8, XP, Linux, FreeBSD, OSX, etc. etc.

Posted 12 October 2013 - 17:02

Clearly the "Best Answer" is his then - not yours quoting his.. :rolleyes:

 

Amazing how simple a concept and users still don't get it..

 

Now if nobody suggested cleartype, and you came back and said - hey I found this works, then you could mark your own post as best answer.