Sign in to follow this  
Followers 0

19 posts in this topic

Posted

Hello,

Sometimes (random, can't find anything that seems to set it off) I connect my phone to wifi but I cannot access internet.

PCs on the network can ping my phone

The phone can ping SOME equipment on my network

I cannot ping google.com

I cannot ping 8.8.8.8

I correctly recieve a IP from the DHCP server

Most tests I should do?

Thanks

Share this post


Link to post
Share on other sites

Posted

Try setting your phone with a static IP.

Share this post


Link to post
Share on other sites

Posted

How can you be sure that the outage happens on your phone and not on your router/access point?

 

Are you running a custom ROM on your phone by any chance?

 

I'd suggest that you check your proxy settings, MAC filters, etc, and reset everything.

 

It's also possible that your router can simply get stuck due to overheating or overloading.

Share this post


Link to post
Share on other sites

Posted

Hello,

Try setting your phone with a static IP.

Why? It works on other wifi equipment.

 

 

How can you be sure that the outage happens on your phone and not on your router/access point?

Because it only happens on my phone

 

Are you running a custom ROM on your phone by any chance?

Yes.

 

I'd suggest that you check your proxy settings, MAC filters, etc, and reset everything.

No proxy, MAC filter checked.

 

It's also possible that your router can simply get stuck due to overheating or overloading.

Already checked and restared. Nothing.

Share this post


Link to post
Share on other sites

Posted

Why? It works on other wifi equipment.

This is how you troubleshoot an issue. I've had an issue with a network where it wouldn't automatically connect. Manually setting a IP allowed me to connect without an problem.

Share this post


Link to post
Share on other sites

Posted

Because it only happens on my phone

 

Are you running a custom ROM on your phone by any chance?

 

Yes.

 

If you have other devices on the same wi-fi network working without any symptoms then it's most likely an issue with the phone.

 

Check it for viruses or better yet, wipe it clean.

Share this post


Link to post
Share on other sites

Posted

Here's another thought: try to change your wireless network's channel. Your selected band can be overcrowded and your phone could be extra sensitive to the interferences at the chosen frequency.

Share this post


Link to post
Share on other sites

Posted

Hello,

Why? It works on other wifi equipment.

Just because DHCP is working correctly on other clients doesn't mean it is working correctly on your phone.

 

What IP was your phone being assigned via DHCP out of curiosity?

Share this post


Link to post
Share on other sites

Posted

"I cannot ping 8.8.8.8"

"The phone can ping SOME equipment on my network"

 

So I assume your using 8.8.8.8 for dns?  If you can not ping it is unlikely you can query for dns.  You mention other stuff on your network - what about your router.. This is kind of the biggest one when trying to get off your network and to the internet.

 

Do you have tools on your phone that allow you see your arp table?  Do you have a mac for your routers IP?

 

You mention you are getting dhcp from your router fine - sure?  Its handing you a gateway address?

 

Top issue that comes to mind with wireless and lack of internet access or can not connect to some device they use to be able to connect too like a printer.. Is they are not even on their network - but on the network across the street, etc. ;)

 

Do you have mac filtering enabled on your router?  This can present itself this way - get an IP, but just can not use the internet.

Share this post


Link to post
Share on other sites

Posted

Hello,

This is how you troubleshoot an issue. I've had an issue with a network where it wouldn't automatically connect. Manually setting a IP allowed me to connect without an problem.

The problem is that this occurs today, next 2 days might work, next week might not work, etc. Nothing on the network has changed. So even if setting a manual IP works, its not a solution-

 

 

If you have other devices on the same wi-fi network working without any symptoms then it's most likely an issue with the phone.

 

Check it for viruses or better yet, wipe it clean.

Well, if you can list a virus on Linux that shows symptoms like this, then please show me. Other than that, there is no virus on my phone.

 

 

Here's another thought: try to change your wireless network's channel. Your selected band can be overcrowded and your phone could be extra sensitive to the interferences at the chosen frequency.

Ive checked for this as it might have been a culprit. As far as I can see, there is nothing in the proximity that can cause wireless interference. No other WiFi in the same channel either.

 

 

Just because DHCP is working correctly on other clients doesn't mean it is working correctly on your phone.

 

What IP was your phone being assigned via DHCP out of curiosity?

The IP is a correct one for my network 192.168.100.xx

 

 

"I cannot ping 8.8.8.8"

"The phone can ping SOME equipment on my network"

 

So I assume your using 8.8.8.8 for dns?  If you can not ping it is unlikely you can query for dns.  You mention other stuff on your network - what about your router.. This is kind of the biggest one when trying to get off your network and to the internet.

I pinged it just in case it was a DNS issue and its the only IP I know that is clearly internet accesable.

Damn I feel like a dumbass donkey now: I cant ping my router. Why didnt I check this at first???

Well thats a CLEAR sign that something is wrong and main reason why I cant ping outside networks (Internet).

My access point has the following settings:

192.168.100.20

255.255.255.0

192.168.100.29

Now my default gateway is a AD server. Its DHCP settings are this:

pfom.png

(I know you are going to point this out but IGNORE 10.11.11.6 It has nothing to do with this and has been there 100000000 years ago)

Now Im pretty sure the router setting is correct (192.168.100.100 is my router)

 

Do you have tools on your phone that allow you see your arp table?  Do you have a mac for your routers IP?

Simple, quick and free tools?

Opening a terminal and "arp -v" shows my AD server then my router.

 

You mention you are getting dhcp from your router fine - sure?  Its handing you a gateway address?

"ip addr show" should show me this right?

 

Thank you BudMan

Share this post


Link to post
Share on other sites

Posted

Ok I am trying to understand these settings

 

192.168.100.20
255.255.255.0
192.168.100.29

 

So your AP is pointing to .29 as gateway?  That is normally how you show settings IP, mask, gateway

 

But you mention your router is .100 -- what is this .29 box?

 

And then this makes no sense at all

"Now my default gateway is a AD server"

 

How is your AD server acting as your gateway off your network?  Makes no sense what so ever - and seems your AD is your dhcp and dns - that would be normal in such a setup.. But it would not be the gateway..

 

So in a typical setup

post-14624-0-85468400-1382626706.png

 

So you have your router (gateway off this local network) connected to the internet.. Then hanging off the routers switch ports, or even another switch you would have stuff like your servers (AD DC for example) your client boxes.  Then sure if you have another AP connected to your network wireless would connect to it.

 

So in such a setup your router would be your default gateway 192.168.100.100 as I take your comments.. Now devices would all have IPs on 192.168.100.X/24  But they ALL need to point to 192.168.100.100 as their gateway.. If your phone is talking to either your AP or your AD server as its default gateway your going to have issues.

 

An AP is just a bridge between wireless and wired - that is all.  Only reason you would talk to its IP would be to configure its wireless.  Only reason it would have a gateway address setup is if that AP itself needed to get off your network, for example to set its time via ntp server off your network.  Or if using its web/gui/command line interface you wanted it to check for updates on the internet some where, in that case it would need a dns server it can reach and gateway to get off the local network (your routers IP).  If that is not the case then it has no need to know how to get off your network, ie a gateway address.

 

With AD running on your local network - YES all devices should point to it for DNS, since it knows about your AD..  And using it as dhcp server makes sense - that way your AD will know about its dhcp clients and can register them in your AD dns, etc.  But it would NOT be the gateway.

 

And pointing to other than AD for dns - say that 10 address listed in your dhcp scope there is not good practice.. I would remove that entry unless that IP can be reached??  How not sure since you mention no 10.x networks?  And unless its a dns server for your AD you shouldn't be pointing to it.

 

Are you maybe running multiple dhcp that your not aware of - maybe your AP.. If points to itself via dhcp lease as default gateway then your not going to get to the internet.  But that should not prevent you from pinging your routers IP.  So you might be correct dhcp lease some times, but then others getting lease from some other dhcp server that is not giving you the correct info.

 

Can we get a run down of your network.. And your SURE your ap is setup as AP and not doing nat?  Does my above drawing look like your network?

Share this post


Link to post
Share on other sites

Posted

Hello,

Ok I am trying to understand these settings

 

192.168.100.20

255.255.255.0

192.168.100.29

 

So your AP is pointing to .29 as gateway?  That is normally how you show settings IP, mask, gateway

 

But you mention your router is .100 -- what is this .29 box?

 

And then this makes no sense at all

"Now my default gateway is a AD server"

 

How is your AD server acting as your gateway off your network?  Makes no sense what so ever - and seems your AD is your dhcp and dns - that would be normal in such a setup.. But it would not be the gateway..

My router should be set as the default gateway? Or did I misunderstand you?

 

So in a typical setup

attachicon.giftypicalnetwork.png

Yes, this is the network setup.

 

With AD running on your local network - YES all devices should point to it for DNS, since it knows about your AD..  And using it as dhcp server makes sense - that way your AD will know about its dhcp clients and can register them in your AD dns, etc.  But it would NOT be the gateway.

Are you maybe running multiple dhcp that your not aware of - maybe your AP.. If points to itself via dhcp lease as default gateway then your not going to get to the internet. But that should not prevent you from pinging your routers IP. So you might be correct dhcp lease some times, but then others getting lease from some other dhcp server that is not giving you the correct info.

From the screenshot, It is configured as the DHCP server. The router's DHCP server is turned off (reconfirmed right now)

 

 

Can we get a run down of your network.. And your SURE your ap is setup as AP and not doing nat?  Does my above drawing look like your network?

Yup.

The AP has everything DHCP disabled. Its DNS is 29 then 100. Its gateway is 100 It doesnt have much screen to configure and it is just a AP (1 port LAN)

Your drawing is correct.

Share this post


Link to post
Share on other sites

Posted

"My router should be set as the default gateway? Or did I misunderstand you?"

 

Yes your router should be your default gateway - how is your AD server going to be your default gateway?

 

You stated this

"Now my default gateway is a AD server. Its DHCP settings are this:"

 

How would that ever work?

Share this post


Link to post
Share on other sites

Posted

Hello,

"My router should be set as the default gateway? Or did I misunderstand you?"

 

Yes your router should be your default gateway - how is your AD server going to be your default gateway?

 

You stated this

"Now my default gateway is a AD server. Its DHCP settings are this:"

 

How would that ever work?

Yes, I mistyped the answer. I apoligize.

The AP's gateway is now the router.

Share this post


Link to post
Share on other sites

Posted

Who cares about the AP gateway - like I said unless you have some need for IT to actually connect to the internet it doesn't even need a gateway.  All it does is bridge traffic from wireless to wired.. It has no actual need to get to the internet, and does not use that setting for any wireless clients connected to it..

 

All it does is bridge the connection from the wireless to your wired - your wired dhcp server hands out info to your wireless clients and gives them an IP, and mask and gateway and dns.. 

 

If your wireless client can not talk to the routers IP, then its never getting off the network.  You mentioned that you could not ping your routers IP.. Yeah that is going to be an issue.

 

So you stated you have the mac address of your router in your phones arp table

 

"Opening a terminal and "arp -v" shows my AD server then my router."

 

But you can not ping the router?  Is that mac actually valid?  And other wireless clients can ping your router?  Your not blocking icmp to the routers lan interface for example?

 

If you show a valid mac and you still can not ping, and your not blocking icmp.. Then I have to assume there is something not quite right with the wireless connection itself.  Or you have mac filtering on?

 

What security are you using wpa2, wpa?  AES or tkip..  Have you tried just open?  have you disconnected and reconnected the wireless on the phone - does that solve the issue normally?  Are you using just PSK to auth with or you mention you have AD server are you using enterprise auth to your wireless?

 

What is the exact make and model of this AP -- does it have logging, to see if your wireless client is just deauthing?  Or other errors that might be going on?

 

When it comes down too it, if you can not talk to your router - be it you have valid dhcp info or not doesn't matter since you need to be able to talk to your router to get off the network.

 

So when you can not talk to your router IP, and you still ping your AD servers IP?  Or any other IPs on the wired network?

Share this post


Link to post
Share on other sites

Posted

Hello,

Phone died so Ill charge it tommorow and be able to run some more tests and answer some more questions.

Share this post


Link to post
Share on other sites

Posted

Hello,

But you can not ping the router?  Is that mac actually valid?  And other wireless clients can ping your router?  Your not blocking icmp to the routers lan interface for example?

Yup. Yesterday I could not ping it. But TODAY I can....Im SURE 100% nothing has been done to the network or my phone. Also nothing to interfere it with...

What security are you using wpa2, wpa?  AES or tkip..  Have you tried just open?  have you disconnected and reconnected the wireless on the phone - does that solve the issue normally?  Are you using just PSK to auth with or you mention you have AD server are you using enterprise auth to your wireless?

Security is WPA PSK TKIP.

 

What is the exact make and model of this AP -- does it have logging, to see if your wireless client is just deauthing?  Or other errors that might be going on?

Senao SL-3054CG3 is the AP

Thank you

Share this post


Link to post
Share on other sites

Posted

so today its working

Share this post


Link to post
Share on other sites

Posted

Hello,

so today its working

Yes. Yesterday it was working and no changes were done.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.