6 posts in this topic

Recently after doing the Windows 8.1 upgrade, one issue I had is when I would right click the desktop I would get the little circle for about 15 seconds before I could see the context Menu. After looking online for a solution everyone said to first update your video drivers. So if you haven't done that do that now.

 

For me that didn't work. The right click menu also looked very clean as if there was no 3rd parties attached, so I was confused.

 

Then I downloaded the application "ShellExview"

 

1dey.jpg

 

ShellExview

 

32bit http://www.nirsoft.net/utils/shexview.zip

64bit http://www.nirsoft.net/utils/shexview-x64.zip

 

I started by arranging by Product Name which put all Microsoft and Internet explorer together. Leaving all the 3rd party apps in a group at both the top and the bottom. I then did a mass select of the top half first and then told the ShellExview to disable them. The key is to restart the explorer shell after disabling.

 

 

 

btsx.jpg

 

Locate "Windows Explorer" then click the restart button in the bottom right.

 

 

Then try your right click, if it hangs, renable everything you just got done disabling. Then restart the Windows Explorer shell one more time and then move onto the next set. If you find disabling one of the groups makes your desktop right click menu work again, go through the group and renable each item one by one, restarting the Windows Explorer shell each time until you find the one causing the issues.

 

In my case, the problem was being caused by "NVIDIA Shell Extensions".

 

Hope this helps people experiencing this issue.

1 person likes this

Share this post


Link to post
Share on other sites

Thanks,

I had this problem as soon as I upgraded to Windows 8.1, and the 8.1 update did nothing to fix it. All the other fixes on the internet that I tried failed to work also. I simply altered your technique by merely going through the list and picking the individual items that I thought might be the cause. After 3 tries I found ?music center by J River? to be the culprit in my case.

Share this post


Link to post
Share on other sites

Great looking out! Sometimes, upgrading immediately to a new update can be a hit or miss. People have been very reluctant with Windows 8. Can't wait for 10, though.

Share this post


Link to post
Share on other sites

Thanks for the post. I did as AD White, and the very first selection cured the problem. In my case it was IEContextMenu Class from Norton Internet Security.

Share this post


Link to post
Share on other sites

Thanks a lot for the post. It got fixed. I tried to restart Windows Explorer, it didnt work, But restarted my laptop (excited and less patience).. It worked..solution for the problem is 100% right. . Thank you +warwagon  :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.