Sign in to follow this  
Followers 0
KENNY P

Wireless (AC) Questions

16 posts in this topic

Am I correct in assuming that if I have a 50mb internet connection and a Linksys EA6500 router (802.11ac) that I should be able to achieve 50mbps speed on the speedtest? I do when I'm using a wired connection, but my new MacBook Retina doesn't get more than 12mbps and I have full signal. I have a friend with the same issue at his house and I can't figure out what's going on. Thanks for your help!

Share this post


Link to post
Share on other sites

Your device must be AC ready (I am assuming your MacBook Pro is not the newest model/ or you may think it is?

1 person likes this

Share this post


Link to post
Share on other sites

You have to connect via AC also. Since AC routers can also connect via G or B speeds too you might be connecting on one of those protocols depending on what your MacBook has to connect with. You can't just buy a new router and get fast speeds without also upgrading the device connecting to it.

Share this post


Link to post
Share on other sites

I can say this router is a pos, but you should be getting your speeds.  What speed are you connected to?  Here is mine, You can see the firmware I am on, my wireless speed, and my speed test. I am also on the 5GHz frequency, not the 2.4.  For some reason the 2.4 is slow. Both of these tests are on N, not AC.  If your wireless card can only go to G, well then what exactly are you expecting?  Max speed G will go is about 24Mb/s

post-118098-0-23876200-1383014898.jpg

 

Here is a speed test on my 2.4GHz. 

post-118098-0-16629900-1383015248.jpg

Share this post


Link to post
Share on other sites

Sorry guys, I'm not a beginner... this Mac has built in 802.11ac - and even on my last computer, 802.11n I was experiencing very similar speeds (same router).

Share this post


Link to post
Share on other sites

Check the firmware. I was having issues with the latest and reverted back to what you see. Waiting on dd-wrt for this router to be released. This thing needs constant reboots to keep speed up and to get to interface.

Also make sure you dont have any other wireless devices connected when running speeed test.

Share this post


Link to post
Share on other sites

first thing i would check to see what is going on is the link rate

if you are close to the router you should expect to see 1300mbps link rate

by holding down the Option key and then clicking on the WiFi menu icon

you can see this kind of information

also you need to ensure you are connected over 5GHz as 802.11ac is a 5GHz only protocol.

 

i tend to separate my ssid between 2.4GHz and 5Ghz so I can pick the desired one as the situation requires

You also need 80MHz channel width for 802.11ac 

 

in my own setup with 802.11n 2.4GHz i can get 80mbps+, and 150+ using 5GHz, and this is with a six year old wireless adapter but in close proximity to the access point

Share this post


Link to post
Share on other sites

Sorry guys, I'm not a beginner... this Mac has built in 802.11ac - and even on my last computer, 802.11n I was experiencing very similar speeds (same router).

You would think a non beginner as yourself would know to show their link rate and details of their connection, other than it is "slow" ;)

Telling us its slow means nothing if your not going to post your actual link rate.. I am not a mac guy, but timmyj says you can see your link rate via

"if you are close to the router you should expect to see 1300mbps link rate

by holding down the Option key and then clicking on the WiFi menu icon"

In w7 for example you can view the link rate of your connection with netsh wlan sho int

post-14624-0-08939200-1383047331.png

As you can see from the above example - mine is currently crap.. That is because its my builtin card on my desktop that has no antenna connected to it, and its sitting under my desk. So yeah does show 100% signal.. But its data rate is currently 72, so its not going to rock no 50mbps internet even though its 100% signal and connected at N and a few feet from the router.

What encryption are you using, see the wpa2 CCMP listed -- kind of requirement for good rates.. If say you were using tkip vs aes and or wep your highly unlikely to rock N speeds. Most everything I have seen requires wpa2 aes for N data rates.

Share this post


Link to post
Share on other sites

This is from same room as the router - 5 GHz band is called Testing, and it is AC/N mixed- AC only mode and laptop won't connect

 

Bad router?

 

 

post-446347-0-96024100-1383066404.png

Share this post


Link to post
Share on other sites

Well it.is.showing.that you are on 802.11a, although it is supposed to go to 54Mb/s your limit is around 20 on a good day. This is why you are seeing 12. You have some issues with the wireless card or issues with router setup. Look at firmware and wireless drivers.

Share this post


Link to post
Share on other sites

Firmware is latest on both my laptop and the router. I reflashed router firmware to same version last night, same problem.

 

I have two other 802.11ac computers (both PCs with internal PCI-e cards) and they don't connect to the AC-only mode. I'm guessing a call to Cisco is needed.

Share this post


Link to post
Share on other sites

Here is what I would do in your situation.

Default/factory reset the router.

Do a simple wireless setup only changing the ssid and adding wpa2 with aes and setting the psk.

Leave all other settings default. No Mac filtering, no forcing wireless speeds, etc.

Do not make any other changes to the lan or wireless setup until this basic setup test is performed. Try again with a speed test. If that fails then call cisco.

It should take you less than 10 min to get this working in a default state.

Share this post


Link to post
Share on other sites

first thing i would check to see what is going on is the link rate

if you are close to the router you should expect to see 1300mbps link rate

by holding down the Option key and then clicking on the WiFi menu icon

you can see this kind of information

also you need to ensure you are connected over 5GHz as 802.11ac is a 5GHz only protocol.

 

i tend to separate my ssid between 2.4GHz and 5Ghz so I can pick the desired one as the situation requires

You also need 80MHz channel width for 802.11ac 

 

in my own setup with 802.11n 2.4GHz i can get 80mbps+, and 150+ using 5GHz, and this is with a six year old wireless adapter but in close proximity to the access point

 

1300 Mbs is the theoretical max, don't think any adapters support it yet, will probably get to 802.11d first. 867Mbs is most likely what you will see with a max connection.

Share this post


Link to post
Share on other sites

Here is what I would do in your situation.

Default/factory reset the router.

Do a simple wireless setup only changing the ssid and adding wpa2 with aes and setting the psk.

Leave all other settings default. No Mac filtering, no forcing wireless speeds, etc.

Do not make any other changes to the lan or wireless setup until this basic setup test is performed. Try again with a speed test. If that fails then call cisco.

It should take you less than 10 min to get this working in a default state.

I owe you one bud!

 

I do this for a living... and I've factory reset it multiple times in the past. It has automatic firmware updating which I think is the reason this happened in the first place... but set it up again, took 2 seconds and all 3 devices are working great. One at 1000mbps, one at 800 and one at 750 - couldn't be happier!

 

The n devices on my network I wasn't able to check because the built-in WiFi diagnostic utility never showed the mbps - turns out there is a special item under the "view" menu that will show you the full wireless specs. Even the n devices are 100mbps+ I'm very pleased!!!

Share this post


Link to post
Share on other sites

"One at 1000mbps,"

Yeah OK love that it says that - might as well say 10Ge -- do a file transfer.. What do you see in actual real world speed?

Share this post


Link to post
Share on other sites

also disable automatic update.  that thing will screw you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.