Jump to content



Photo

Debian network connections (icons)

Answered Go to the full post

  • Please log in to reply
7 replies to this topic

#1 cork1958

cork1958

    Neowinian

  • Tech Issues Solved: 2
  • Joined: 04-October 02

Posted 30 October 2013 - 14:04

Here's my next issue with Debian network connections, which is related to my topic here,

http://www.neowin.ne...uter-log/page-2

 

On the computer I'm on now, the network connection icon in top right corner says network connections are disabled, which it is. On another computer with Debian installed, I don't even have that icon, but have the icon that I think wicd put there!

 

I have uninstalled wicd on both computers and set my IP up statically, after learning how from that link above.

 

On this computer, I can't get rid of the icon in top right corner where as I didn't even try to remove it on  other computer, but it's gone! The other computer does still have the icon from wicd and shows the IP I'm connected to. The icon on this computer only says networking disabled.

 

Anybody have any idea what the heck I did? Sound confusing? Does to me! Seeing as how I don't need them, might as well get them out of my sight and maybe I'll leave this stuff alone! :)

 

This isn't really a big issue, so doesn't really matter if I can "fix" it, but curious as to what I might've done without even trying to do anything!

 

Thank you



Best Answer +Karl L. , 31 October 2013 - 14:39

# Use the following command to disable NetworkManager on boot
# if you are using systemd as init.
$ sudo systemctl disable NetworkManager.service

# Use the follow command to disable NetworkManager on boot
# if you are using sysvinit as init.
$ sudo rcconf --off network-manager

 

Another dumb question!

 

How do I know which of those I'm using?

 

At the moment SysVInit is the default in Debian, so if you haven't explicitly switched to systemd, use the latter command. (You may need to install the rcconf package first.)

 

On a side note, systemd has many advantages over SysVInit, and I recommend that you give it a try. It is already the default in many tier-1 Linux distributions (notably Fedora, Arch, and SUSE), and will likely become the default in Debian in a future release (pending the outcome of the current review by the Technical Committee). You can make systemd init in Debian Wheezy by issuing the following commands:

$ sudo apt-get install systemd
$ sudo sed -ri 's|(GRUB_CMDLINE_LINUX_DEFAULT.*=.*)(")(.+)(")|\1\2\3 init=/lib/systemd/systemd\4|' /etc/default/grub
$ sudo update-grub
$ sudo reboot
Go to the full post



#2 +Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 8
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: #!Crunchbang Debian
  • Phone: HTC ONE V

Posted 30 October 2013 - 14:40

What desktop are you running? XFCE, Gnome?



#3 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 30 October 2013 - 23:25

Do you have NetworkManager installed? Some people like WICD, but NetworkManager is the default in most desktop environments. Presumably it is installed on your system unless you explicitly removed it at some point (wicd does not conflict with NetworkManager, although only one or the other can be used to manage a network interface at any point in time).

 

If you wish to remove the entirety of NetworkManager, you can do so as follows:

$ sudo apt-get remove 'network-manager.*'

If you would like to keep NetworkManager installed (so the GNOME or XFCE meta-package is not removed, for example) but not use it, you can also just disable the service.

$ sudo service network-manager stop

# Use the following command to disable NetworkManager on boot
# if you are using systemd as init.
$ sudo systemctl disable NetworkManager.service

# Use the follow command to disable NetworkManager on boot
# if you are using sysvinit as init.
$ sudo rcconf --off network-manager


#4 OP cork1958

cork1958

    Neowinian

  • Tech Issues Solved: 2
  • Joined: 04-October 02

Posted 31 October 2013 - 11:53

I am using XFCE.

 

Yes,

Network manager is installed and disabling it is exactly what I'd like to do, I think!

 

Hey xorangkiller,

Like I asked it that other topic above, what's the sense of having either network manager or wicd installed if neither of them actually set your IP address as static, when you set it up that way? Seems rather stupid, IMO. I would've never thought of having to use the command line to set it up that way if Budman hadn't mentioned that in other topic.

 

Unfortunately,

I try to use Linux to much like Windows where everything needs a UI!



#5 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 31 October 2013 - 13:40

Like I asked it that other topic above, what's the sense of having either network manager or wicd installed if neither of them actually set your IP address as static, when you set it up that way? Seems rather stupid, IMO. I would've never thought of having to use the command line to set it up that way if Budman hadn't mentioned that in other topic.

 

Unfortunately,

I try to use Linux to much like Windows where everything needs a UI!

 

NetworkManager and WICD are each useful in their own right, but they are designed to mask the complexities of the dynamic network connections encountered by most consumers. Consequently, doing something trivial like setting a static address for an Ethernet connection is slightly more complicated than doing the same thing via the command line. However, that does not really answer your question. The most succinct explanation is that the network configuration in /etc/network/interfaces is an alternative to NetworkManager, WICD, and other such network configuration utilities. (Or more properly, those utilities are an alternative to  /etc/network/interfaces.) Since only one network manager can control an interface at once (like I explained earlier), once you configured your network adapter with a static address in your network interfaces configuration file, NetworkManager lost control of it, hence the icon claiming you are not connect to any networks.

 

BudMan recommended that you set a static address using your network interfaces configuration file because complex systems like NetworkManager are overkill for that scenario. He works primarily with servers where the type of configuration he suggested is expected, and anything is abnormal. In most cases where a static IP address is required, I would recommend the same thing. However, you ran into a conflict with NetworkManager because, while your network configuration is by no means unreasonable in certain situations, it is an atypical setup for most desktops (which also happens to be the precise reason why both GNOME and XFCE ship with NetworkManager).



#6 OP cork1958

cork1958

    Neowinian

  • Tech Issues Solved: 2
  • Joined: 04-October 02

Posted 31 October 2013 - 14:21

Awesome explanation!!

Hadn't seen anything close to that in my searches for trying to figure out why that setting wasn't "sticking"

 

Thank you

 

# Use the following command to disable NetworkManager on boot
# if you are using systemd as init.
$ sudo systemctl disable NetworkManager.service

# Use the follow command to disable NetworkManager on boot
# if you are using sysvinit as init.
$ sudo rcconf --off network-manager

 

Another dumb question!

 

How do I know which of those I'm using?



#7 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 31 October 2013 - 14:39   Best Answer

# Use the following command to disable NetworkManager on boot
# if you are using systemd as init.
$ sudo systemctl disable NetworkManager.service

# Use the follow command to disable NetworkManager on boot
# if you are using sysvinit as init.
$ sudo rcconf --off network-manager

 

Another dumb question!

 

How do I know which of those I'm using?

 

At the moment SysVInit is the default in Debian, so if you haven't explicitly switched to systemd, use the latter command. (You may need to install the rcconf package first.)

 

On a side note, systemd has many advantages over SysVInit, and I recommend that you give it a try. It is already the default in many tier-1 Linux distributions (notably Fedora, Arch, and SUSE), and will likely become the default in Debian in a future release (pending the outcome of the current review by the Technical Committee). You can make systemd init in Debian Wheezy by issuing the following commands:

$ sudo apt-get install systemd
$ sudo sed -ri 's|(GRUB_CMDLINE_LINUX_DEFAULT.*=.*)(")(.+)(")|\1\2\3 init=/lib/systemd/systemd\4|' /etc/default/grub
$ sudo update-grub
$ sudo reboot


#8 OP cork1958

cork1958

    Neowinian

  • Tech Issues Solved: 2
  • Joined: 04-October 02

Posted 31 October 2013 - 15:47

Yep,

Had to install rcconf first. I'm going to hold off on that installing systemd for a bit.
 

Thanks again!





Click here to login or here to register to remove this ad, it's free!