Jump to content



Photo

Desktop Issue

Answered Go to the full post

  • Please log in to reply
7 replies to this topic

#1 Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 9
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Mint Debian LMDE
  • Phone: HTC ONE V

Posted 30 October 2013 - 14:55

I'm running Debian Wheezy 7 with XFCE version 4.8

 

I see this on my left screen of desktop:

 

Screenshotfrom2013-10-30094437_zps7f73f0

 

Right screen shows my home folder. Now, I look in my desktop folder, I see nothing, other than my minecraft link, qjoypad, mctest folder and trash. Looks like something is mirroring the info. If I remove it, the files in my home folder are deleted as well. Help?



Best Answer +Karl L. , 31 October 2013 - 03:57

It looks like you found your issue. I suggest that you make your XDG config match mine (and make sure that the folder each XDG_[A-Z]+_DIR references actually exists). You will probably need to log out then log back in (or, alternatively, reboot) for the changes to take effect.

Go to the full post



#2 vetmarkjensen

markjensen

    Linux noob since Red Hat 5.1

  • Joined: 02-October 03
  • Location: Middle Tennessee
  • OS: GNU/Linux
  • Phone: Android and iPhone

Posted 30 October 2013 - 15:44

I can't see anything in those pictures.

Can you open a terminal and do a

ls ~/Desktop/ -al


#3 OP Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 9
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Mint Debian LMDE
  • Phone: HTC ONE V

Posted 30 October 2013 - 15:51

All I see is this:

drwxr-xr-x  4 david david      4096 Oct 13 20:08 .
drwxr-xr-x 72 david david      4096 Oct 30 09:44 ..
drwxr-xr-x  5 david david      4096 Oct  6 11:18 DefinitiveGuidetoClickbank Free Book (MRR license)
-rw-r--r--  1 david david        65 Sep 20 21:57 .directory
-rwxr-xr-x  1 david david     82803 Jul  5 18:57 Minecraft.jar
drwxr-xr-x  3 david david      4096 Oct 13 20:13 minecraft_test_server
-rwxr--r--  1 david david       203 Sep 20 21:58 QJoyPad.desktop
-rwxr-xr-x  1 david david      4431 Sep  2 14:01 thunar-settings.desktop
-rw-r--r--  1 david david 952496274 Sep 30 10:17 VanExp_world.zip

It doesn't account for all the other files. That's what's the issue is here. :huh:



#4 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 30 October 2013 - 23:10

Based on your screenshot it looks like everything in your home folder and in your desktop folder is being displayed on your desktop. XFCE seems to respect XDG, so what is your XDG_DESKTOP_DIR set to? For reference, mine is as follows:

$ cat ~/.config/user-dirs.dirs 
XDG_PUBLICSHARE_DIR="$HOME/Public"
XDG_DOWNLOAD_DIR="$HOME/Download"
XDG_MUSIC_DIR="$HOME/Music"
XDG_VIDEOS_DIR="$HOME/Videos"
XDG_DESKTOP_DIR="$HOME/Desktop"
XDG_DOCUMENTS_DIR="$HOME/Documents"
XDG_TEMPLATES_DIR="$HOME/Templates"
XDG_PICTURES_DIR="$HOME/Pictures"


#5 OP Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 9
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Mint Debian LMDE
  • Phone: HTC ONE V

Posted 31 October 2013 - 01:09

XDG_DOWNLOAD_DIR="$HOME/downloads"
XDG_DOCUMENTS_DIR="$HOME/documents"
XDG_MUSIC_DIR="$HOME/"
XDG_PICTURES_DIR="$HOME/"
XDG_VIDEOS_DIR="$HOME/"
XDG_DESKTOP_DIR="$HOME/"
XDG_TEMPLATES_DIR="$HOME/"
XDG_PUBLICSHARE_DIR="$HOME/"

Could that be the issue? This never happened before...



#6 +Karl L.

Karl L.

    xorangekiller

  • Tech Issues Solved: 15
  • Joined: 24-January 09
  • Location: Virginia, USA
  • OS: Debian Testing

Posted 31 October 2013 - 03:57   Best Answer

It looks like you found your issue. I suggest that you make your XDG config match mine (and make sure that the folder each XDG_[A-Z]+_DIR references actually exists). You will probably need to log out then log back in (or, alternatively, reboot) for the changes to take effect.



#7 OP Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 9
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Mint Debian LMDE
  • Phone: HTC ONE V

Posted 31 October 2013 - 12:56

Thanks, Orange! All fixed now. :D



#8 Haggis

Haggis

    Neowinian Senior

  • Tech Issues Solved: 10
  • Joined: 13-June 07
  • Location: Near Stirling, Scotland
  • OS: Debian 7
  • Phone: Samsung Galaxy S3 LTE (i9305)

Posted 31 October 2013 - 13:24

It looks like you found your issue. I suggest that you make your XDG config match mine (and make sure that the folder each XDG_[A-Z]+_DIR references actually exists). You will probably need to log out then log back in (or, alternatively, reboot) for the changes to take effect.

 

 

you sir are a legend lol