Jump to content



Photo

Users folder getting shared by default


  • Please log in to reply
4 replies to this topic

#1 murderdoll

murderdoll

    PROTECTED Neowinian

  • Joined: 02-September 04
  • Location: \\127.0.0.1

Posted 03 November 2013 - 13:01

Hello,

 

As you may already know, when you start sharing folders on LAN, the Users folder gets shared automatically.

 

In Windows 8 if you un-share the Users folder, it will get shared again automatically at some point in the future. Now I can remove permissions from the Sharing tab and nobody can access the folder but still I need to get rid of this, I don't want 'Users' folder to show for anyone trying to browse my shares.

 

I've searched a lot and I couldn't find anything that works so now I'm seeking help from Neowin!

 

Thanks,

 




#2 TPreston

TPreston

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 18-July 12
  • Location: Ireland
  • OS: Windows 8.1 Enterprise & Server 2012R2/08R2 Datacenter
  • Phone: Nokia Lumia 1520

Posted 03 November 2013 - 15:36

Disable the "server" service on your clients, If you are storing your content on a home server you don't need smb shares on them anyway.

#3 OP murderdoll

murderdoll

    PROTECTED Neowinian

  • Joined: 02-September 04
  • Location: \\127.0.0.1

Posted 03 November 2013 - 19:25

@TPreston, Thanks for the information. Can you elaborate on what will I lose if I disable the Lanman service? I've tried to read a bit about but I'm not entirely sure if other clients will still be able to access me?

 

Also I've read on another forum that disabling the 'Homegroup' would get rid of the 'Users' folder being shared.

 

I'm still collecting options and I'll begin trying them out soon.

 

Thanks



#4 Richard C.

Richard C.

    Neowinian Senior

  • Joined: 15-April 05
  • Location: Around
  • OS: Windows 8.1 Pro & Mac OSX
  • Phone: iPhone 5

Posted 07 November 2013 - 15:17

I've found that simply disabling "Simple Sharing", then removing the share from Computer Managment MMC snap-in rather than using the "Shares" tab on the folder seems to work pretty well.

 

folders.png

 

shares.png

 

Did this the day after installing 8.1, nothing changed yet. I don't have homegroup disabled but I've also not set one up



#5 OP murderdoll

murderdoll

    PROTECTED Neowinian

  • Joined: 02-September 04
  • Location: \\127.0.0.1

Posted 08 November 2013 - 16:20

I've disabled Homegroup Listener/Provider from the services (basically no more homegroups) and it's good, no more sharing of C:\Users