Jump to content



Photo

Windows 8.1 not seeing all hard drives

win8.1

  • Please log in to reply
7 replies to this topic

#1 Enron

Enron

    Windows for Workgroups

  • Tech Issues Solved: 1
  • Joined: 30-May 11
  • OS: Windows 8.1 U1
  • Phone: Nokia Lumia 900

Posted 21 November 2013 - 23:23

I'm having trouble with one of my Windows 8.1 PCs. It has 4 internal hard drives and only two of them are showing up in Windows Explorer. I see all of them in Disk Management but it gives me an error if I try to give them a drive letter:

 

diskserror.png

 

It also doesn't mount external drives when I plug them in. They were all working before the upgrade in Windows 7. This PC has an Asus P8Z77-V DELUXE motherboard if that helps any. I can confirm all the drives themselves are good.

 

disks.png




#2 Roger H.

Roger H.

    Neowinian Senior

  • Tech Issues Solved: 20
  • Joined: 18-August 01
  • Location: Germany
  • OS: Windows 8.1
  • Phone: Nexus 5

Posted 21 November 2013 - 23:41

Is that system in UEFI mode? I'm guessing they are from a UEFI system with secure boot and now you aren't on that system anymore?

#3 John.D

John.D

    Neowinian

  • Tech Issues Solved: 2
  • Joined: 10-November 09

Posted 21 November 2013 - 23:47

 Some people have fixed that error by doing this

 

Even tho thats for server it probably applies to other versions



#4 Hum

Hum

    totally wAcKed

  • Tech Issues Solved: 5
  • Joined: 05-October 03
  • Location: Odder Space
  • OS: Windows XP, 7

Posted 21 November 2013 - 23:55

Can't you disconnect all drives, except C, then add them back one by one, in the order you want them in ?



#5 OP Enron

Enron

    Windows for Workgroups

  • Tech Issues Solved: 1
  • Joined: 30-May 11
  • OS: Windows 8.1 U1
  • Phone: Nokia Lumia 900

Posted 22 November 2013 - 00:53

Is that system in UEFI mode? I'm guessing they are from a UEFI system with secure boot and now you aren't on that system anymore?

 

I'm not sure. I don't remember seeing any UEFI or secure boot stuff in my BIOS settings.

 

 

Also I don't want to format the disks. They have stuff on them.



#6 Riva

Riva

    Neowinian

  • Tech Issues Solved: 1
  • Joined: 11-February 07

Posted 22 November 2013 - 01:12

I'm not sure. I don't remember seeing any UEFI or secure boot stuff in my BIOS settings.

 

 

Also I don't want to format the disks. They have stuff on them.

Your PC is UEFI. Try enabling the CSM option under Boot



#7 OP Enron

Enron

    Windows for Workgroups

  • Tech Issues Solved: 1
  • Joined: 30-May 11
  • OS: Windows 8.1 U1
  • Phone: Nokia Lumia 900

Posted 23 November 2013 - 19:28

Your PC is UEFI. Try enabling the CSM option under Boot

 

Ok, I checked and all the Secure Boot stuff is on.

 

I also am able to access the drives if I use a partition tool to give them a drive letter, but I have to do it every time I restart Windows.



#8 Riva

Riva

    Neowinian

  • Tech Issues Solved: 1
  • Joined: 11-February 07

Posted 23 November 2013 - 19:48

Ok, I checked and all the Secure Boot stuff is on.

 

I also am able to access the drives if I use a partition tool to give them a drive letter, but I have to do it every time I restart Windows.

 

I am guessing your boot sector is on another disk than the one where windows is installed. I would leave secureboot on and CSM off. Unplug all disks, clean install windows, then plug the other discs in. When booting from the windows install disc, ensure it is the UEFI mode version of it. If you press F8 during boot you will get a dialog showing you available disks, you will see your optical appearing twice; normal mode and UEFI mode.

I have a similar config as yours but I run the P9X79 Deluxe motherboard.





Click here to login or here to register to remove this ad, it's free!