Jump to content



Photo

Mounting Issue


  • Please log in to reply
6 replies to this topic

#1 +Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 9
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Mint Debian LMDE
  • Phone: HTC ONE V

Posted 23 November 2013 - 17:29

Whenever I restart my PC, once a week maybe, I get this error when mounting my DVD Library drive:

Error mounting: mount exited with exit code 1: helper failed with:
Unprivileged user can not mount NTFS block devices using the external FUSE
library. Either mount the volume as root, or rebuild NTFS-3G with integrated
FUSE support and make it setuid root. Please see more information at
http://tuxera.com/community/ntfs-3g-faq/#unprivileged

So, it can't automount it? Ok, if I type this in terminal:

sudo mount /dev/sdb1 /media/DVD_Library

All is well, I can access the drive and everything...  :huh:




#2 +LambdaLambdaLambdaFn

LambdaLambdaLambdaFn

    Neowinian

  • Joined: 13-November 13

Posted 23 November 2013 - 18:20

What's the content of your fstab?



#3 OP +Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 9
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Mint Debian LMDE
  • Phone: HTC ONE V

Posted 23 November 2013 - 21:18

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=18c3ecb8-0f1e-4995-9bf1-1dab8a191424 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=b583b2ed-ba06-471e-b4dc-457663e50a0a none            swap    sw              0       0
/dev/sdb1       /media/usb0     auto    rw,user,noauto  0       0
/dev/sdb2       /media/usb1     auto    rw,user,noauto  0       0

Not perfect, I know...



#4 Growled

Growled

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 17-December 08
  • Location: USA

Posted 30 November 2013 - 03:14

My fstab for a NTFS device looks like this:

 

UUID=9C5C73345C730872 /media/sdb1 ntfs-3g auto,users,noexec,uid=1000,gid=users,dmask=002,fmask=113,relatime 0 0

 

It mounts on startup. Otherwise, I have to mount it as root like you do.



#5 KenJackson

KenJackson

    Neowinian

  • Joined: 17-May 08
  • Location: Maryland, USA

Posted 30 November 2013 - 12:40

It's not clear if you're saying the system tries to mount the DVD which fails, or if you try to mount it as a regular user after boot.

 

I see you've specified the rw option in fstab.  Is the DVD writeable?  If not, it should be ro.

 

You can find the UUID, if you want to use it in fstab, with either of these commands:

sudo blkid /dev/sdb1
ls -l /dev/disk/by-uuid | grep sdb1

Also note that the word auto is used in the two fstab files differently.  In the first, it's a filesystem type.  The system apparently guesses the actual filesystem correctly, but it would be better to specify it explicitely (ntfs-3g) instead.  In the second fstab, it's an option, which which should be the default, but it wouldn't hurt to add it.  Or you could use option noauto to prevent the system from tying to mount it at boot.



#6 OP +Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 9
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Mint Debian LMDE
  • Phone: HTC ONE V

Posted 30 November 2013 - 15:00

Ken, this isn't a DVD drive, it is a HDD, Western Digital Black 1.5TB. I save backups of all my DVDs on there.



#7 Haggis

Haggis

    Neowinian Senior

  • Tech Issues Solved: 9
  • Joined: 13-June 07
  • Location: Near Stirling, Scotland
  • OS: Debian 7
  • Phone: Samsung Galaxy S3 LTE (i9305)

Posted 30 November 2013 - 16:00

  • Download the source for the latest NTFS-3G from tuxera: http://www.tuxera.co...fs-3g-download/
  • Extract it anywhere, then switch to the new directory:
    Code:

    tar xvzf ntfs-3g-2011.1.15.tgz
    Code:

    cd ntfs-3g-2011.1.15/
  • Run the configure command with the argument --with-fuse=internal
    Code:

    ./configure --with-fuse=internal
  • Execute make
  • When make completes, execute make install with sudo
    Code:

    sudo make install

If everything worked as expected, you should have a new ntfs-3g binary in /bin. The one installed by the package manager was in /usr/bin. This new one is the one you have to setuid root for. Note that there's no need to setgid root.

Code:

sudo chmod 4755 `which ntfs-3g`

The final step is to ensure that your normal user has access to the device. By default, disk devices are owned by the root user, associated with the "disk" group, and allow read/write access to the owner and the group. So, you'll need to append your username to the line defining the disk group in /etc/group. The line looks like this:

Code:
disk:x:6:ghodmode

That part after the last colon is a comma-separated list of usernames that are in the disk group. Naturally, you have to use sudo to modify this file.

Finally, log out and back in so that your user's new group will be acknowledged and you'll be able to mount your partition as a normal user.

I have an entry in /etc/fstab to make mounting easier. It's usually /dev/sde1 on my system, but since my device is an external USB drive, it could get a different device file name. So, I got the UUID from /dev/disk/by-uuid and used that in my fstab.

Code:

UUID=12C23AD8C23AC031 /mnt/My\040Book ntfs defaults,users,noauto 0 0




Click here to login or here to register to remove this ad, it's free!