Jump to content



Photo

Speed drops inside VM guest (winxp)

Answered Go to the full post

  • Please log in to reply
7 replies to this topic

#1 Koshur

Koshur

    Neowite

  • Tech Issues Solved: 1
  • Joined: 08-February 12
  • OS: Win7, Ubuntu 12.04LTS, PinguyOS 11.10, Backtrack 5R2, Zorin OS

Posted 07 December 2013 - 14:09

Hey, 

 

I've recently noticed a drop in speed when i run speedtest.net inside the VM guest OS. 

 

On Host (ubunutu): ping - 31ms, Download- 1.9Mbps (ive got a 2mbps plan from this ISP)

On Guest (win xp) : ping - 21ms, Download - 1.2 Mbps

 

VM is in bridge mode. 

 

Screenshot from 2013-12-07 19:34:24.png  Screenshot from 2013-12-07 19:36:02.png

 

 

Thanks

 



Best Answer +BudMan , 08 December 2013 - 13:21

So do you understand what nat mode means? And what bridge mode means? Lets go over it real quick so we are sure everyone is on the same page.

So you have host nic tied to your network.. Lets say this network is 192.168.1.0/24, your router to the internet is say 192.168.1.1 -- it hands out dhcp .100 to .150.. So your Host box network interface is say 192.168.1.100.

(host)192.168.1.100 -- switch -- 192.168.1.1(router)publicIP --- internet

Now when you bridge your vms to your host nic, they just use a different mac, but are on the same physical network.. So your VM would send out dhcp and your router would see the traffic and say hey, you are .101

so you have this

(vm)192.168.1.101
(host)192.168.1.100 -- switch -- 192.168.1.1(router)publicIP --- internet

To the router, your vm is just like any physical box on this 192.168.1.0/24 network. This is normally how you would setup vms, easy not complicated - allows your vms to use anything on your network, allows your real boxes to talk to vms, etc. etc. etc..

Now in NAT mode -- you just turned your host into basically your internet router with what network?? If you used 192.168.1.0/24 on your nat side.. All kinds of problems, so you need to use a different network than what your real network is. So get something like this.

(vm)192.168.2.100 -VMnetwork- 192.168.2.1(host)192.168.1.100 -- switch -- 192.168.1.1(router)publicIP --- internet

Now boxes on your physical network would need to know if they want to talk to 192.168.2.100 that they need to talk to 192.168.1.100, and you would have to create port forwards on your host, just like you would on your internet router.

This is normally not very good way to setup vms that want to talk to your physical network, unless you want some sort of isolation like you do to the internet, or you can only get 1 IP on this network your host is connected too, etc. It is more complicated that bridging.

Now for this to work, your vm software needs to provide dhcp services.. Have you turned them on or off? You need to make sure that your VM is connected to the correct vmnetwork that provides dhcp and is in turned connected to your physical network. You need to make sure that your nat network is not the same as your physical network. There is not overlap with masks, etc.

If when you go to nat mode your vm says he can not get an address, then you need to look to your vm software that dhcp services are enabled, etc.. This mode while it has uses, is prob not something you want to do for normal vms.. But is most likely your only option for having that vm use your VPN connection since your VPN connection is only going to give you 1 IP address in that vpn network, etc.

So how many boxes are you going to want to use this vpn? Why is your host connecting and not your guest vm? If you want your host and guest to both use it - why not put the vpn connection on your router, and then use policy based routing to say which boxes on your network use the vpn connection?

As to why you saw slower vm speedtest when you were bridging your host wireless? Could be lost of reasons - different driver for the bridging in the vm software? Your wireless network was also doing traffic for the host you were not aware of our other machines, remember wireless is shared, etc. Could be different network setups on the vm -- to the vm it was connected at gig with wire for all its OS knows.. And your vm software was then sending that to a wireless network with much less available bandwidth than gig, and then to a internet connection that is only 2mbps vs 1000. Could be some combination of that, etc. To troubleshoot that I would start by first testing speed from guest to just something local on your network - take the internet out of the equation. What kind of speeds do you get there? If that is normal, then look to see what else is going on with the wireless network or what the host was doing on the wireless network while the vm was doing the speedtest, etc.

I would really suggest though if using a host for vm, that host be connected via wire vis wireless if possible.

So what exact vm software are you using? Player for linux? What version? And your hosting on ubuntu 12.? Or did you update to 13 yet? Go to the full post



#2 Brian M.

Brian M.

    Neowinian Senior

  • Tech Issues Solved: 10
  • Joined: 07-January 05
  • Location: London, UK

Posted 07 December 2013 - 14:32

Remember speediest.net is Flash.

Are the speeds comparable when you download a file via HTTP?

#3 +BudMan

BudMan

    Neowinian Senior

  • Tech Issues Solved: 93
  • Joined: 04-July 02
  • Location: Schaumburg, IL
  • OS: Win7, Vista, 2k3, 2k8, XP, Linux, FreeBSD, OSX, etc. etc.

Posted 07 December 2013 - 14:45

So you host is connected to your network via wireless? Use a wire, what do your tests look then?

#4 OP Koshur

Koshur

    Neowite

  • Tech Issues Solved: 1
  • Joined: 08-February 12
  • OS: Win7, Ubuntu 12.04LTS, PinguyOS 11.10, Backtrack 5R2, Zorin OS

Posted 08 December 2013 - 10:50

ok. so I'm wired up with a LAN cable now. Turned off the wifi from physical switch.

 

Its 1.9Mbps on host and 1.9Mbps on guest as well! Looks like wifi is the issue. Why would that be? It has been working fine since 2 years. I didn't change any wifi settings on router level or on clients (host or guest). While doing tests I was sitting right next to router on table.

 

On a separate note, i just noticed that I'm not able to go online within guest when i switch to NAT mode. The status is stuck at "acquiring network address" and eventually "limited or no connectivity". I tried enabling and disabling the Vmware Net Adapter. Didn't help. 

Host network is on xxx.xxx.1.1 network.

 

Screenshot from 2013-12-08 16:15:42.png


Edited by Koshur, 08 December 2013 - 10:51.


#5 +BudMan

BudMan

    Neowinian Senior

  • Tech Issues Solved: 93
  • Joined: 04-July 02
  • Location: Schaumburg, IL
  • OS: Win7, Vista, 2k3, 2k8, XP, Linux, FreeBSD, OSX, etc. etc.

Posted 08 December 2013 - 13:21   Best Answer

So do you understand what nat mode means? And what bridge mode means? Lets go over it real quick so we are sure everyone is on the same page.

So you have host nic tied to your network.. Lets say this network is 192.168.1.0/24, your router to the internet is say 192.168.1.1 -- it hands out dhcp .100 to .150.. So your Host box network interface is say 192.168.1.100.

(host)192.168.1.100 -- switch -- 192.168.1.1(router)publicIP --- internet

Now when you bridge your vms to your host nic, they just use a different mac, but are on the same physical network.. So your VM would send out dhcp and your router would see the traffic and say hey, you are .101

so you have this

(vm)192.168.1.101
(host)192.168.1.100 -- switch -- 192.168.1.1(router)publicIP --- internet

To the router, your vm is just like any physical box on this 192.168.1.0/24 network. This is normally how you would setup vms, easy not complicated - allows your vms to use anything on your network, allows your real boxes to talk to vms, etc. etc. etc..

Now in NAT mode -- you just turned your host into basically your internet router with what network?? If you used 192.168.1.0/24 on your nat side.. All kinds of problems, so you need to use a different network than what your real network is. So get something like this.

(vm)192.168.2.100 -VMnetwork- 192.168.2.1(host)192.168.1.100 -- switch -- 192.168.1.1(router)publicIP --- internet

Now boxes on your physical network would need to know if they want to talk to 192.168.2.100 that they need to talk to 192.168.1.100, and you would have to create port forwards on your host, just like you would on your internet router.

This is normally not very good way to setup vms that want to talk to your physical network, unless you want some sort of isolation like you do to the internet, or you can only get 1 IP on this network your host is connected too, etc. It is more complicated that bridging.

Now for this to work, your vm software needs to provide dhcp services.. Have you turned them on or off? You need to make sure that your VM is connected to the correct vmnetwork that provides dhcp and is in turned connected to your physical network. You need to make sure that your nat network is not the same as your physical network. There is not overlap with masks, etc.

If when you go to nat mode your vm says he can not get an address, then you need to look to your vm software that dhcp services are enabled, etc.. This mode while it has uses, is prob not something you want to do for normal vms.. But is most likely your only option for having that vm use your VPN connection since your VPN connection is only going to give you 1 IP address in that vpn network, etc.

So how many boxes are you going to want to use this vpn? Why is your host connecting and not your guest vm? If you want your host and guest to both use it - why not put the vpn connection on your router, and then use policy based routing to say which boxes on your network use the vpn connection?

As to why you saw slower vm speedtest when you were bridging your host wireless? Could be lost of reasons - different driver for the bridging in the vm software? Your wireless network was also doing traffic for the host you were not aware of our other machines, remember wireless is shared, etc. Could be different network setups on the vm -- to the vm it was connected at gig with wire for all its OS knows.. And your vm software was then sending that to a wireless network with much less available bandwidth than gig, and then to a internet connection that is only 2mbps vs 1000. Could be some combination of that, etc. To troubleshoot that I would start by first testing speed from guest to just something local on your network - take the internet out of the equation. What kind of speeds do you get there? If that is normal, then look to see what else is going on with the wireless network or what the host was doing on the wireless network while the vm was doing the speedtest, etc.

I would really suggest though if using a host for vm, that host be connected via wire vis wireless if possible.

So what exact vm software are you using? Player for linux? What version? And your hosting on ubuntu 12.? Or did you update to 13 yet?

#6 OP Koshur

Koshur

    Neowite

  • Tech Issues Solved: 1
  • Joined: 08-February 12
  • OS: Win7, Ubuntu 12.04LTS, PinguyOS 11.10, Backtrack 5R2, Zorin OS

Posted 12 December 2013 - 14:44

Wow. thanks for such a nice explanation. I've got it setup like you told: http://imm.io/1m6EI

 

(vm)192.168.2.128 -VMnetwork- 192.168.2.1(host)192.168.1.100 -- switch -- 192.168.1.1(router)publicIP --- internet 

 

I can go online now and can connect to vpn as well. I'm be using only one VM guest for this. I turned on the DHCP from virtual network editor to dish out 192.168.2.xx range. and BAMMM.. i've got the same VPN on my host and guest too!!!  (Y)

 

" If you want your host and guest to both use it - why not put the vpn connection on your router, and then use policy based routing to say which boxes on your network use the vpn connection?"  

I'd love to do this, how can i setup this on my ADSL TP-link W8968?. 

 

So what exact vm software are you using? Player for linux? What version? And your hosting on ubuntu 12.? Or did you update to 13 yet?

I'm using VMWare workstation 9. Ubuntu 12.04LTS, didn't move to 13.10 yet.

 

Cheers for BUDMAN  :santa:  :pint:  :pint:



#7 +BudMan

BudMan

    Neowinian Senior

  • Tech Issues Solved: 93
  • Joined: 04-July 02
  • Location: Schaumburg, IL
  • OS: Win7, Vista, 2k3, 2k8, XP, Linux, FreeBSD, OSX, etc. etc.

Posted 12 December 2013 - 14:54

So TP-link W8968 is gateway (modem/router combo) - yeah doubt that runs 3rd party firmware. And would be flabbergasted if native had any sort of vpn client option or allowed for policy based routing.

Now if could run dd-wrt for example
http://www.dd-wrt.co...y_Based_Routing

Or say using a routing/firewall distro like pfsense, ipcop, m0n0wall, smoothwall, etc. etc.. Then you could prob do policy based routing.

But with native firmware on a gateway - I find it highly unlikely to be able to do that.

#8 OP Koshur

Koshur

    Neowite

  • Tech Issues Solved: 1
  • Joined: 08-February 12
  • OS: Win7, Ubuntu 12.04LTS, PinguyOS 11.10, Backtrack 5R2, Zorin OS

Posted 25 December 2013 - 08:19

Budman, 

 

Sorry, that I'm still posting stuff on Christmas.. 

 

I was recently trying to change my above NAT network from 192.168.2.xxx to 10.0.0.1 (coz i'm testing AD concepts and user policies, i've got a 20008 R2 running) and i got into this issue http://chakra-projec...pic.php?id=8579. I can't see to get it working again. The fix that is mentioned in the link, i don't get the first step. Need help, when you're back from celebrations :)

 

Merry Christmas and a happy new year!! \m/

 

Cheers

MArk