Jump to content



Photo

Come on FireFox, i am not American!


  • Please log in to reply
5 replies to this topic

#1 Technique

Technique

    Technical Difficulties

  • Joined: 09-October 03
  • Location: England

Posted 21 December 2013 - 13:47

When typing, FireFox keeps trying to tell me i am spelling colour wrong, neighbour wrong etc. Clearly not noticing i am from England & speak & spell like an English person!

 

I have gone Tools>Options>Content>Languages & removed US English & put in UK English.

 

I went to Add Ons & installed "British English Dictionary Updated 1.19.5" yet i'm still being told to spell as color & neighbor.

 

How can i put this right?




#2 Zlip792

Zlip792

    Neowinian

  • Tech Issues Solved: 4
  • Joined: 31-October 10
  • Location: Pakistan
  • OS: Windows 8.1 Pro 64-bit
  • Phone: Nokia C3-00 (8.70 firmware) It sucks!!!

Posted 21 December 2013 - 13:50

Why not you try English (British) build?

 

From here: https://www.mozilla....US/firefox/all/



#3 Max Norris

Max Norris

    Neowinian Senior

  • Tech Issues Solved: 10
  • Joined: 20-February 11
  • OS: Windows, *Nix

Posted 21 December 2013 - 13:53

Did you tell Firefox to use that new dictionary?  Right click, under "check spelling" you should have an option to change languages. Just because it's installed doesnt mean it's being used, you can have more than one.  Random example, I don't actually speak that, just installed as a demo:

 

1d4j.png



#4 OP Technique

Technique

    Technical Difficulties

  • Joined: 09-October 03
  • Location: England

Posted 21 December 2013 - 14:07

Where am i supposed to right click out of interest? I've left clicked & right clicked all over the place & can't see that.



#5 Max Norris

Max Norris

    Neowinian Senior

  • Tech Issues Solved: 10
  • Joined: 20-February 11
  • OS: Windows, *Nix

Posted 21 December 2013 - 14:08

Try it in an edit box, doesn't always appear, may need to highlight some text.  Could always edit spellchecker.dictionary in about:config as well.



#6 +Majesticmerc

Majesticmerc

    Resident Idealist

  • Tech Issues Solved: 5
  • Joined: 24-August 05
  • Location: United Kingdom
  • OS: Arch Linux / Win 7
  • Phone: HTC One X

Posted 21 December 2013 - 14:30

Where am i supposed to right click out of interest? I've left clicked & right clicked all over the place & can't see that.


Assuming that you've got the British English dictionary installed. You can do it right on this page.

1) Go to the quick reply box at the bottom.
2) Switch to "basic text mode" in the reply box by clicking on the top left icon (the one that looks like a light switch).
3) Right click inside the reply box
4) Choose the "Language" option in the right-click menu
5) Choose "English (United Kingdom)"



Click here to login or here to register to remove this ad, it's free!