Sign in to follow this  
Followers 0

Windows 8.1 Sleep Mode not working

22 posts in this topic

Posted

Hi All

 

Auto Sleep Mode not working for some reason on my Windows 8.1 Pro 64bit System,  System software is WIndows 8.1 Pro 64bit, Avast Antivirus 9.0.2011,  (willing to switch to Windows Defender if need to),  Just want sleep mode to work properly for the time I set it for---Tried 1 hour failed, tried 30 minutes mode, failed so far.  

 

 

Any advice welcomed.

 

 

P.S. I prefer using sleep mode since I get right back on it soon as I wake up in the morning...Currently set for 30 minutes, if that isn't good for the hard drive, I can set for longer time, or configure it different, just as long as it works properly

 

 

Share this post


Link to post
Share on other sites

Posted

(edited)

 

Run cmd by Winkey+R, or right-click bottom-left corner in Win 8 Desktop and type in powercfg /? to see some troubleshooting options.

 

Maybe powercfg /requests to see what driver or application is requesting power.

 

check this thread (kind of long): http://social.technet.microsoft.com/Forums/en-US/a4a7cc99-a49a-42a8-b2af-aff748623c34/windows-8-does-not-go-to-sleep-how-to-identify-the-deviceapp-preventing-sleep

 

Running powercfg /energy, you can get a report of devices not entering suspend state. For example the report on mine says about my VIA motherboard audio: "The device or driver has made a request to prevent the system from automatically entering sleep."

 

When you run powercfg /energy report, copy the html report from c:\windows\sytem32 to your desktop because it won't open from there.

Share this post


Link to post
Share on other sites

Posted

Like Grunsprek said, open a Command Prompt as an Administrator and type 'powercfg -requests' and tell us or post a screen shot of what it says. Should give an idea of what's preventing sleep and help figure out how to fix it.

Share this post


Link to post
Share on other sites

Posted

Here is the Energy Report if it lets me reply this time

 

 

Well nothing is pasting lol for some reason

 

may end up having to run sfc /scannow again from boot

 

 

USB Suspend: Device not entering selective Suspend is what it said

 

just had to run sfc scan now recently to fix a green video screen on video playback due to some corrupt files, prior to that sleep mode was working fine..just recently switched to Avast Antivirus from Windows Defender,  (Also did a refresh install recently to fix a few issues)

 

 

couldn't even reply til I disabled Avast's online security plugin

 

Perhaps I should do a clean install once I get my faster internet going, and upgrade to 8.1 the proper way thru the Windows Store from 8.0, last upgrade used an ISO got from RL friend, and installed it that way.

Share this post


Link to post
Share on other sites

Posted

Go to your Control Panel (the normal one, not the one in Metro) and search for HomeGroup. Leave the homegroup, make sure the 'sleep after...' option is set in Power options and see if that changes anything.

Share this post


Link to post
Share on other sites

Posted

Currently is No Homegroup on the network, tested 30 minute sleep setting before, didn't change anything...still looking into what the cause fully could be, and going from there at this point. 

 

Tired of trouble shooting PC problems already...Either i'll leave avast in, and see if PC will sleep after I do offline (boot) sfc /scannow, and see if it works better after that, or wait til my cable internet is installed, and do a completely clean install of 8.0, and then upgrade to 8.1 thru the Store properly--(time consuming) but not sure what else to do at this point.  

 

Could be avast interfering I suppose, but I don't know for sure...Sleep mode was working properly a few weeks ago, but had to do refresh install since all video playback screen was all green

Share this post


Link to post
Share on other sites

Posted

Here is the Energy Report if it lets me reply this time

Well nothing is pasting lol for some reason

There is a little switch icon in the reply editor at the top left corner of the toolbar. Toggle that and you should be able to paste content in plain text mode.

Share this post


Link to post
Share on other sites

Posted

try disabling ipv6 for the network connection , was the only thing that fixed the sleep problem for me.

Share this post


Link to post
Share on other sites

Posted

tried that, didn't still paste at all....replies seem to be working better now though, just still can't paste anything, why I don't know

 

There is a little switch icon in the reply editor at the top left corner of the toolbar. Toggle that and you should be able to paste content in plain text mode.

Share this post


Link to post
Share on other sites

Posted

This might sound a bit silly but are you sure you're copying successfully.  You could always paste into Notepad before posting to confirm that the clipboard is populated :)

Share this post


Link to post
Share on other sites

Posted

From my experience, Sleep Mode was often interfered by various services which mimic or supervise inputs.  In this case, Avast (with all bells and whistles activated) is a possible culprit.  The best resort is by process of elimination:

 

My suggestion: disconnect from Internet, uninstall Avast, reboot... then go into Desktop view and walk away from the computer.

 

(Yeah, this is a lengthly process but it's necessary to be 100% certain.)

Share this post


Link to post
Share on other sites

Posted

Both my windows 8.1 PC's seem to randomly wake themselves up at random times after going to sleep.

Share this post


Link to post
Share on other sites

Posted

Well with Avast Removed, and IPv6 Disabled, Sleep Mode works fine now--and seems to have stayed asleep thus far.     Antivirus Protection Now Windows Defender built into 8.1, IE 11 Enhanced Mode on, I guess I should be safe enough at this point...

Share this post


Link to post
Share on other sites

Posted

I have this same issue with my laptop and desktop both running 8.1. My laptop will stay asleep for hours then randomly wake up. My Desktop will only stay asleep for a few mins before waking. If disabling ipv6 is a workaround, what good is that? what if you actually want to use ipv6?

Share this post


Link to post
Share on other sites

Posted

Yea I don't know what good of disabling ipv6 workaround is if you actually wanna use ipv6...so far sleeping fine though since I disabled that...not sure if it would sleep fine with it enabled now or not...but don't wanna make too many changes and corrupt files again...Just fixed corruption with sfc /scannow related to green video playback screens in various programs

Share this post


Link to post
Share on other sites

Posted

Odd to hear of a Windows 8.1 sleep issue of it NOT sleeping.

 

I have been trying to figure out why when my monitor sleeps (not the computer, that is set to never sleep) and I try and wake it up, I get a black screen. I have to push the power button to make the system sleep then wake it up normally.

 

I would give all the wages from my kids working in Chinese sweat shops to figure out why this is continually happening.

Share this post


Link to post
Share on other sites

Posted

Odd to hear of a Windows 8.1 sleep issue of it NOT sleeping.

 

I have been trying to figure out why when my monitor sleeps (not the computer, that is set to never sleep) and I try and wake it up, I get a black screen. I have to push the power button to make the system sleep then wake it up normally.

 

I would give all the wages from my kids working in Chinese sweat shops to figure out why this is continually happening.

actually, ive run into this issue too. my first inclination is to check for video driver updates. have you tried that? sometimes, rarely, there will be a driver for your monitor too.

Share this post


Link to post
Share on other sites

Posted

actually, ive run into this issue too. my first inclination is to check for video driver updates. have you tried that? sometimes, rarely, there will be a driver for your monitor too.

 

Tried both, still an issue. This was never a problem under Windows XP --> Windows 7.

Share this post


Link to post
Share on other sites

Posted

Are you running a Homegroup? If so, do you use it? If not, delete it and see if the machine sleeps.

Share this post


Link to post
Share on other sites

Posted

Machine seems to be sleeping fine now, perhaps it was related to old DSL internet, since switching to cable internet--seems to be sleeping a lot better so far...Also checked video drivers, all up to date, and every other program on here is up to date as well.   

 

Thank you all for the helpful replies in this matter

Share this post


Link to post
Share on other sites

Posted

I had the same problem and finally I found the solution: disable the devices

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.