Jump to content



Photo

Windows 8 to Server 2012 R2 Network Performance

Answered Go to the full post

  • Please log in to reply
5 replies to this topic

#1 goatsniffer

goatsniffer

    Supercalifragilisticexpialidosh

  • Joined: 11-January 04
  • Location: New York, USA

Posted 16 January 2014 - 00:43

I am having a network performance issue that I would like to ask the community's help with. I will try and describe the issue as best as possible.

 

I have a Windows 2008 R2 server that I use mainly as a file server, but it also functions as a Hyper-V server. There are three active VMs on that server, one is running Server 2008 R2, the others are Server 2012 R2. I use my main workstation which is Windows 8 Professional (not 8.1) to move large files as they arrive on one of the Server 2012 R2 servers to the host Server 2008 server. The problem is that I am experiencing 40MB/s transfer speeds over my gigabit network when making these "full duplex" transfers (data being pulled from one server to my machine and pushed to another). Normally I have full saturation of 110MB/s, and I get full saturation if I'm copying from one of the Windows 2012 R2 servers directly to my windows 8 workstation. The problem only exists when a Server 2012 R2 server is involved, any 2012 R2 server, and it is a "full duplex" transfer to another network location.I can transfer "full duplex" when copying from the guest 2008 R2 server to the host 2008 R2 server from my workstation.

 

I have tried using a Windows 7 machine to do the same transfers and there is no problem. So this tells me the problem has something to do with Windows 8 full duplex transfers when Windows Server 2012 R2 is involved.

 

Here is some information regarding my Windows 8 machine:

 

Windows 8 Professional, Up to date with windows updates

Intel X58 Chipset

Intel 82567V-2 Gigabit with driver 10.1.17.0

Hyper-V guest are running off their own physical NIC, Hyper-V host has seperate physical NIC

 

What I have already tried:

 

Uninstalling network adapter from windows 8 workstation and Server 2012 R2 servers, reinstalling

Driver update (previous driver unknown, updated to version mentioned above)

Disable packet signing on Windows 8 workstation and Server 2012 R2 servers

New cable (though hardware and cable issues are out of the question as full duplex transfer work when 2012 R2 servers are not involved)

Researched disabling SMB3 (Not possible without disabling SMB2, SMB1 is inefficient for gigabit speeds)

Disabled remote differential compression 

 

 

Now before blaming virtualization, hardware, configuration of the virtual machines, etc. please take note that full duplex transfers work on my setup from a Windows 7 machine when any Server 2012 R2 IS involved, and they also work on the Windows 8 machine when any Server 2008 R2 IS NOT involved.

 

Any help would be appeciated. I am really scratching my head on this one. I've been searching for several hours...



Best Answer +macoman , 24 January 2014 - 01:57

Disabling Large Send Offload on all my network interfaces resolved the issues I was experiencing and transfers are back to as fast as they should be.

Thank you for the tip, I will take a look at it for my Windows Server 2012 R2 machine.

Go to the full post



#2 Vinny4

Vinny4

    Neowinian

  • Joined: 13-December 12
  • Location: Canada
  • OS: Win8Pro-PC / Win7Ent-EdgeE220s / SurfaceRT / Nexus 7 / BB Playbook
  • Phone: iPhone4 (work) / HTC 8X 16GB (personal)

Posted 16 January 2014 - 01:11

Have you installed the latest integration services onto the virtual client?



#3 OP goatsniffer

goatsniffer

    Supercalifragilisticexpialidosh

  • Joined: 11-January 04
  • Location: New York, USA

Posted 16 January 2014 - 01:24

My Server 2008 R2 host is fully updated, so I should have the latest integration services ISO. When attempting to install the integration services from the Hyper-V console from one of the Server 2012 R2 guests I get a message saying it is already installed.

 

It seems like everything is up to date.

 

However, it seems like my Server 2008 R2 guest was able to be updated with the newest integration services. Unrelated to the issue, but thanks anyway,



#4 OP goatsniffer

goatsniffer

    Supercalifragilisticexpialidosh

  • Joined: 11-January 04
  • Location: New York, USA

Posted 24 January 2014 - 01:11

As an update to this topic. I discussed the issue with Budman privately, so credit goes to him for helping me focus my troubleshooting efforts in the right place. When a transfer is initiated from one machine where the source and destination transfer are the same NIC, you are only seeing the status of the transfer, and the transfer will be very quick, and may exceed gigabit speeds. When the source and destination are different NICs, the data will actually be traveling physically through the initiating machine.

 

This still didn't explain the slow transfers between Windows 8 and Server 2012 R2, but some further research indicated that Large Send Offload (which is enabled by default on any network driver that supports it, and Windows 8 and Server 2012 R2 attempt to take advantage of by default) eats into your bandwidth because of a lack of standardization with the feature. You can read more about the problems here http://www.peerwisdo...rk-performance/

 

Disabling Large Send Offload on all my network interfaces resolved the issues I was experiencing and transfers are back to as fast as they should be.



#5 tbarnett

tbarnett

    Neowinian

  • Tech Issues Solved: 1
  • Joined: 10-January 06
  • Location: North Carolina

Posted 24 January 2014 - 01:39

try disabling all offloading on the NICs



#6 +macoman

macoman

    Neowinian

  • Tech Issues Solved: 3
  • Joined: 25-December 13

Posted 24 January 2014 - 01:57   Best Answer

Disabling Large Send Offload on all my network interfaces resolved the issues I was experiencing and transfers are back to as fast as they should be.

Thank you for the tip, I will take a look at it for my Windows Server 2012 R2 machine.