Jump to content



Photo

  • Please log in to reply
1 reply to this topic

#1 Axel

Axel

    --[Est. 1986]--

  • Joined: 05-August 03
  • Location: Milton Keynes, UK

Posted 16 January 2014 - 08:39

Hi all,

 

I enabled the administrator account on a Windows 7 based laptop I have and by default it shares C$ on the network.

 

The ultimate goal is to use backuppc (via samba) on my linux box to backup certain directories.  HOWEVER, the problem occurs with sharing permissions in Windows which are driving me up the bloody wall. 

 

When backing up, backuppc will hault with an error such as:

 

NT_STATUS_ACCESS_DENIED listing \Users\*
NT_STATUS_ACCESS_DENIED listing \Users\All Users\*

 

etc..

 

so I ran the smbclient commandline manually to see what was going with said directories.

 

and I get a different error:
 
NT_STATUS_INVALID_NETWORK_RESPONSE listing \Users\All Users\*
 
So I attempt to access the folder through windows and I get this error:
 
[Window Title]
Open Folder
 
[Content]
\\Holland-i3-330m\c$\Users\All Users is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.
 
The symbolic link cannot be followed because its type is disabled.
 
 
[OK]
 
So I do some research and find out that I might need to enable remote to local symbolic links.  I just enabled everything on both my local machine and remote machine and voila, I can access that folder.
 
fsutil behavior set SymlinkEvaluation L2L:1 R2R:1 L2R:1 R2L:1
 
I'm unsure about how to do this on the linux server side though.
 
I fear this is not the only issue, however.
 
I'm still getting permissions errors preventing certain directories from being accessed whilst browsing from Windows.
 
[Window Title]
Open Folder
 
[Content]
\\Holland-i3-330m\c$\Users\Default User is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.
 
The parameter is incorrect.
 
 
[OK]
 
So at the moment, I'm kind of at a loss and am requesting the help of you kind people.
 
I either want to solve the permissions issues or just tell backuppc to skip over files it cant access or doesn't have permissions for.
 
Many thanks!



#2 OP Axel

Axel

    --[Est. 1986]--

  • Joined: 05-August 03
  • Location: Milton Keynes, UK

Posted 16 January 2014 - 18:23

After arsing about all day, upgrading from Ubuntu 12.04 to 12.10 appears to have fixed it.

 

Apparently samba 3.6.3 has a bug which causes this issue.  It's now on 3.6.6 and appears to be behaving itself!





Click here to login or here to register to remove this ad, it's free!