Sign in to follow this  
Followers 0

Problem with flash using FireFox


19 posts in this topic

Posted

When playing flash videos on FF, the video often freezes/locks FF and the program says Not Responding.  After a few seconds, things are fine.  I looked online and disabled hardware acceleration, disabled protected mode, reinstalled, and updated drivers.  Chrome and IE are fine.  I have pretty much the same setup at work other than I am using Win8.1 at work, Win7 at home.  No problems at work.  Have not tried reinstalling FF yet.  Was hoping to avoid that but will if needed.

Share this post


Link to post
Share on other sites

Posted

And what version of flash is being used - are they the same.. I show 12.0.0.43 as latest for firefox.

Share this post


Link to post
Share on other sites

Posted

12 must of just came out.  I checked not to long ago and only 11 was available. I  updated and it seems to be better.  To early to tell but I will keep posted.

Share this post


Link to post
Share on other sites

Posted

I've had this same issue with firefox....

Firefox doesn't play well with flash :/

  • Try Another Browser (Waterfox, Palemoon, Google Chrome, Opera)

Pale Moon works well for me and can be found : http://www.palemoon.org

Share this post


Link to post
Share on other sites

Posted

I've had this same issue with firefox....

Firefox doesn't play well with flash :/

To be fair, does any browser play well flash at this point? I've had various performance issues with the built in pepper flash in Chrome over the last year  :laugh: Not enough to drop it mind you though.

1 person likes this

Share this post


Link to post
Share on other sites

Posted

To be fair, does any browser play well flash at this point? I've had various performance issues with the built in pepper flash in Chrome over the last year  :laugh: Not enough to drop it mind you though.

Anything else but firefox would work.....

Share this post


Link to post
Share on other sites

Posted

Had the same issue. I solved it by copying "*.*" from "C:\windows\SysWOW64\Macromed\Flash" to "C:\Program Files (x86)\Mozilla Firefox\browser\plugins" and uninstall the flash plugin.

 

In the "C:\windows\syswow64\macromed\flash" directory, create a file named "mms.cfg". Open this file and add the following line to it:

 

"ProtectedMode=0" without the quotes.

 

This disables the Flash plugin container, which is bull anyway in my opinion, as Firefox already runs every plugin in its own container. I know security is important, but running a plugin container within a plugin container...

 

You could always set the Flash plugin to "ask" before it's loaded / enabled. (So called "click to enable" -feature).

Open Firefox, click the "Firefox" button -> add-ons -> plugins. On the Flash plugin choose "ask to activate".

 

Solved all crazy slowdowns, sound stutters and everything for me.

Share this post


Link to post
Share on other sites

Posted

And what version of flash is being used - are they the same.. I show 12.0.0.43 as latest for firefox.

 

Still had issues after ugrading to 12.  Not as many issues, but there were still lock ups when playing flash vids.  So I ininstalled FF, Flash, and all my addons/references and started from scratch.  Just watched a 18min flash vid and no issues.  So I think it was a combo of FF and F that was causing the problem.  Something got borked along the way.  FF seems to be running better as well.

 

I've had this same issue with firefox....

Firefox doesn't play well with flash :/

  • Try Another Browser (Waterfox, Palemoon, Google Chrome, Opera)

Pale Moon works well for me and can be found : http://www.palemoon.org

 

IE and Chrome worked fine. 

 

Had the same issue. I solved it by copying "*.*" from "C:\windows\SysWOW64\Macromed\Flash" to "C:\Program Files (x86)\Mozilla Firefox\browser\plugins" and uninstall the flash plugin.

 

In the "C:\windows\syswow64\macromed\flash" directory, create a file named "mms.cfg". Open this file and add the following line to it:

 

"ProtectedMode=0" without the quotes.

 

This disables the Flash plugin container, which is bull anyway in my opinion, as Firefox already runs every plugin in its own container. I know security is important, but running a plugin container within a plugin container...

 

You could always set the Flash plugin to "ask" before it's loaded / enabled. (So called "click to enable" -feature).

Open Firefox, click the "Firefox" button -> add-ons -> plugins. On the Flash plugin choose "ask to activate".

 

Solved all crazy slowdowns, sound stutters and everything for me.

 

Had already tried that.  That didnt work for me.

Share this post


Link to post
Share on other sites

Posted

Still had issues after ugrading to 12.  Not as many issues, but there were still lock ups when playing flash vids.  So I ininstalled FF, Flash, and all my addons/references and started from scratch.  Just watched a 18min flash vid and no issues.  So I think it was a combo of FF and F that was causing the problem.  Something got borked along the way.  FF seems to be running better as well.

It's never simple with flash is it? You'd think by this point flash would be working in all browsers consistently. It's been almost a decade since adobe acquired it and NOPE! ;-)

Share this post


Link to post
Share on other sites

Posted

You could always set the Flash plugin to "ask" before it's loaded / enabled. (So called "click to enable" -feature).

Open Firefox, click the "Firefox" button -> add-ons -> plugins. On the Flash plugin choose "ask to activate".

 

Solved all crazy slowdowns, sound stutters and everything for me.

This actually worked. Resetting FF and updating Flash to 12 seemed to work but the issue started again. Hopefully this holds up to.

thanks

Share this post


Link to post
Share on other sites

Posted

I'm having a similar problem, except mine is somehow related to my mouse + youtube. It only happens on Youtube....If I'm watching a video and press the back button on my mouse, it locks up FF for a moment then gives me the flash error.

 

On the flip side, if I use the back button in the upper left-hand corner of the screen, it always works fine. :/  Only happens in FF, I've tested with Chrome, IE and Opera and they all work flawless.

 

and I've checked that it's not any of my extensions by process of elimination.

Share this post


Link to post
Share on other sites

Posted

Quit Skype - it worked for me! I'm not kidding.

 

Skype was hogging the CPU on a family computer every 10 seconds or so (for about one second). Closing it (from the task tray) now results in smooth Flash video playback again.

Share this post


Link to post
Share on other sites

Posted

Quit Skype - it worked for me! I'm not kidding.

 

Skype was hogging the CPU on a family computer every 10 seconds or so (for about one second). Closing it (from the task tray) now results in smooth Flash video playback again.

 

I'll be damned, you are correct sir!  I exited Skype and the problem is non-existent. (Y)

1 person likes this

Share this post


Link to post
Share on other sites

Posted

Had the same issue. I solved it by copying "*.*" from "C:\windows\SysWOW64\Macromed\Flash" to "C:\Program Files (x86)\Mozilla Firefox\browser\plugins" and uninstall the flash plugin.

 

In the "C:\windows\syswow64\macromed\flash" directory, create a file named "mms.cfg". Open this file and add the following line to it:

 

"ProtectedMode=0" without the quotes.

 

This disables the Flash plugin container, which is bull anyway in my opinion, as Firefox already runs every plugin in its own container. I know security is important, but running a plugin container within a plugin container...

 

You could always set the Flash plugin to "ask" before it's loaded / enabled. (So called "click to enable" -feature).

Open Firefox, click the "Firefox" button -> add-ons -> plugins. On the Flash plugin choose "ask to activate".

 

Solved all crazy slowdowns, sound stutters and everything for me.

The above didn't work for me, but it's good to set Flash to "ask to activate" anyhow - it will make browsing faster and significantly reduce CPU load.

 

 

I'll be damned, you are correct sir!  I exited Skype and the problem is non-existent. (Y)

Someone should report this to Microsoft!

Share this post


Link to post
Share on other sites

Posted

 

I'll be damned, you are correct sir!  I exited Skype and the problem is non-existent. (Y)

From what I've been hearing on forums, it sounds like firefox is rather racey (timing dependent) in its bugs these days. Is there major work in the multi-threading/processing implementation going on with it or something?

Share this post


Link to post
Share on other sites

Posted

it's good to set Flash to "ask to activate" anyhow - it will make browsing faster and significantly reduce CPU load.

What I did and just always remember/allow certain sites.

Share this post


Link to post
Share on other sites

Posted

Well, I found the culprit....apparently running Skype with elevated privileges is what causes this bug. I had User account control turned off (everything is run as Admin.)  I turned it back on and Skype and youtube/flash can now coexist.

Share this post


Link to post
Share on other sites

Posted

"I had User account control turned off (everything is run as Admin.)"

For what possible reason I have to ask - is the OP doing the same thing? Why people Why??

If you run your box in configuration that it was not designed to run in, then its quite possible you can run into issues that nobody else is going to have seen.

For future reference - need to make it a sticky somewhere I think.. If you have turned off UAC, and you are having an issue that should be right at the top of your post before you even report you have a problem.

If you have disabled service X because you didn't think the OS needed it and you wanted to tweak your machine for the best possible what I have no idea, that also should be listed and what you turned off and why for starters.. Other then you read it somewhere ;)

I would also suggest that if you have done such things, that you UNDO them before you even post a thread that you having a problem ;)

Not saying you can not tweak a bit, just that you need to fully understand the possible ramifications, and what exactly a service for example does before you disable it. And should be documented so you know what you have done and can undo it or atleast let someone know that you did it while they try and help you solve your problem.

example - couple of services I have disabled, I have a flipcam - which I rarely use the software with, so I disabled its 2 stupid services it runs for the software to work. So I know that before I run that software I have to enable those services. I don't use homegroups so those services are off, this for one removes the homegroup listing in the explorer navigation tab. I have the computer browse service disabled, because I don't want this machine to be or participate in computer browser elections. I have another machine that is my master browser so that service is of no use.

Sorry to ramble -- just this sort of thing just gets my goat sometimes ;)

Share this post


Link to post
Share on other sites

Posted

Ok, started having this issue again and I think I finally figured it out...

 

1) Removed Firefox and Flash

2) Deleted Mozilla folder under users\appdata\local

3) Deleted prefetch data from c:\windows\prefetch

4) Run CCLEANER

5) Reboot

 

Then I reinstalled FF and Flash, and so far so good.  Been running for a couple days so far and no lockups/freezes in FF while playing flash videos. 

 

If I have more issues, I will post back here.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.