Jump to content



Photo

Weird Keyboard buttons problem.Some not mapped.HID Keyboard!

keyboard ms hid

  • Please log in to reply
9 replies to this topic

#1 medhunter

medhunter

    Muslim Emergency physician

  • Joined: 19-June 11
  • Location: Egypt
  • OS: Win 7 SP1 Home Premium , Ubuntu 12.04 LTS, Xubuntu 13.04
  • Phone: Sony Sola

Posted 07 February 2014 - 14:15

I have just made a a clean installation of win7sp1.It automatically recognizes my wireless MS Keyboard and Mouse 800 bundle.Yet, it didn't detect correctly.windows sees kb as HID Keyboard

 

Keys mapping is not right.No function for tab key, lt control..Shift+ numbers is changed can't even type (at) for emails.

 

Even my DV6 HP laptop keyboard is mapped like this

 

I downloaded and installed official MS driver and setting app, but in vain.

 

I have installed win7sp1 alot b4 on this laptop with this keyboard, but have never had this problem

 

Any idea to investigate and solve?




#2 Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 13
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Debian Jessie
  • Phone: Samsung Galaxy SIII

Posted 07 February 2014 - 14:43

Try removing the keyboard's drivers from device manager and re-install the correct drivers from MS.



#3 OP medhunter

medhunter

    Muslim Emergency physician

  • Joined: 19-June 11
  • Location: Egypt
  • OS: Win 7 SP1 Home Premium , Ubuntu 12.04 LTS, Xubuntu 13.04
  • Phone: Sony Sola

Posted 07 February 2014 - 15:05

done already, not solved...



#4 Hum

Hum

    totally wAcKed

  • Tech Issues Solved: 10
  • Joined: 05-October 03
  • Location: Odder Space
  • OS: Windows XP, 7

Posted 07 February 2014 - 15:12

Maybe check your BIOS settings, on boot up.



#5 OP medhunter

medhunter

    Muslim Emergency physician

  • Joined: 19-June 11
  • Location: Egypt
  • OS: Win 7 SP1 Home Premium , Ubuntu 12.04 LTS, Xubuntu 13.04
  • Phone: Sony Sola

Posted 07 February 2014 - 15:18

Maybe check your BIOS settings, on boot up.

Which setting exactly?



#6 Hum

Hum

    totally wAcKed

  • Tech Issues Solved: 10
  • Joined: 05-October 03
  • Location: Odder Space
  • OS: Windows XP, 7

Posted 07 February 2014 - 15:33

^ Look for keyboard settings, if there are any.

 

I would also look in Windows Device Manager, for HID drivers, Settings.



#7 OP medhunter

medhunter

    Muslim Emergency physician

  • Joined: 19-June 11
  • Location: Egypt
  • OS: Win 7 SP1 Home Premium , Ubuntu 12.04 LTS, Xubuntu 13.04
  • Phone: Sony Sola

Posted 07 February 2014 - 18:36

^ Look for keyboard settings, if there are any.

 

I would also look in Windows Device Manager, for HID drivers, Settings.

 

No such settings in bios, No more HID devices in device manager



#8 +snaphat (Myles Landwehr)

snaphat (Myles Landwehr)

    Electrical & Computer Engineer

  • Tech Issues Solved: 29
  • Joined: 23-August 05
  • OS: Win/Lin/Bsd/Osx
  • Phone: dumb phone

Posted 07 February 2014 - 20:15

Try different USB ports for the transceiver. Also check the keyboard in another computer. This is just to try to narrow down if the hardware is faulty (suddenly). Odd that it would mis-detect otherwise imo.



#9 OP medhunter

medhunter

    Muslim Emergency physician

  • Joined: 19-June 11
  • Location: Egypt
  • OS: Win 7 SP1 Home Premium , Ubuntu 12.04 LTS, Xubuntu 13.04
  • Phone: Sony Sola

Posted 09 February 2014 - 19:01

Maybe this is right, yet there is a very important thing happening......

The same problem exist with my HP Laptop Keyboard


#10 Hum

Hum

    totally wAcKed

  • Tech Issues Solved: 10
  • Joined: 05-October 03
  • Location: Odder Space
  • OS: Windows XP, 7

Posted 09 February 2014 - 19:08

^ I'm not sure, but maybe your Region & Language settings need changed, under the Control panel.

 

Read the Help & Support files for this.