Jump to content



Photo

Internet Explorer 11 and Neowin Forums (now working)

ie11

  • Please log in to reply
21 replies to this topic

#1 Steven P.

Steven P.

    aka Neobond

  • 31,250 posts
  • Joined: 09-July 01
  • Location: Neowin HQ

Posted 24 February 2014 - 12:04

Along with several fixes that Redmak (our developer/coder) has done in order to get IE10 and 11 working with our forums, we've now forced IE10 compatibility mode so that copy/paste and several other controls work, such as adding in Attached images from the full Editor where you want in the post.

 

Roll on IPB 4! and Thanks Redmak :)




#2 Barney T.

Barney T.

    Debian Linux: I'm Loving It!

  • 15,068 posts
  • Joined: 30-August 03
  • Location: Williamsburg, Virginia

Posted 24 February 2014 - 12:06

(Y)



#3 riahc3

riahc3

    Neowin's most indecisive member

  • 7,815 posts
  • Joined: 09-April 03
  • Location: Spain
  • OS: Windows 7
  • Phone: HTC Desire Z

Posted 24 February 2014 - 12:06

Hello,

Along with several fixes that Redmak (our developer/coder) has done in order to get IE10 and 11 working with our forums, we've now forced IE10 compatibility mode so that copy/paste and several other controls work, such as adding in Attached images from the full Editor where you want in the post.
 
Roll on IPB 4! and Thanks Redmak :)

Intresting. Ive always perfered BBMode but better for all that perfer the other method.

#4 Dot Matrix

Dot Matrix

    Neowinian Senior

  • 11,480 posts
  • Joined: 14-November 11
  • Location: Upstate New York
  • OS: Windows 8.1
  • Phone: Nokia Lumia 920

Posted 24 February 2014 - 12:22

My Surface RT thanks you! :)

#5 George P

George P

    Neowinian Senior

  • 19,507 posts
  • Joined: 04-February 07
  • Location: Greece
  • OS: Windows 8.1 Pro 64bit
  • Phone: HTC Windows Phone 8X

Posted 24 February 2014 - 12:34

Have you guys tested with both the desktop and metro version of IE11?  Some times I get a weird behavior on my tablet and the onscreen keyboard starts to act up. Though I think this only happens with the editor off, now that you've improved it i'll turn it back on and see if the kb acts up again.



#6 +LimeMaster

LimeMaster

    LippyZillaD Council ( ͡° ͜ʖ ͡°)

  • 10,626 posts
  • Joined: 28-August 10
  • OS: Windows 8
  • Phone: Nokia Lumia 920

Posted 24 February 2014 - 13:20

Testing pasting text using IE11 on Neowin.

 

It works! :) I guess you guys got tired of waiting for the IPB team to fix it. :laugh:



#7 stoo2000

stoo2000

    Neowinian

  • 25 posts
  • Joined: 21-June 12
  • OS: Windows 8.1 Pro
  • Phone: Nokia Lumia 900

Posted 24 February 2014 - 13:31

It works! :) I guess you guys got tired of waiting for the IPB team to fix it. :laugh:

 

No, they're using a hook/fix provided by IPS. 



#8 OP Steven P.

Steven P.

    aka Neobond

  • 31,250 posts
  • Joined: 09-July 01
  • Location: Neowin HQ

Posted 24 February 2014 - 13:32

It works! :) I guess you guys got tired of waiting for the IPB team to fix it. :laugh:

Well in all honesty, we didn't want to force backward compatibility for IE11 :p


No, they're using a hook/fix provided by IPS. 

We're not. We know how to edit meta tags in the global_template :p



#9 stoo2000

stoo2000

    Neowinian

  • 25 posts
  • Joined: 21-June 12
  • OS: Windows 8.1 Pro
  • Phone: Nokia Lumia 900

Posted 24 February 2014 - 13:37

Well in all honesty, we didn't want to force backward compatibility for IE11 :p


We're not. We know how to edit meta tags in the global_template :p

 

So, you've got the same code that sniffs for Trident and says EmulateIE10 :p



#10 OP Steven P.

Steven P.

    aka Neobond

  • 31,250 posts
  • Joined: 09-July 01
  • Location: Neowin HQ

Posted 24 February 2014 - 13:43

We went a bit further than that actually. We fixed the Editor for IE10 in 3.4.5 ourselves, not sure why you are insisting we needed a hook to do all the fixes, but whatevs :p



#11 +LimeMaster

LimeMaster

    LippyZillaD Council ( ͡° ͜ʖ ͡°)

  • 10,626 posts
  • Joined: 28-August 10
  • OS: Windows 8
  • Phone: Nokia Lumia 920

Posted 24 February 2014 - 13:49

Well in all honesty, we didn't want to force backward compatibility for IE11 :p

That's a wise decision because I remember issues started happening in compatibility mode. :) Anyways, hopefully the editor won't break again when a new version of IPB comes out.



#12 menifred

menifred

    Conquérant de la lumière

  • 251 posts
  • Joined: 01-August 12
  • Location: Albany, NY
  • OS: Windows 8.1 Pro with Media Center x64
  • Phone: Lumia 1020 Cyan (8.10.14176.243)

Posted 24 February 2014 - 14:11

That's great! No more frustration when I use IE11 :jump:



#13 vetJohn Callaham

John Callaham

    Neowinian

  • 666 posts
  • Joined: 29-April 11

Posted 24 February 2014 - 15:46

Good job to Marcel ;)



#14 Ian W

Ian W

    Neowinian Senior

  • 1,533 posts
  • Joined: 01-March 13
  • OS: Windows Vista

Posted 24 February 2014 - 19:54

Finally! Now I can happily use Internet Explorer 11 again.

Thank you Neobond and Redmak.



#15 Boo Berry

Boo Berry

    Neowinian Ghost

  • 4,109 posts
  • Joined: 26-March 05
  • Location: United States
  • OS: Windows 8.1 Pro 64-bit Mac OS X Yosemite 10.10.1 Ubuntu 14.10 64-bit

Posted 24 February 2014 - 22:03

Posted from Internet Explorer 11. Works good!