37 posts in this topic

Hello,

In phone i checked Wi-fi network settings.

There i can see 192.168.1.1 is the default gateway ip.

There is a difference between the gateway IP and the IP address of your device.

Since it works on your laptop, open up CMD and type

ipconfig

And let me see the output.

Share this post


Link to post
Share on other sites

Hello,

There is a difference between the gateway IP and the IP address of your device.

Since it works on your laptop, open up CMD and type

ipconfig

And let me see the output.

 

Here is my ipconfig output.

 

Windows IP Configuration
 
 
Ethernet adapter Local Area Connection:
 
   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::9d90:c725:ecf3:1a5d%11
   IPv4 Address. . . . . . . . . . . : 192.168.1.100
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : fe80::21e:a6ff:fe1a:6640%11
                                       192.168.1.1
 
Tunnel adapter isatap.{E795BF25-A6F5-4690-981F-A8DC4B5F5529}:
 
   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
 
Tunnel adapter 6TO4 Adapter:
 
   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
 
Tunnel adapter Teredo Tunneling Pseudo-Interface:
 
   Connection-specific DNS Suffix  . :
   IPv6 Address. . . . . . . . . . . : 2001:0:9d38:6ab8:3057:36e1:3f57:fe9b
   Link-local IPv6 Address . . . . . : fe80::3057:36e1:3f57:fe9b%13
   Default Gateway . . . . . . . . . : ::

 

 

Share this post


Link to post
Share on other sites

Guys I think the issue is due to default gateway .

 

Scenario is that I have a Wi-Max connection and I have used 2 router.

1st router dooesnt have a Wi-Fi port So i have used 2nd ADSL 2 router for Wi-Fi.

May be this is root cause Why I am not able to get Wi-Fi on my phone.

Share this post


Link to post
Share on other sites

Hello,

Guys I think the issue is due to default gateway .

More or less; Your Android seems to have its wlan0 interface (wifi) with a IP address that is in use by your router!

Before anything else, I wanna fully confirm this so on your Android (which is connected to the wifi) go ahead and open terminal emulator and type:

ip addr show wlan0

This will confirm.

Share this post


Link to post
Share on other sites

Guys sorry for late reply.

Here is the screenshot of ip addr show wlan0.

 

post-241833-0-94804900-1396778226.png

Share this post


Link to post
Share on other sites

Guys sorry for late reply.

Here is the screenshot of ip addr show wlan0.

 

attachicon.gifScreenshot_2014-04-06-15-20-44.png

If I'm reading everything correctly, your phone has the same IP address as your laptop. This is a problem. Are you using DHCP on your router and/or do you have any IP addresses manually entered into either your laptop or phone?

Share this post


Link to post
Share on other sites

Here is ip configuration of my laptop.

It says ip as 192.168.1.102

 

Wireless LAN adapter Wi-Fi:
 
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Qualcomm Atheros AR9002WB-1NG Wireless Ne
twork Adapter
   Physical Address. . . . . . . . . : E0-CA-94-2B-74-A3
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::c464:4d67:c310:2de9%13(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.102(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Tuesday, April 8, 2014 10:25:02 AM
   Lease Expires . . . . . . . . . . : Friday, April 11, 2014 10:25:06 AM
   Default Gateway . . . . . . . . . : fe80::21e:a6ff:fe1a:6640%13
                                       192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 333499028
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-19-16-B3-FA-00-26-6C-D2-6E-50
 
   DNS Servers . . . . . . . . . . . : 192.168.1.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Share this post


Link to post
Share on other sites

If I'm reading everything correctly, your phone has the same IP address as your laptop. This is a problem. Are you using DHCP on your router and/or do you have any IP addresses manually entered into either your laptop or phone?

 

I am using a Windows PC also in this network.I checked ip address of that system too.It says IP as 192.168.1.101(Preffered).

Also i haven't configured any IP manually..About DHCP I am not sure about it.

Share this post


Link to post
Share on other sites

I am using a Windows PC also in this network.I checked ip address of that system too.It says IP as 192.168.1.101(Preffered).

Also i haven't configured any IP manually..About DHCP I am not sure about it.

Try opening the command prompt on your PC and type the following:

ipconfig /release

ipconfig /renew

That should tell your PC to find a new IP from your router that is not in use by any other devices.

Share this post


Link to post
Share on other sites

As a test you could try shutting that PC off and testing your phone to see if the issues go away. If they both have 192.168.1.100 you will have problems.

Share this post


Link to post
Share on other sites

As a test you could try shutting that PC off and testing your phone to see if the issues go away. If they both have 192.168.1.100 you will have problems.

 

I tried using only my phone connected to that network,but still no luck. :(

Share this post


Link to post
Share on other sites

Let me go out on a limb and ask if you have MAC address filtering turned on?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.