Sign in to follow this  
Followers 0

31 posts in this topic

http://answers.microsoft.com/en-us/windows/forum/windows8_1-tms/multi-monitor-mouse-bug-after-update-to-windows-81/a4eb4cc9-def1-4e80-b823-83460339afb8

 

 

There is a new bug that won't let the mouse to the other screen unless you move the mouse quickly across the monitor edge.

 

 

http://vimeo.com/91216253

 

 

I can confirm this issue. I have 3x monitor and I just updated to W8.1 update ~1 hour ago.

As soon as I went to desktop and opened something, I was trying to move it to another monitor and faced this issue.

 

Behavior BEFORE W8.1 update (i.e., w8.1):

there is a small area from top and bottom (~100px height) of each left/right edge of all monitor where your mouse cursor will get stuck if you are moving it slowly. This has been done (on Windows 8.1) to help activate charms for mouse users.

 

Behavior AFTER W8.1 update (I.e., w8.1u):

1. The stickiness level has been increased a little

2. The small area (~100px height) has been changed to 100%.

#2 is the real culprit. This is almost a deal breaker. I am having SERIOUS issues moving windows from one monitor to another. And often, the cursor would just get stuck in the edge while going from one to another monitor just because im not moving it really fast.

 

 

 

Anyone else facing this issue? None of the kb/m enhancement in win 8.1 update 1 helps me in any way. But now this stupid issue is really bringing down my productivity :(

Share this post


Link to post
Share on other sites

windows 8.x should have the ability to re-locates the 'charm bar location', just like previous windows could relocate the taskbar.

since almost none use their multi-monitors vertically, its ideal to relocate the charm bar to top/bottom screen.

Share this post


Link to post
Share on other sites

I too am encountering this issue, its incredibly annoying.

Share this post


Link to post
Share on other sites

Yes, I had the same issue although only with 2 monitors, I fixed it by opening the screen resolution (right click, desktop) and although it was already set to "Extend these displays" I changed it "Duplicate these displays" and then back again, applying each time.

 

This worked and the issue has gone, back to normal pre update. :)

3 people like this

Share this post


Link to post
Share on other sites

Yes, I had the same issue although only with 2 monitors, I fixed it by opening the screen resolution (right click, desktop) and although it was already set to "Extend these displays" I changed it "Duplicate these displays" and then back again, applying each time.

 

This worked and the issue has gone, back to normal pre update. :)

Can confirm your method solves the issue, thank you

Share this post


Link to post
Share on other sites

Not sure what you did wrong, albeit no problems here. . . :D

Share this post


Link to post
Share on other sites

Can confirm your method solves the issue, thank you

Yes all good now, like I said back to normal

Share this post


Link to post
Share on other sites

Yes, I had the same issue although only with 2 monitors, I fixed it by opening the screen resolution (right click, desktop) and although it was already set to "Extend these displays" I changed it "Duplicate these displays" and then back again, applying each time.

 

This worked and the issue has gone, back to normal pre update. :)

Thanks!

 

This has fixed the issue indeed!

Share this post


Link to post
Share on other sites

Spoke too soon. After a restart, problem is back.

1 person likes this

Share this post


Link to post
Share on other sites

Spoke too soon. After a restart, problem is back.

you can autohotkey it to make the ritual are automatically done for every restart.

Share this post


Link to post
Share on other sites

I haven't had this problem either.

Share this post


Link to post
Share on other sites

It's only the top corner that is affected, no big deal for me. In fact it makes it easier to bring up the charms menu whereas before I would be sliding straight past it :P

Share this post


Link to post
Share on other sites

It's only the top corner that is affected, no big deal for me. In fact it makes it easier to bring up the charms menu whereas before I would be sliding straight past it :p

 

Same here, also the bottom right corner does the same.  Other than that I have no problems going back and forth between my two monitors.

Share this post


Link to post
Share on other sites

It's only the top corner that is affected, no big deal for me. In fact it makes it easier to bring up the charms menu whereas before I would be sliding straight past it :p

 

 

Same here, also the bottom right corner does the same.  Other than that I have no problems going back and forth between my two monitors.

yes, top and bottom corners. That's how it is suppose to be. But since W8.1u1, it is the WHOLE edge :/

Share this post


Link to post
Share on other sites

yes, top and bottom corners. That's how it is suppose to be. But since W8.1u1, it is the WHOLE edge :/

If I move the mouse go slowly across the monitors I see the lag but if I go fast, no lag.

Share this post


Link to post
Share on other sites

I'm having the same issue. Sure hope Microsoft fixes this.

Share this post


Link to post
Share on other sites

Not sure this is even a "bug" that needs "fixing." All it's doing is allowing mouse users to activate Charms easier. You must be moving the mouse really slow to get stuck on the edge of the screen.

 

I've personally noticed the extra stickiness, but it has not effected me at all. Increase your mouse tracking, and you'll be fine.

Share this post


Link to post
Share on other sites

Not sure this is even a "bug" that needs "fixing." All it's doing is allowing mouse users to activate Charms easier. You must be moving the mouse really slow to get stuck on the edge of the screen.

 

I've personally noticed the extra stickiness, but it has not effected me at all. Increase your mouse tracking, and you'll be fine.

I don't see why this would be a bad setting to add to the control panel.

Try modifying the following value in regedit:

HKCU\Control Panel\Desktop\MouseCornerClipLength

Default is 6, 0 is to turn off the sticky area completely. You might find a value of 2 to be more to your liking.

Share this post


Link to post
Share on other sites

Not sure this is even a "bug" that needs "fixing." All it's doing is allowing mouse users to activate Charms easier. You must be moving the mouse really slow to get stuck on the edge of the screen.

 

I've personally noticed the extra stickiness, but it has not effected me at all. Increase your mouse tracking, and you'll be fine.

 

definitely something that needs fixing, as it is very annoying. The mouse gets stuck at regular mousing speed. As someone that has many windows open at once on 3 monitors, constantly moving them around and aligning them, having the mouse stick every time I pass between monitors becomes frustrating very quickly. I shouldn't have to adjust my regular mouse movement to actively remember to 'throw' my mouse from one monitor to another with enough speed to break through the sticking boundary.

 

Prior to the recent 8.1 update, the sticky corners for charms was the perfect size, and worked as it was intended. This is most definitely a bug.

 

edit: for now, as others have suggested, toggling into duplicate displays, and then back to extended desktop resolves the problem until your next reboot. 

Share this post


Link to post
Share on other sites

Disabling the charms bar was the first thing I did when I got Start8. 
Honestly, best thing I ever did.
But yeah the mouse clipping is still present after a reboot, that still bugs me a bit since im always working with duel monitors.

Share this post


Link to post
Share on other sites

definitely something that needs fixing, as it is very annoying. The mouse gets stuck at regular mousing speed. As someone that has many windows open at once on 3 monitors, constantly moving them around and aligning them, having the mouse stick every time I pass between monitors becomes frustrating very quickly. I shouldn't have to adjust my regular mouse movement to actively remember to 'throw' my mouse from one monitor to another with enough speed to break through the sticking boundary.

 

Prior to the recent 8.1 update, the sticky corners for charms was the perfect size, and worked as it was intended. This is most definitely a bug.

 

edit: for now, as others have suggested, toggling into duplicate displays, and then back to extended desktop resolves the problem until your next reboot. 

What are your mouse settings at? I don't have any issues at all moving from monitor to monitor. I don't even see it when I have fullscreen windows open.

 

post-420821-0-75249700-1397816504.png

Share this post


Link to post
Share on other sites

What are your mouse settings at? I don't have any issues at all moving from monitor to monitor. I don't even see it when I have fullscreen windows open.

 

attachicon.gifMouse.PNG

It is not about mouse settings. My mouse settings are almost same as yours (1 tick less and no acceleration).

 

I already have applied the registry tweak but didn't bother restarting yet.

Share this post


Link to post
Share on other sites

For those googling, follow this link. http://winaero.com/blog/fix-mouse-pointer-sticks-on-the-edge-when-moving-between-multiple-monitors/

 

For those too lazy, open regedit.exe.

 

Go to HKEY_CURRENT_USER>Software>Windows>CurrentVersion>ImmersiveShell>EdgeUi

 

Add or edit a DWORD value named "MouseMonitorEscapeSpeed" and give it a value of 20

 

Go to HKEY_CURRENT_USER>Control Panel>Desktop

 

Add or edit a DWORD value named "MouseMonitorEscapeSpeed" and give it a value of 1

 

Restart explorer.exe via the Task Manager.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.