Jump to content



Photo

  • Please log in to reply
7 replies to this topic

#1 xeel

xeel

    Neowinian

  • Joined: 02-April 06

Posted 09 May 2014 - 02:53

Hello,

 

I've been having this problem for quite a while by now. It worked before but from certain moment all of color pallette fixes for old games stoped working. This includes the classic explorer.exe kill, registry edit by PID, dx dlls override and other utils.

 

I know that the quickest way to solve this would be by reinstalling the system, but I really have no time for this since I've got hundreds of programs installed and it would take several days to reinstall them all.

 

Any ideas what could have happened or where should I look for the source of the problem? The most probable place of the source would be the Windows registry, though I have absolutely no idea where to look.

 

I have Windows 7 SP1 updated up to date.

 

Let me know if any of the logs could be useful to post them here.

 

Thanks and Regards




#2 Aergan

Aergan

    Neowinian Senior

  • Tech Issues Solved: 7
  • Joined: 24-September 05
  • Location: Staffordshire, UK
  • OS: Windows 8.1 Pro | Xubuntu | OSX Yosemite| Server 2012 R2 | Ubuntu Server
  • Phone: Sony Xperia Z1

Posted 11 May 2014 - 21:09

Which games? From my experience with older titles, it's either force the application into 256 colours / 16bit colour mode or enabling the legacy/deprecated texture modes on the video driver via 3rd party tool.

 

A lot of older games have been patched by communities to get around the whole deprecation of original DX1 - DX3 textures and legacy DirectDraw alpha issues - e.g. Planescape Torment, Starwars Supremacy.



#3 vetneufuse

neufuse

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 16-February 04

Posted 11 May 2014 - 21:11

color pallets? how old are these games? Why not just use DOS Box or Visual Box?



#4 Max Norris

Max Norris

    Neowinian Senior

  • Tech Issues Solved: 22
  • Joined: 20-February 11
  • OS: Windows 2012R2, 7, BSD Unix
  • Phone: HTC One (Work) Lumia 1020 (Home)

Posted 11 May 2014 - 21:22

Had a few reeeeealy old 256 color games do this under 7.  Adding an entry for it under HKLM\Wow6432Node\Microsoft\DirectDraw\Compatibility hasn't ever failed for me though.  No tricks or killing anything, once and done per game and run it as you'd expect.  Old stuff like the original Baldur's Gate, etc.



#5 n_K

n_K

    Neowinian Senior

  • Tech Issues Solved: 3
  • Joined: 19-March 06
  • Location: here.
  • OS: FreeDOS
  • Phone: Nokia 3315

Posted 11 May 2014 - 21:29

I've always had success killing explorer.exe.

What games do you find it doesn't work with?



#6 OP xeel

xeel

    Neowinian

  • Joined: 02-April 06

Posted 12 May 2014 - 04:30

Dark Reign, Total Annihilation or Sid Meier's Alpha Centauri for example. There are no DX related tools or patches made for these games to fix colours in full screen mode.

 

1. HKLM\Software\Wow6432Node\Microsoft\DirectDraw\Compatibility isn't working (it did, but not now)

2. Manual or automatic explorer.exe killers aren't working either (they also did, but not now)

3. ddraw wrappers aren't working (never did, at least in full screen)

 

I'm quite familiar with the problem. As I mentioned before, my actual problem is that no common solution is working now.



#7 Raa

Raa

    Resident president

  • Tech Issues Solved: 8
  • Joined: 03-April 02
  • Location: NSW, Australia

Posted 12 May 2014 - 04:40

Sounds like a system component has become corrupted.

Worth trying to reinstall DirectX components to see if that helps?



#8 OP xeel

xeel

    Neowinian

  • Joined: 02-April 06

Posted 12 May 2014 - 04:51

Though it all happened several months ago. I started to rewalk my steps I made that time, and one of the programs I tried was PalettestealerSuspender. I was when I "played" with it when all other solutions stoped working.

 

 

Sounds like a system component has become corrupted.

Worth trying to reinstall DirectX components to see if that helps?

 

Any ideas how to do that in it's "complete" form?