Jump to content



Photo

Super Slow Windows (8) SMB Folder Mounts in OS X Mavericks


  • Please log in to reply
8 replies to this topic

#1 vetDirtyLarry

DirtyLarry

    ®®\vers.12.vis.13.u.03.al\DL

  • Tech Issues Solved: 2
  • Joined: 31-August 03
  • Location: dirty jersey
  • OS: Win 8 | OS X 10.8.5 | Android 4.2.3
  • Phone: LG G3

Posted 17 May 2014 - 04:05

First as a reference here are two threads on the official Apple Community forums with people who have pretty much the same issue I am having.

 

 

 

In my own words...
 

It used to be when I did an smb mount of my Windows 8 computer from my Macbook Pro I could mount any sized folder in seconds. Now it takes upwards of 10-15 minutes for folders on my Windows 8 computer to finally resolve themselves in the OS X Finder.
 
Once they do mount, copying over files is as fast as they should be. My Gigabit network performs as normal once it resolves. 
 
It is just the initial connection and mount now takes way, way longer than it should.
 
FYI, it is the same experience whether I am using my WiFi or Hardwired connection.
 
I just spent the last hour trying a multitude of different solutions found in the linked threads at the Apple Support Community to no avail. 
 
This seems to have been an issue with the introduction of OS X Mavericks. Really has been an issue with 10.9.2. I did update to 10.9.3 hoping it would fix things, but slow as ever.
 
Anyone experience a similar issue and even more important anyone know of a solution?
 
I can verify
  • I also have a Synology Disk Station, but I do not even have Cloud Station installed, which was one fix a few other people reported working (disabling it). The other thing is my Disk Station mounts super quick as it normally would, so no issues there.
  • I also have disabled Real Time protection on my AV Solution just to see. Nothing.
  • Tried a whole myriad of Terminal commands in the threads above.
  • Also did a Repair Boot and did a Verify / Repair Disk from the Disk utility. Nothing.
     
  • The only thing I did not try that was suggested was to delete my Library's cache completely as I know that can cause some funkiness once I do it, but I am willing to go ahead and do it if that is recommended.
 
Any help is greatly appreciated. I am thinking there has to be plenty of people here who regularly mount Windows 8 folders in OS X.
It is super annoying at this point, especially since it worked smooth as can be just a few weeks back.
 
TIA,
DL

 




#2 jasondefaoite

jasondefaoite

    Neowinian

  • Tech Issues Solved: 2
  • Joined: 04-October 02
  • Location: Ireland - Singapore

Posted 17 May 2014 - 04:15

Edit:
 Removed.

 

I didn't notice you already updated to 10.9.3. So scratch that.



#3 OP vetDirtyLarry

DirtyLarry

    ®®\vers.12.vis.13.u.03.al\DL

  • Tech Issues Solved: 2
  • Joined: 31-August 03
  • Location: dirty jersey
  • OS: Win 8 | OS X 10.8.5 | Android 4.2.3
  • Phone: LG G3

Posted 19 May 2014 - 14:23

I guess no one else has encountered this issue? Just giving a bump since I did post it at Midnight on a Saturday night.

TIA,

DL



#4 jasondefaoite

jasondefaoite

    Neowinian

  • Tech Issues Solved: 2
  • Joined: 04-October 02
  • Location: Ireland - Singapore

Posted 19 May 2014 - 14:33

I'm running 10.9.3 and also Windows 8.1 on my microserver. Never had this issue. Sorry.



#5 PGHammer

PGHammer

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 31-August 03
  • Location: Accokeek, MD
  • OS: Windows 8 Pro with Media Center x64

Posted 19 May 2014 - 14:55

I'm running 10.9.3 and also Windows 8.1 on my microserver. Never had this issue. Sorry.

I triple-boot Mavericks, 8.1 update 1, and Server 2012R2, and have exactly zero issues mounting either Windows partition from Mavericks.  (The two Windows OSes share a drive, but are on separate partitions on that drive, while Mavericks is on a different drive altogether.)

 

It comes in handy as 8.1 update 1 has the largest partition, followed by Server 2012R2; Mavericks "makes do" woth an 80 GB SATA HDD to its lonesome.



#6 jasondefaoite

jasondefaoite

    Neowinian

  • Tech Issues Solved: 2
  • Joined: 04-October 02
  • Location: Ireland - Singapore

Posted 19 May 2014 - 15:10

Sorry, maybe I wasn't clear :) I meant I was running OSX 10.9.3 on a separate machine to my microserver running Windows 8.1. The problem the TS is having is mounting SMB shares across the network, rather than reading a windows formatted partition on the same system. Thankfully I've not had the issue described.



#7 Eric

Eric

    Neowinian Senior

  • Tech Issues Solved: 13
  • Joined: 02-August 06
  • Location: Greenville, SC

Posted 19 May 2014 - 15:19

Did you try Ronsey's fix in the second thread you linked?

 


I went through a bunch of the steps in this thread with no luck.

 

 

Ended up forcing the Macs to use SMB1 until this is fixed by Apple:

 

 

echo "[default]" >> ~/Library/Preferences/nsmb.conf; echo "smb_neg=smb1_only" >> ~/Library/Preferences/nsmb.conf

 

 

That's all one line and it fixed the issue for use instantly.  No reboot required.

 

There apparently is/was something wrong with SMB2 in Mavericks so you can switch back to SMB1 until Apple issues a fix for it.



#8 OP vetDirtyLarry

DirtyLarry

    ®®\vers.12.vis.13.u.03.al\DL

  • Tech Issues Solved: 2
  • Joined: 31-August 03
  • Location: dirty jersey
  • OS: Win 8 | OS X 10.8.5 | Android 4.2.3
  • Phone: LG G3

Posted 22 May 2014 - 23:07

Did you try Ronsey's fix in the second thread you linked?

 

 

 

There apparently is/was something wrong with SMB2 in Mavericks so you can switch back to SMB1 until Apple issues a fix for it.

How would I do that? Via Terminal?

 

I still have the issue, and what I have been doing is using Remote Desktop Connection from the Macbook to get into the Windows Computer, going to my Macbook from Windows, then copying the files over from Windows itself. And there is zero issues and it is fast as it should be. So it is a bit convoluted but it works, but I would love to solve it so I did not have to use RDC.

 

EDIT - So I went ahead and copy and pasted that command above into Terminal, and it seems to have worked!!!! I missed it somehow. Thanks Eric. I think that did it for now. (Y)

 

EDIT 2 - Damn, it seems to have made my transfer speeds very slow. Ouch. I guess to set it back I would change the 1 to a 2??



#9 Sikh

Sikh

    Neowin Addict!

  • Tech Issues Solved: 2
  • Joined: 11-March 07
  • Location: localhost
  • OS: Windows 7 / 10.8 / Ubuntu Server
  • Phone: Nexus 5 PA 4.4.2 / iPhone 5

Posted 22 May 2014 - 23:34

Smb1 by nature is slow.

Have you tried connecting to the smb2 share via IP instead of hostname? Smb2 server is broken on mavericks. As far as client connection goes its because apple built their smb stack to microsofts specs. In doing so the smb2 authentication and resolution of dns is broken. I have tested this with some cheap nas's I have at home and my freenas server. If I connect via IP the cheap nas's work great. If I connect via UNC / host name they take a few minutes. If I connect to freenas either way it works great because they are using the samba3/4 implementation and which is by far better than what most cheap nas's use.

To undo the above terminal command just remove the code / files.