Jump to content



Photo

Black Screen


  • Please log in to reply
13 replies to this topic

#1 Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 13
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Debian Jessie
  • Phone: Samsung Galaxy SIII

Posted 12 June 2014 - 13:26

Yesterday, I added on Steam on my Crunchbang OS. Used Debian Jessie to install. Everything on default.

 

This morning, when I turn on the computer, It just goes blank. This is after it posts "wait until /dev gets populated" The last thing it does before desktop shows up.

 

It did this before, but normally I just restart the computer, and its fine.

 

Using my other SSD, that has Ubuntu (latest version?).''

 

I think this is a problem with X11, but not sure exactly what.

 

What's up?!




#2 OP Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 13
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Debian Jessie
  • Phone: Samsung Galaxy SIII

Posted 12 June 2014 - 23:57

100 views, and nothing? I don't mean to bump this, just I haven't got a solution all day.



#3 John.D

John.D

    Neowinian

  • Tech Issues Solved: 3
  • Joined: 10-November 09

Posted 13 June 2014 - 00:11

Ask in  the debian forums? Looks like it was a bug and it's still there. Looks like users got that same message after upgrading from Lenny to Squeeze

 

Probably better if you use another distro of linux



#4 OP Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 13
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Debian Jessie
  • Phone: Samsung Galaxy SIII

Posted 13 June 2014 - 00:59

Ask in  the debian forums? Looks like it was a bug and it's still there. Looks like users got that same message after upgrading from Lenny to Squeeze

 

Probably better if you use another distro of linux

 

I ask here because i know there are some educated people on here. I ask all my Debian-based questions on here. That's like saying use Google.

 

A bug? Tell me what bug that is. I am not upgrading, I am simply using the repositories.

 

Another distro, are you kidding me?!



#5 Eric

Eric

    Neowinian Senior

  • Tech Issues Solved: 13
  • Joined: 02-August 06
  • Location: Greenville, SC

Posted 13 June 2014 - 01:06

Are you using Plymouth by chance? There's something wrong with it on Debian that causes it to not display anything except a black screen.



#6 OP Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 13
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Debian Jessie
  • Phone: Samsung Galaxy SIII

Posted 13 June 2014 - 01:19

No, last thing I installed to cause this problem is Steam.



#7 Eric

Eric

    Neowinian Senior

  • Tech Issues Solved: 13
  • Joined: 02-August 06
  • Location: Greenville, SC

Posted 13 June 2014 - 01:28

Try adding "nomodeset" to the kernel options from the GRUB screen and see if you can get it to come up at all.

I never had much luck getting Steam to work right on Debian. I know SteamOS is forked from it but I had issues with jockey and glib when I tried it.

#8 OP Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 13
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Debian Jessie
  • Phone: Samsung Galaxy SIII

Posted 13 June 2014 - 02:16

It was working fine before I installed Steam... I'll test nomodeset later.



#9 Eric

Eric

    Neowinian Senior

  • Tech Issues Solved: 13
  • Joined: 02-August 06
  • Location: Greenville, SC

Posted 13 June 2014 - 03:34

If you used the custom deb package make sure you install the extra dependency packages it needs, too. (enable multi-arch and add i386, and the x86 opengl package)

 

I don't think the glibc and jockey issues I mentioned are relevant for Jessie, only Wheezy.



#10 OP Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 13
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Debian Jessie
  • Phone: Samsung Galaxy SIII

Posted 13 June 2014 - 13:56

I followed this guide: https://wiki.debian.org/Steam



#11 Eric

Eric

    Neowinian Senior

  • Tech Issues Solved: 13
  • Joined: 02-August 06
  • Location: Greenville, SC

Posted 13 June 2014 - 13:59

That's really odd, then. Maybe it's something in Crunchbang that's causing the issue? I can try doing a plain Jessie install later and see if I can replicate your issue.



#12 +ChuckFinley

ChuckFinley

    member_id=28229

  • Joined: 14-May 03

Posted 13 June 2014 - 14:06

It happens with some ATI driver versions and Kernel versions. Its a known thing. Google Around for a bit more. 



#13 OP Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 13
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Debian Jessie
  • Phone: Samsung Galaxy SIII

Posted 13 June 2014 - 14:07

There some fix for this? I'm done searching on Google....



#14 OP Mindovermaster

Mindovermaster

    Neowinian Senior

  • Tech Issues Solved: 13
  • Joined: 25-January 07
  • Location: /USA/Wisconsin/
  • OS: Debian Jessie
  • Phone: Samsung Galaxy SIII

Posted 14 June 2014 - 02:18

Ok, I put Mint Debian LMDE over my Ubuntu install on my Samsung 830 120GB SSD. After I got the propietary drivers up, I rather liked it. I know the overscan bit. That was easy. Loaded  up all the programs I used, easy peasy.

 

I'll keep picking at that Crunchbang thing, but, until I find a solution, it's borged.