Sign in to follow this  
Followers 0

Server 2012 - unable to join domain

25 posts in this topic

Posted

I've Windows Server 2012 R2 setup in VirtualBox along with a Windows 7 virtual machine, I'm trying to join it to the domain, but it says the following... 'An Active Directory Domain Controller (AD DC) for the domain "hq.com" could not be contacted'

 

LL

 

Any ideas?

Share this post


Link to post
Share on other sites

Posted

I do not see the DNS server listed.  The DNS needs to be set to an Active Directory DNS server's IP address.  Considering the DNS suffix is "home" and not "hq.com" I would assume your router is handing out DHCP which is either handing itself as the DNS server or your ISP DNS servers.  Set a static DNS to point to the AD server (I hope your AD server is also statically set) and it should work.

Share this post


Link to post
Share on other sites

Posted

btriZb8bexpZcfNfBfzFR8cMB_tROU7z7SxUUhKR

 

Does this help?

 

I'll turn off DHCP on my router too.

Share this post


Link to post
Share on other sites

Posted

Your server does not have a valid IPv4 IP address.  You need to set a static IP on the server, set the gateway to your router, proper subnet mask and you can leave the DNS pointing to the server itself or plug in the static IP you use.  You can run DHCP on the router, but it needs to hand out DNS that has the servers IP address first in the list.  That or turn DHCP on the server itself and make sure it hands out the proper DNS, subnet and gateway info.

 

Also for a test setup, I would advise against using a .com, .net, etc for the domain suffix, use something like hq.loc unless you want to set something up like split DNS.  DNS resolution could get fun if you do need to visit www.hq.com :)

1 person likes this

Share this post


Link to post
Share on other sites

Posted

Appreciate your help. Could you assist further with the above?

Share this post


Link to post
Share on other sites

Posted

+Martog prettu much laid it out there. What specifically do you need help with?

What router do you have?

Your server is using a private IP address because it's not finding a DHCP server on the network and/or you haven't set one statically. Static is the best way to do it, anyway.

Share this post


Link to post
Share on other sites

Posted

My router is a Huawei HG635. 

 

I'm new to this, just becoming familiar with setting things up!

 

I'll recreate the domain as hq.loc and follow up.

Share this post


Link to post
Share on other sites

Posted

no offense viennaa but if you're as new to this as you say then you should probably read up on some basic networking and windows server guides

 

joining a domain is one of the easier tasks of windows server.

 

if you're able, ask a colleague for some assistance. i'm sure they'll be glad to teach you. hands-on face-to-face is always better then asking on a forum with this kind of thing

 

just some friendly advice smile.png

1 person likes this

Share this post


Link to post
Share on other sites

Posted

It's just setting up the static IP I have an issue with, I'm not sure what to set the server IP to. I'm trying to wrap my head around this!

 

Appreciate all your help.

 

I've given the IP address 192.168.1.19

Subnet - 255.255.255.0

Gateway - 192.168.1.1

DNS - 192.168.1.1

Share this post


Link to post
Share on other sites

Posted

It sounds like you need to input the following information into the server.

 

Set a static IP like this:

 

 

 

Go to Control Panel > Network and Sharing Center > (on the left hand side) click on Adapter Settings > then Right click on your network connection) > then select Properties > Scroll down a little bit and find "Internert Protocol Version 4 (TCP..) and then select properties

 

You can now fill out the information as shown below.  Once done click OK

 

cCEN8ch.png

Share this post


Link to post
Share on other sites

Posted

I know how to navigate to the IPv4 properties, when I input this information and apply it, I'm unable to connect to the internet. See below.

 

4lWADfxv-uRHGwaM8DMhkXqH86V6GqdalakIm7GS

Share this post


Link to post
Share on other sites

Posted

Hi Vienna.

Personally I would turn off DHCP on your router and install it on your server, the best place for it.

How to install and configure, http://blogs.technet.com/b/teamdhcp/archive/2012/08/31/installing-and-configuring-dhcp-role-on-windows-server-2012.aspx

Configuring the scope, http://technet.microsoft.com/en-us/library/dd759218.aspx

But I would also recommend doing a spreadsheet of how you want your scope laid out. Example, I am currently in the process of migrating a small company from SBS 2003 to Server 2012 with 365. I have created the scope for expansion and it is something like this.

192.168.0.1 to .9 - Servers

192.168.10.10 to 15 - Printers

192.168.0.250 to 192.168.0.254 - Switches and routers

Now, for the scope properties I would have the server pointing its DNS to its self along with all other servers and client (including the machine you want to join to the domain) The gateway to the router.

The important thing here though is to point the client to the server for DNS. Otherwise it not going to join.

I know how to navigate to the IPv4 properties, when I input this information and apply it, I'm unable to connect to the internet. See below.

 

4lWADfxv-uRHGwaM8DMhkXqH86V6GqdalakIm7GS

On your original ipconfig the IP address is a 10.0.2.2 for the gateway, ow the IP is 192.168.1.19. They need to be on the same subnet for data to flow.

Share this post


Link to post
Share on other sites

Posted

I've turned off DHCP on my router and it's installed on my server, though not configured as of yet. 

 

I will look into configuring it and creating a scope as well as it will come in handy in future.

 

Unsure as of why I cannot get an internet connection on my server though.

Share this post


Link to post
Share on other sites

Posted

Since you're using Virtualbox, did you set you Networking to Bridge?

Share this post


Link to post
Share on other sites

Posted

I've turned off DHCP on my router and it's installed on my server, though not configured as of yet. 

 

I will look into configuring it and creating a scope as well as it will come in handy in future.

 

Unsure as of why I cannot get an internet connection on my server though.

Different subnets. What is the IP of your gateway? Compare it to the IP of the server and you client.

Share this post


Link to post
Share on other sites

Posted

Since you're using Virtualbox, did you set you Networking to Bridge?

 The Server is set to bridged.

Share this post


Link to post
Share on other sites

Posted

Different subnets. What is the IP of your gateway? Compare it to the IP of the server and you client.

They're both bridged and the client now displays this...

 

N273zptBcncPJQJMWQHMtoC-04N7j6jEs5YRUgqY

Share this post


Link to post
Share on other sites

Posted

FMC8uLuq5o_7sNCDJE2gOJ0Q82JognqH6eL0z-_K

Share this post


Link to post
Share on other sites

Posted

FMC8uLuq5o_7sNCDJE2gOJ0Q82JognqH6eL0z-_K

 

Normally if you get an IP address starting with 169.254 it indicates a networking problem. You only get that IP addressed when it's self-assigned which means the computer has no other way of obtaining an IP address.

Share this post


Link to post
Share on other sites

Posted

Unless you have a specific reason for using VirtualBox I'd probably go with Hyper-V, the stripped down version is available for free in both Windows 7 and 8 and as a beginner it's going to do everything you need and is much easier to setup networking.

Cheers

Hynesy

Share this post


Link to post
Share on other sites

Posted

Unless you have a specific reason for using VirtualBox I'd probably go with Hyper-V, the stripped down version is available for free in both Windows 7 and 8 and as a beginner it's going to do everything you need and is much easier to setup networking.

Cheers

Hynesy

I'll just clarify... because I only just remembered. Hyper-V can't be used with Basic and Home Premium versions on Win 7/8.

Share this post


Link to post
Share on other sites

Posted

I'll just clarify... because I only just remembered. Hyper-V can't be used with Basic and Home Premium versions on Win 7/8.

To further clarify, Hyper-V is only on Windows 8 and 8.1, only the tools to connect to a Hyper-V server are in Windows 7.

 

I cannot see the OP's attached images. Vienna,  you should set a static IP on the server that matches your internal network, just set it up high, like the last number .240 as the last octet.  If you want to run DHCP on the network, I would install DHCP server on the server as I mentioned earlier and configure it and get it running, disable the DHCP on the router.  With DHCP handing out DNS as the static IP of the server, any Pro/Enterprise version and servers can join the domain easily.

Share this post


Link to post
Share on other sites

Posted

Hey,

 

So I've set up the server in Hyper-V and created a Windows 8 client. 

 

Server -

IP - 192.168.1.5

Subnet mask - 255.255.255.0

Gateway - 192.168.1.1

DNS 192.168.1.5

 

Windows 8 -

IP - 192.168.1.13

Subnet  mask - 255.255.255.0

Gateway - 192.168.1.1

DNS - 192.168.1.5

 

Though devices e.g iPhone won't pick up an IP dynamically from my DHCP on the server. 

 

Any ideas?

Share this post


Link to post
Share on other sites

Posted

The servers dns should point to itself. 127.0.0.1 there's your problem. Point the clients dns to the ip of the server. IE:192.168.1.5. Maybe that will help. I'm a little rusty...

Share this post


Link to post
Share on other sites

Posted

 

Hey,

 

So I've set up the server in Hyper-V and created a Windows 8 client. 

 

Server -

IP - 192.168.1.5

Subnet mask - 255.255.255.0

Gateway - 192.168.1.1

DNS 192.168.1.5

 

Windows 8 -

IP - 192.168.1.13

Subnet  mask - 255.255.255.0

Gateway - 192.168.1.1

DNS - 192.168.1.5

 

Though devices e.g iPhone won't pick up an IP dynamically from my DHCP on the server. 

 

Any ideas?

 

 

 

The adapters in VirtualBox are setup as Bridged, correct? I only ask because your first screenshot showed 10.0.2.X as the subnet of the guest.  What is your normal network's IP info look like?

 

 

The servers dns should point to itself. 127.0.0.1 there's your problem. Point the clients dns to the ip of the server. IE:192.168.1.5. Maybe that will help. I'm a little rusty...

 

That used to be the case, but best practice is to make the loopback secondary or tertiary in line.  http://technet.microsoft.com/en-us/library/ff807362(WS.10).aspx

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.