Jump to content

Question

Posted

Hi,
I've a D-Link DGE-528T Gigabit Ethernet Adapter PCI.
Connected to Dell OptiPlex GX620.
Built-in NIC is disabled from bios setup for the machine.
Running on Windows 8.1 Pro WMC 32x with 3 GB Ram.
I am using CAT.6 cable connected to a D-Link Gigabit Switch.
There are another 4 identical machine in the local network and all are reading 1 Gbps except this one.
Cables are all the same for all machines and same copy of windows with exact image using arconis true image.
I've tried all trouble shooting using google but no way out.
I updated 
These are the settings from device manager for this device:
DL23Hcvl.jpg
VSz6xPLl.jpg
Gc1mWdzl.jpg
fXoPtOyl.jpg
7RFWsaIl.jpg
YXfYGGxl.jpg
ruPexzvl.jpg
zAQsz2hl.jpg
AkxiB7El.jpg
p1nfi0xl.jpg
CMifevtl.jpg
beJhxL7l.jpg
dxKDJTzl.jpg
wI1fDmKl.jpg
3QErSicl.jpg
W445jdvl.jpg
FDxRAUsl.jpg
qtYG8NAl.jpg
MtFMel7l.jpg
So please help as this is very urgent for business purposes especially that vendor says it is working and nothing wrong with it.
Thanks a lot.

Share this post


Link to post
Share on other sites

10 answers to this question

  • 0

Posted

Check the cable. IIRC 10mbps and 100mbps only use 2 pairs (4 wires), whilst gigabit needs 4 pairs (8 wires).

Share this post


Link to post
Share on other sites
  • 0

Posted

If other identical machines do work there's probably something physically wrong with the port or the cable.

Share this post


Link to post
Share on other sites
  • 0

Posted

Check the cable. IIRC 10mbps and 100mbps only use 2 pairs (4 wires), whilst gigabit needs 4 pairs (8 wires).

Thanks for fast reply.

Yes it is 4 wires and all cables are the same brand and same length and I've bought them already ready to be connected.

This is really driving me nuts :(


If other identical machines do work there's probably something physically wrong with the port or the cable.

Thanks for replying me.

You mean the built-in port or you mean the eathernet pci card because the built-in port already disabled as I've mentioned earlier. Or you mean something else I am not aware of?

Share this post


Link to post
Share on other sites
  • 0

Posted

Ok 2 things i want to query:

 

1) You have a 7K MTU. Is the switch and other wired devices all capable of that size MTU?

2) Gigabit requires Auto Negotiation to be enabled. See http://en.wikipedia.org/wiki/Autonegotiation

 

 

The standards for 1000BASE-T, 1000BASE-TX and 10GBASE-T require autonegotiation to be always present and enabled.

Share this post


Link to post
Share on other sites
  • 0

Posted

If the cable is proper Cat6 it'll consist of four pairs, which is what you need.

 

Switch cables between computers and switch ports on the switch. If the situation remains completely the same, there is probably something physically broken on the port on the PCI card. If even one of the second set of pairs' pins is broken, for example, it'll consider the extra pairs needed for Gigabit unusable and will fall back to 100Mbps.

Share this post


Link to post
Share on other sites
  • 0

Posted

Have you tried changing the Auto Disable Gigabit off AC?  I mean, that suggests it's disabling Gigabit when the system is plugged in.

Share this post


Link to post
Share on other sites
  • 0

Posted

Ok 2 things i want to query:

 

1) You have a 7K MTU. Is the switch and other wired devices all capable of that size MTU?

2) Gigabit requires Auto Negotiation to be enabled. See http://en.wikipedia.org/wiki/Autonegotiation

 

Actually I've tried all options for each set and nothing changed.

But thanks for the tip and I will keep that in mind.

Yes all other machines have the same exact settings and all can send and receive the suitable 1 Gbps.

All settings in the picture above I've tried and you can imagine 3 hours trying this little thing lol.

If the cable is proper Cat6 it'll consist of four pairs, which is what you need.

 

Switch cables between computers and switch ports on the switch. If the situation remains completely the same, there is probably something physically broken on the port on the PCI card. If even one of the second set of pairs' pins is broken, for example, it'll consider the extra pairs needed for Gigabit unusable and will fall back to 100Mbps.

I did switched the cables but I will try once again. But I hope if the machine has nothing physically wrong.


Have you tried changing the Auto Disable Gigabit off AC?  I mean, that suggests it's disabling Gigabit when the system is plugged in.

Yes I did tried disabling this one as well ... Each set I disabled and apply settings then try once again. And disabled each one , one by one and tried but nothing changed.

Share this post


Link to post
Share on other sites
  • 0

Posted

After rebooting or did you just switch it?

Share this post


Link to post
Share on other sites
  • 0

Posted

Can you take the cable from one of the 1Gbs working machines and swap it out on the slow (100Mbps) one? One brand NIC's are the other devices using?

Share this post


Link to post
Share on other sites
  • 0

Posted

After rebooting or did you just switch it?

No, just switched and applied.

Can you take the cable from one of the 1Gbs working machines and swap it out on the slow (100Mbps) one? One brand NIC's are the other devices using?

Ok.

 

- later edit -

It seems that cable was the problem and it seems that all cables I tried with this machine were having problem as well.

I've bought a brand new cat.6 cable today and tried it and it is working now with 1 Gbps.

Thanks a lot for all participants and much appreciated your valuable time helping me.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.