Jump to content



Photo

NTFS - Storage Drive Unable to Mount

ntfs mount error ubuntu

  • Please log in to reply
12 replies to this topic

#1 jbarcus81

jbarcus81

    American

  • Joined: 30-November 01
  • Location: Ohio
  • OS: Ubuntu 14.04.1 LTS x64

Posted 26 July 2014 - 16:28

Just a fresh install of  Ubuntu 14.04.1 LTS and I unplugged my Storage drive to help prevent me mistakingly formatting the drive and losing EVERYTHING.. But, maybe something else is wrong here? I powered down, plugged it back into its SATA port and I get this... Granted, if it's an issue I can just put it back in my external drive case and plug it in the USB 3.0 port.. But I prefer to have it internal as the external power supply is required..

 

xxnFHo9.png




#2 +Jack Unterweger

Jack Unterweger

    in linux i trust

  • Tech Issues Solved: 2
  • Joined: 19-January 03
  • OS: Snapshot-Linux x64 1149 0.5
  • Phone: Samsung Galaxy S3

Posted 26 July 2014 - 16:41

I would just do what the dialog box says. Boot it in Windows and remove it safely in doubt also disable cache fastboot and how they are called. Then should mount properly in Ubuntu

#3 OP jbarcus81

jbarcus81

    American

  • Joined: 30-November 01
  • Location: Ohio
  • OS: Ubuntu 14.04.1 LTS x64

Posted 26 July 2014 - 17:05

I would just do what the dialog box says. Boot it in Windows and remove it safely in doubt also disable cache fastboot and how they are called. Then should mount properly in Ubuntu

So I need to go back to Windows just to 'remove' it? I'm not running Windows anymore.. I'm just wondering if mounting this externally would even help..



#4 +Jack Unterweger

Jack Unterweger

    in linux i trust

  • Tech Issues Solved: 2
  • Joined: 19-January 03
  • OS: Snapshot-Linux x64 1149 0.5
  • Phone: Samsung Galaxy S3

Posted 26 July 2014 - 17:20

So I need to go back to Windows just to 'remove' it? I'm not running Windows anymore.. I'm just wondering if mounting this externally would even help..

 

the problem is that afaik you did not remove it savely when you last tiime had pluged it in (i guess this was in windows). windows does this quite often, i had a friend whos data was lost even after savely removing it, i think its also because windows used to (or still does) to write the files on the hdd not right on time but delayed due to some cache setting thing.

 

maybe there is a guide how you can mount it still in linux now, but i would not advice you to do this, its risky to your data..



#5 x-scratch

x-scratch

    Whaaaaaaaat

  • Tech Issues Solved: 1
  • Joined: 19-November 03
  • Location: California, USA
  • OS: Ubuntu 14.10 (Gnome 3.14)
  • Phone: Iphone 5S

Posted 26 July 2014 - 17:23

make sure you have the correct mount setup. i have mine set to defauls,uid=1000,x-gvfs-show & works wonders



#6 Praetor

Praetor

    ASCii / ANSi Designer

  • Tech Issues Solved: 7
  • Joined: 05-June 02
  • Location: Lisbon
  • OS: Windows Eight dot One dot One 1!one

Posted 26 July 2014 - 17:37

that happens if you didn't shutdown properly on windows or you were using Windows 8, that has fast restarting.



#7 OP jbarcus81

jbarcus81

    American

  • Joined: 30-November 01
  • Location: Ohio
  • OS: Ubuntu 14.04.1 LTS x64

Posted 26 July 2014 - 17:52

make sure you have the correct mount setup. i have mine set to defauls,uid=1000,x-gvfs-show & works wonders

I can mount RO and it works fine.. all my files are still there and are fine..

 

Currently mount options are..

 

nosuid,nodev,nofail,x-gvfs-show


#8 OP jbarcus81

jbarcus81

    American

  • Joined: 30-November 01
  • Location: Ohio
  • OS: Ubuntu 14.04.1 LTS x64

Posted 26 July 2014 - 18:00

!!FIXED!!

 

http://linuxevangeli...n-gnulinux.html

 

I entered sudo ntfsfix /dev/sbd1 in terminal... all is better!! That was way too simple.. lol



#9 Jones111

Jones111

    Neowinian

  • Joined: 30-October 08

Posted 27 July 2014 - 10:59

the problem is that afaik you did not remove it savely when you last tiime had pluged it in (i guess this was in windows). windows does this quite often, i had a friend whos data was lost even after savely removing it, i think its also because windows used to (or still does) to write the files on the hdd not right on time but delayed due to some cache setting thing.

 

maybe there is a guide how you can mount it still in linux now, but i would not advice you to do this, its risky to your data..

 

The problem is that if you use caching, advanced caching etc. Windows will write to and read from the cache to give you way better performance. If you don't want that, like on external drives, simply disable the cache completely for that affected drive and you can remove it after the file transfer is finished. Don't blame an OS where the user can choose the behavior. That's especially to you Linux-users.



#10 +Jack Unterweger

Jack Unterweger

    in linux i trust

  • Tech Issues Solved: 2
  • Joined: 19-January 03
  • OS: Snapshot-Linux x64 1149 0.5
  • Phone: Samsung Galaxy S3

Posted 27 July 2014 - 11:02

The problem is that if you use caching, advanced caching etc. Windows will write to and read from the cache to give you way better performance. If you don't want that, like on external drives, simply disable the cache completely for that affected drive and you can remove it after the file transfer is finished. Don't blame an OS where the user can choose the behavior. That's especially to you Linux-users.

 

no i blame this on the os. such things should, especially if they tend to confuse users, be on disabled by default not by user.

if i have an external hd connected on linux i can remove it even unsafely and perfectly connect it to windows or mac os x or whatever without having such problems.

this is windows to blame, not the user or linux. a bit like windows just refuses to implement drivers to read ext3/4 disks and partitions while on the other hand you can easily read/write ntfs partitions on linux.



#11 Jones111

Jones111

    Neowinian

  • Joined: 30-October 08

Posted 27 July 2014 - 11:15

no i blame this on the os. such things should, especially if they tend to confuse users, be on disabled by default not by user.

if i have an external hd connected on linux i can remove it even unsafely and perfectly connect it to windows or mac os x or whatever without having such problems.

this is windows to blame, not the user or linux. a bit like windows just refuses to implement drivers to read ext3/4 disks and partitions while on the other hand you can easily read/write ntfs partitions on linux.

 

Yup, super easy and intuitive:

https://bugs.launchp...s2/ bug/1067876



#12 +Jack Unterweger

Jack Unterweger

    in linux i trust

  • Tech Issues Solved: 2
  • Joined: 19-January 03
  • OS: Snapshot-Linux x64 1149 0.5
  • Phone: Samsung Galaxy S3

Posted 27 July 2014 - 11:21

the thread creator had a problem which was solved days ago. whats your intention here to even post?



#13 Jones111

Jones111

    Neowinian

  • Joined: 30-October 08

Posted 27 July 2014 - 12:04

the thread creator had a problem which was solved days ago. whats your intention here to even post?

 Maybe there are others who have this problem and stumble over this post. So making them aware that there are caching and removal options are in any OS which could lead to such problems is still important.