Jump to content



Photo

PC won't stay in "sleep" mode

Answered Go to the full post win7

  • Please log in to reply
14 replies to this topic

#1 TDT

TDT

    Hey yo!

  • Tech Issues Solved: 2
  • Joined: 17-March 10
  • Location: Bucharest, Romania

Posted 30 July 2014 - 19:06

Hi guys. I have a problem with a PC, as the title says, it won't stay in sleep mode and I don't know why. I click the sleep option, it looks like it's going to sleep, but it "turns off" for half a second or so, before "resuming". I've checked the bios and there's nothing enabled there that could wake the PC, but, interestingly, the output of "powercfg -lastwake" command shows 

Wake History Count - 1
Wake History [0]
  Wake Source Count - 1
  Wake Source [0]
    Type: Device
    Instance Path: USB\ROOT_HUB\4&e097488&0
    Friendly Name:
    Description: USB Root Hub
    Manufacturer: (Standard USB Host Controller)

and that thing is the USB port where the mouse is plugged in. In the Power Management tab of the device, the "allow this device to wake the computer" option is not checked and it's greyed out, like on all other USB Root Hub devices there.

 

The MB chipset drivers are installed, so that's not the issue. Should I get rid of the mouse?  :laugh:



Best Answer xendrome , 30 July 2014 - 19:21

Are you guys disabling the Allow Device to Wake computer on the HID Input devices and Mouse/Keyboard devices?

Go to the full post



#2 Roger H.

Roger H.

    Neowinian Senior

  • Tech Issues Solved: 22
  • Joined: 18-August 01
  • Location: Germany
  • OS: Windows 8.1
  • Phone: Nexus 5

Posted 30 July 2014 - 19:07

Seems like you figured out everything needed ;)

#3 Jason S.

Jason S.

    Neowinian Senior

  • Tech Issues Solved: 6
  • Joined: 01-September 03
  • Location: Cleveland, Ohio

Posted 30 July 2014 - 19:12

What OS? I have this problem on 8.1; hasnt been fixed



#4 xrobwx

xrobwx

    Leave the gun. Take the cannoli.

  • Tech Issues Solved: 1
  • Joined: 14-June 03
  • Location: Panama City Beach, FL USA
  • OS: Win 8.1
  • Phone: Galaxy Note II

Posted 30 July 2014 - 19:19

What OS? I have this problem on 8.1; hasnt been fixed

Same here. I have been looking for a fix and if I find one I'll post here of course. 



#5 xendrome

xendrome

    In God We Trust; All Others We Monitor

  • Tech Issues Solved: 14
  • Joined: 05-December 01
  • OS: Windows 8.1 Pro x64

Posted 30 July 2014 - 19:21   Best Answer

Are you guys disabling the Allow Device to Wake computer on the HID Input devices and Mouse/Keyboard devices?



#6 Jason S.

Jason S.

    Neowinian Senior

  • Tech Issues Solved: 6
  • Joined: 01-September 03
  • Location: Cleveland, Ohio

Posted 30 July 2014 - 19:21

Are you guys disabling the Allow Device to Wake computer on the HID Input devices and Mouse/Keyboard devices?

not sure if ive tried this. i kind of just gave up. how does one do this?



#7 OP TDT

TDT

    Hey yo!

  • Tech Issues Solved: 2
  • Joined: 17-March 10
  • Location: Bucharest, Romania

Posted 30 July 2014 - 19:29

It's Win 7 x64.



#8 xendrome

xendrome

    In God We Trust; All Others We Monitor

  • Tech Issues Solved: 14
  • Joined: 05-December 01
  • OS: Windows 8.1 Pro x64

Posted 30 July 2014 - 19:31

not sure if ive tried this. i kind of just gave up. how does one do this?

 

Go into device manager and open up the "Human Interface Devices" section, double click each device, look for Power Management tab, and uncheck allow this device to wake.

Also check Mice and Keyboard sections and check those devices as well.

 

Another thing to do is check your Power Profile, Advanced settings and make sure "Allow Wake Timers" is disabled.



#9 OP TDT

TDT

    Hey yo!

  • Tech Issues Solved: 2
  • Joined: 17-March 10
  • Location: Bucharest, Romania

Posted 30 July 2014 - 19:33

Are you guys disabling the Allow Device to Wake computer on the HID Input devices and Mouse/Keyboard devices?

Yeah, that did it, both the mouse and the keyboard had that option checked. I unchecked it for both and the PC sleeps like a baby now. :D Thanks!



#10 xendrome

xendrome

    In God We Trust; All Others We Monitor

  • Tech Issues Solved: 14
  • Joined: 05-December 01
  • OS: Windows 8.1 Pro x64

Posted 30 July 2014 - 20:21

Yeah, that did it, both the mouse and the keyboard had that option checked. I unchecked it for both and the PC sleeps like a baby now. :D Thanks!

 

You can keep the keyboard one checked if you want and you should be able to just press spacebar to wake the system, unless it's a wireless keyboard then it might wake on it's own.



#11 jimmy_jazz

jimmy_jazz

    Neowinian

  • Tech Issues Solved: 1
  • Joined: 19-May 04

Posted 30 July 2014 - 20:36

It is likely to be a USB device attached to your PC, from experience changing sleep settings won't make any difference. One by one physically remove USB devices and see if it will stay in sleep mode when removed. When you have identified which device it is causing the problem, bin it and get another one.



#12 xendrome

xendrome

    In God We Trust; All Others We Monitor

  • Tech Issues Solved: 14
  • Joined: 05-December 01
  • OS: Windows 8.1 Pro x64

Posted 30 July 2014 - 22:14

It is likely to be a USB device attached to your PC, from experience changing sleep settings won't make any difference. One by one physically remove USB devices and see if it will stay in sleep mode when removed. When you have identified which device it is causing the problem, bin it and get another one.

 

Nice job reading the thread, it was a USB device, the setting did make a difference, and that's stupid advice to "bin" a piece of hardware over such a simple fix.



#13 OP TDT

TDT

    Hey yo!

  • Tech Issues Solved: 2
  • Joined: 17-March 10
  • Location: Bucharest, Romania

Posted 31 July 2014 - 00:00

Nice job reading the thread, it was a USB device, the setting did make a difference, and that's stupid advice to "bin" a piece of hardware over such a simple fix.

This really made me laugh  :laugh:



#14 COKid

COKid

    Neowinian Senior

  • Joined: 07-April 10
  • Location: Loveland, CO

Posted 31 July 2014 - 00:16

Pfft! Everyone knows you need to read it a bedtime story first. Then it will go to sleep. :sleep:



#15 jimmy_jazz

jimmy_jazz

    Neowinian

  • Tech Issues Solved: 1
  • Joined: 19-May 04

Posted 01 August 2014 - 11:46

Nice job reading the thread, it was a USB device, the setting did make a difference, and that's stupid advice to "bin" a piece of hardware over such a simple fix.

 

That will teach me to post when I'm drunk

 

Sorry sweetie x