Sign in to follow this  
Followers 0
elenarie

Mark as Solved bug

7 posts in this topic

IE11 x64 with EPM on Win 8.1 x64 / fully updated.

 

Weird thing when marking posts as solutions. If you mark post X as a solution, X's poster will get his issues solved counter increased by 1. But afterwards if you change your mind, and mark Y as the solution without first clicking on the X post to unmark that one, Y will get his issues solved counter increased by one, but X's won't be reduced by one.

 

Then you can repeat the process backwards, and their counters will just keep rising. I guess this may be something to have a look at, as it can be exploited.

 

Example of where this happened: http://www.neowin.net/forum/topic/1224415-visual-studio-iso-ed-updates/#entry596520065

Share this post


Link to post
Share on other sites

Did you do these steps by also refreshing the page fully (before marking unresolved, and then marking another post resolved)?

Share this post


Link to post
Share on other sites

Did you do these steps by also refreshing the page fully (before marking unresolved, and then marking another post resolved)?

 

I am like 95% sure that I did not.

Share this post


Link to post
Share on other sites

Also had this problem before and if you modify the url of the check as solved it's possible to abuse it to check your own answer as solved as I said before.

Share this post


Link to post
Share on other sites

Well I just tried it myself and I was able to mark elenarie's post as the answer, and then mark unsolved and the count went fromn 3 back to 2. I also did the same on Seahorsepip's post and the solved numbers are still correct, (elenarie stayed at 2) not a bug.

Share this post


Link to post
Share on other sites

Oh, it is definitely happening. I just increased your count by three and Sea's count as well.

 

Mind you, I am not clicking the Mark Unsolved button. But just straight clicking on another person's Mark Solved button.

Share this post


Link to post
Share on other sites

Well I just tried it myself and I was able to mark elenarie's post as the answer, and then mark unsolved and the count went fromn 3 back to 2. I also did the same on Seahorsepip's post and the solved numbers are still correct, (elenarie stayed at 2) not a bug.

Correct? I remember to have my solved number on 19 before :p

 

When I go to my answered posts in my profile I see 15 answers not 20 O.o

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.