Sign in to follow this  
Followers 0
cbrookhart

firefox Firefox running slow

6 posts in this topic

Lately, about once or twice a week I am having to reset Firefox (Firefox 31) because it becomes unbearably slow. I've been doing a Firefox reset over the past month, and initially the reset would restore the tabs. Now when I do the reset, none of my tabs come back.

 

Why is Firefox becoming so slow where it takes over a minute to scroll down a page or takes several minutes just to open?

 

Why the is the reset now not restoring my tabs?

Share this post


Link to post
Share on other sites

Tried running without addons to see if it's one of them causing the issue? I've had one or two that could seriously slow it down, last one was one of the "linkification" addons, especially on javascript heavy sites it clobbered the browser. Just run it in safe mode (Firefox's, not your OS) and see if it's still dragging.

Could always try building a new profile too.. once in a long while the data get get a little wonky and it'll do strange things.

Share this post


Link to post
Share on other sites

I've long since given up trusting firefox's session manager. i use Session Manager extension now and it's MUCH more reliable

 

as far as the slowing down. how many tabs do you have open on average? do any of the tabs have flash loaded? also how much ram does your computer have? also, what extensions do you have?

 

if you have 8gigs or less ram & 20+ tabs open (with at least a few containing flash content) then you'll definitely start to notice slow downs in firefox due to ram usage and a few other things after a week or two

Share this post


Link to post
Share on other sites

you can try running firefox in safe mode which will disable all add-ons

or you can try disabling the add-ons individually thru the add-ons page. it doesnt uninstall them it just turns them off and then you can turn them back on

Share this post


Link to post
Share on other sites

usually, Firefox slowness problem is cause of Addons not because of Firefox itself.

1 person likes this

Share this post


Link to post
Share on other sites

Add-ons Manager --> Plugins --> set 'Ask to Activate' for all plugins.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.