Jump to content



Photo

Dual monitor issue with AMD


  • Please log in to reply
4 replies to this topic

#1 Sinster

Sinster

    Neowinian

  • Joined: 25-August 05

Posted 15 August 2014 - 03:29

I recently upgraded from two 6970 to two 280X.   The other day I hooked up my 2nd monitor back up.  Now everything I play a game and exit back to the desktop my main monitor screen goes crazy like it has the wrong refresh rate.  I get a bunch of flickering, noise lines, and what not.  I end up having to reboot.     I'm running 14.6RC drivers and once I remove the 2nd monitor everything works fine.  I'm running the monitors as extended desktop. One monitor is hook up via DVI and the other HDMI.  Both monitors are running at 1920 x 1080 with 60Hz refresh rate. 




#2 Hum

Hum

    totally wAcKed

  • Tech Issues Solved: 10
  • Joined: 05-October 03
  • Location: Odder Space
  • OS: Windows XP, 7

Posted 16 August 2014 - 00:41

Are the old drivers completely removed ?

 

Perhaps if you take out all video drivers and Reinstall the latest video drivers.

 

Run the Registry cleaner from CCleaner (free) after you remove all video drivers, and before you install the newest drivers.

 

Also check all the optional video settings, after the new install.



#3 Max Norris

Max Norris

    Neowinian Senior

  • Tech Issues Solved: 16
  • Joined: 20-February 11
  • OS: Windows 8.1, BSD Unix
  • Phone: HTC One (Home) Lumia 1020 (Work)

Posted 16 August 2014 - 01:01

Just to toss it out there, could always be a bug in the driver too.  Last official is 14.4, and personally I'm having zero issues with multiple monitors with 14.7 beta, has been rock solid for me.



#4 OP Sinster

Sinster

    Neowinian

  • Joined: 25-August 05

Posted 16 August 2014 - 08:21

I will give these suggestions a go.  

 

There could be old drivers left behind, but I always use CCleaner as you suggested when update my video drivers. 

 

I've downloaded the 14.7 and haven't installed them.  That's because as soon as I install them the official ones will be released and or 14.8 ;) 



#5 Luc2k

Luc2k

    Neowinian

  • Tech Issues Solved: 3
  • Joined: 16-May 09

Posted 16 August 2014 - 13:33

I will give these suggestions a go.  

 

There could be old drivers left behind, but I always use CCleaner as you suggested when update my video drivers. 

 

I've downloaded the 14.7 and haven't installed them.  That's because as soon as I install them the official ones will be released and or 14.8 ;)

CCleaner is not really ideal for this. Use Display Driver Uninstaller instead.