Jump to content
  • 0
Sign in to follow this  
Followers 0

Dual monitor issue with AMD

Question

Posted

I recently upgraded from two 6970 to two 280X.   The other day I hooked up my 2nd monitor back up.  Now everything I play a game and exit back to the desktop my main monitor screen goes crazy like it has the wrong refresh rate.  I get a bunch of flickering, noise lines, and what not.  I end up having to reboot.     I'm running 14.6RC drivers and once I remove the 2nd monitor everything works fine.  I'm running the monitors as extended desktop. One monitor is hook up via DVI and the other HDMI.  Both monitors are running at 1920 x 1080 with 60Hz refresh rate. 

Share this post


Link to post
Share on other sites

4 answers to this question

  • 0

Posted

Are the old drivers completely removed ?

 

Perhaps if you take out all video drivers and Reinstall the latest video drivers.

 

Run the Registry cleaner from CCleaner (free) after you remove all video drivers, and before you install the newest drivers.

 

Also check all the optional video settings, after the new install.

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Posted

Just to toss it out there, could always be a bug in the driver too.  Last official is 14.4, and personally I'm having zero issues with multiple monitors with 14.7 beta, has been rock solid for me.

2 people like this

Share this post


Link to post
Share on other sites
  • 0

Posted

I will give these suggestions a go.  

 

There could be old drivers left behind, but I always use CCleaner as you suggested when update my video drivers. 

 

I've downloaded the 14.7 and haven't installed them.  That's because as soon as I install them the official ones will be released and or 14.8 ;) 

Share this post


Link to post
Share on other sites
  • 0

Posted

I will give these suggestions a go.  

 

There could be old drivers left behind, but I always use CCleaner as you suggested when update my video drivers. 

 

I've downloaded the 14.7 and haven't installed them.  That's because as soon as I install them the official ones will be released and or 14.8 ;)

CCleaner is not really ideal for this. Use Display Driver Uninstaller instead.

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.