Jump to content



Photo

4670K down clocking Itself


  • Please log in to reply
4 replies to this topic

#1 +Fractalizer

Fractalizer

    Cupcakes!

  • Joined: 03-February 09
  • Location: England
  • OS: Windows 7 Professional x64 Service Pack 1

Posted 25 August 2014 - 17:22

So I Installed Windows 8.1 to give it a go and after setting up everything and then Installing Samsung Magician for my SSD to set up Windows for it then I then Of course went into System Management -> OS Optimization and selected "Maximum Reliability" and then re-booted the system. 

 

LlQ643F.png

 

Upon doing that it created a new Power Profile called Samsung High Performance.

 

bgiTWEl.png

 

Then after doing all this I loaded up CPU-Z to just make sure everything was as expected and for the last few days I thought it was then I realized after watching a Tech Video last night that Haswell CPUs down clock themselves when they are barely doing anything and I remembered that with just CPU-Z Open my CPU Was running on 3.8 GHZ not the 800MHZ I should be seeing and this was doing it on Windows 7 as well.

 

oodLDUV.png

 

So I did a bit of googling and found out that this could be either due to something that I disabled in the BIOS (Which I didn't) or it could be in the power options in windows which lead me to go poking around in that Samsung High Performance Power Plan and I found this...

 

eM4J4jg.png

 

So I copied the Minimum Processor State number from the Power Saver Power Plan which was 5% and changed it so it now looks like this.

 

iDV9V1y.png

 

Now I had CPU-Z open when I did this and I noticed that my CPU Turbod Down.

 

3vGbaK9.png

 

Now I was wondering if I did this right and I havn't just done some Janky ass fix and if I am missing something to why it was never turboing down or if I did it correctly and if that will cause any CPU issues at all?




#2 Krome

Krome

    Neowinian God!

  • Joined: 29-August 01

Posted 25 August 2014 - 17:34

One of my old CPU does that. It's just to cool down the CPU.. a way to save energy... but when it needs high processing power, it burst back to it's original spec...



#3 tsupersonic

tsupersonic

    Neowinian Senior

  • Tech Issues Solved: 3
  • Joined: 30-September 06
  • Location: USA
  • OS: Win. 8.1 Pro. x64/Mac OS X
  • Phone: iPhone 5S/Nexus 5

Posted 25 August 2014 - 17:36

Selecting High Performance power mode will make your CPU run at full speed. Keep it on balanced and it will down clock to 800 MHz, and clock up when there's load on the CPU. 



#4 OP +Fractalizer

Fractalizer

    Cupcakes!

  • Joined: 03-February 09
  • Location: England
  • OS: Windows 7 Professional x64 Service Pack 1

Posted 25 August 2014 - 17:47

Selecting High Performance power mode will make your CPU run at full speed. Keep it on balanced and it will down clock to 800 MHz, and clock up when there's load on the CPU. 

 

I got that bit but I was wondering if what I did by changing the minimum speed down to 5% was the right way to get it to down clock to 800MHz again while keeping all the other settings samsung magician made in tact.



#5 tsupersonic

tsupersonic

    Neowinian Senior

  • Tech Issues Solved: 3
  • Joined: 30-September 06
  • Location: USA
  • OS: Win. 8.1 Pro. x64/Mac OS X
  • Phone: iPhone 5S/Nexus 5

Posted 25 August 2014 - 17:49

I got that bit but I was wondering if what I did by changing the minimum speed down to 5% was the right way to get it to down clock to 800MHz again while keeping all the other settings samsung magician made in tact.

you should be fine, this is what I am doing on my desktop as well (I have the 4670). You just edited the windows power profile and leaving the drive optimized for reliability.