Jump to content



Photo

Chrome not shutting down properly

chrome

  • Please log in to reply
8 replies to this topic

#1 cbrookhart

cbrookhart

    Neowinian

  • Joined: 07-February 06
  • Location: Staten Island, NY

Posted 08 December 2014 - 17:56

Just about every time I open Google Chrome, it displays a message that it did not shut down properly. When I have multiple tabs open, sometimes I will close each tab individually. Other times I just close Chrome by clicking in the X in the upper right corner. Regardless of what method I use to exit Chrome, I get this message. What can I do so that this doesn't come up every time?




#2 +Zlip792

Zlip792

    Neowinian Senior

  • Tech Issues Solved: 16
  • Joined: 31-October 10
  • Location: Pakistan
  • OS: Windows 8.1 Pro 64-bit
  • Phone: Nokia C3-00 (8.70 firmware)

Posted 08 December 2014 - 18:01

Try one by one all below.

- Untick following option from Chrome Advanced Settings:

 

q8HPnBw.png

 

- Go to following URL:

chrome://version/

and copy paste, Command Line here, so we can see you might not be in some field trial experiment with stupid flags turned on.

 

- If nothing works, Sync your stuff and go to Documents and Settings in Windows OS drive then navigate to "user\appdata\local\google\chrome\userdata\", rename default folder to "default_old" (without quotes) and then start Chrome, where it will create new profile, then sync back your old stuff.



#3 OP cbrookhart

cbrookhart

    Neowinian

  • Joined: 07-February 06
  • Location: Staten Island, NY

Posted 12 December 2014 - 17:03

I've unchecked the 'continue running background apps when Chromium is closed' option. Hopefully that will fix the problem.

 

Here is the command line from Chrome:

 

"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --flag-switches-begin --flag-switches-end



#4 +Zlip792

Zlip792

    Neowinian Senior

  • Tech Issues Solved: 16
  • Joined: 31-October 10
  • Location: Pakistan
  • OS: Windows 8.1 Pro 64-bit
  • Phone: Nokia C3-00 (8.70 firmware)

Posted 12 December 2014 - 18:10

I've unchecked the 'continue running background apps when Chromium is closed' option. Hopefully that will fix the problem.

 

Here is the command line from Chrome:

 

"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --flag-switches-begin --flag-switches-end

 

You didn't have any experimental flags enabled. If problem will be fixed, let us know by commenting here.



#5 Anibal P

Anibal P

    Neowinian

  • Tech Issues Solved: 1
  • Joined: 11-June 02
  • Location: Waterbury CT
  • OS: Win 8.1
  • Phone: Android

Posted 13 December 2014 - 18:38

Chrome does that to me, I also run the Hangouts app, you have to close out any apps/extensions that may be also running outside of the browser or you get the error 



#6 OP cbrookhart

cbrookhart

    Neowinian

  • Joined: 07-February 06
  • Location: Staten Island, NY

Posted 17 December 2014 - 16:22

Still getting the 'Chrome did not shut down properly' message. If there is a tab that I want to keep open, and I close the lid on the computer, it will make Chrome shut down. If I close every tab and then come back to Chrome later, I get this message.

 

The only other application I would be running is a game, but I close out of that. What I want to accomplish is to be able to open Chrome without getting a message every single time that it did not shut down properly.



#7 +Zlip792

Zlip792

    Neowinian Senior

  • Tech Issues Solved: 16
  • Joined: 31-October 10
  • Location: Pakistan
  • OS: Windows 8.1 Pro 64-bit
  • Phone: Nokia C3-00 (8.70 firmware)

Posted 17 December 2014 - 16:37

Still getting the 'Chrome did not shut down properly' message. If there is a tab that I want to keep open, and I close the lid on the computer, it will make Chrome shut down. If I close every tab and then come back to Chrome later, I get this message.

 

The only other application I would be running is a game, but I close out of that. What I want to accomplish is to be able to open Chrome without getting a message every single time that it did not shut down properly.

 

- Open this using RUN:

%UserProfile%\AppData\Local\Google\Chrome\User Data\Default

or this

%UserProfile%\AppData\Local\Chrome\User Data\Default

- Open Preferences file from this folder in "Notepad"

- Find "exit_type" using F3 or Ctrl+F

- remane exit_type : "crashed" to exit_type : "normal"



#8 OP cbrookhart

cbrookhart

    Neowinian

  • Joined: 07-February 06
  • Location: Staten Island, NY

Posted 19 December 2014 - 11:48

Still getting the message that the browser did not shut down properly, even after making the change above.



#9 +Zlip792

Zlip792

    Neowinian Senior

  • Tech Issues Solved: 16
  • Joined: 31-October 10
  • Location: Pakistan
  • OS: Windows 8.1 Pro 64-bit
  • Phone: Nokia C3-00 (8.70 firmware)

Posted 19 December 2014 - 12:10

Still getting the message that the browser did not shut down properly, even after making the change above.

 

- Rename, Default folder to Default_old

- Open Chrome and let it create new profile