Jump to content



Photo

Firefox v38 - makes YouTube totally unusable


18 replies to this topic

#1 T3X4S

T3X4S

    Neowinian Senior

  • Tech Issues Solved: 4
  • Joined: 28-October 13

Posted 06 May 2015 - 09:39

Since v38 has forced HTML5, I can not watch a single video now.  I have had this problem for a while and cant find the culprit.

Only way I can watch a vid is via Flash.  Furthermore, if someone were to embed a video from Youtube into a webpage in neowin, I would not be able to watch the vid, I would have to go to YouTube to watch that video... via the default flash player... but now, that isnt an option.

When I click on a video, I get the white-ish grey circles rotating, but it never stops, and the video never starts.  If I hover over the placemarker to advance somewhere in the video, I see the little thumbnail over the placemarker, but when I click Start - nothing happens.

I have disabled addons to see if that was causing it - no change.

 

I have switched to Chrome now, but would rather FF work correctly.

Anyone have any ideas ?

Thanks 

ew.JPG




#2 vanx

vanx

    Neowinian Senior

  • Tech Issues Solved: 2
  • Joined: 23-April 09

Posted 06 May 2015 - 10:01

Yep, it's YouTube's way of saying "What is wrong with you? Why are you watching Ariana Grande stuff?"  :laugh:



#3 cork1958

cork1958

    Neowinian

  • Tech Issues Solved: 2
  • Joined: 04-October 02

Posted 06 May 2015 - 10:29

I guess that's what happens when you want to run beta software! ;)

 

Expect issues and bugs.



#4 OP T3X4S

T3X4S

    Neowinian Senior

  • Tech Issues Solved: 4
  • Joined: 28-October 13

Posted 06 May 2015 - 10:32

I guess that's what happens when you want to run beta software! ;)

 

Expect issues and bugs.

It was the same with 36, and 37.

If you read my original post, you will see I mentioned it has been an issue for a while, but before I was able to select the default flash player.

 


Yep, it's YouTube's way of saying "What is wrong with you? Why are you watching Ariana Grande stuff?"  :laugh:

I was wondering if someone was going to comment on that - it was on my main page - I like the Jimmy Fallon stuff ;)



#5 Pikey

Pikey

    Neowinian

  • Joined: 19-February 02

Posted 06 May 2015 - 10:36

I was having a similar problem a week or so ago with a 'nightly' build but one of the updates along the way sorted it! ... (Youtube seemed to be OK though?)

 

I'm on *40.0a1 (2015-05-05)* at the moment ... maybe you could try the latest 'nightly' out?



#6 torrentthief

torrentthief

    Neowinian Senior

  • Joined: 18-November 06

Posted 06 May 2015 - 10:43

maybe try creating a new profile. Also try uninstalling firefox first before deleting profile then re-install with a new profile. HTML5 video rocks, i'm glad flash is dying, hope you sort your problem though.



#7 Ace

Ace

    Neowinian

  • Joined: 06-November 01
  • Location: United Kingdom

Posted 06 May 2015 - 10:57

Have you tried an add-on like the one below to force videos to play with Flash Player?

 

https://addons.mozil...h-video-player/



#8 OP T3X4S

T3X4S

    Neowinian Senior

  • Tech Issues Solved: 4
  • Joined: 28-October 13

Posted 06 May 2015 - 13:05

Have you tried an add-on like the one below to force videos to play with Flash Player?

 

https://addons.mozil...h-video-player/

Yes I did - unfortunately no difference.

Here is a weird update....

I clicked on a video and instead of seeing the circles rotate then do nothing - I just sat there, and after about 10 seconds, the video started to play, then stops after 1-2 seconds with an error.

I click on the "about this error" and it says there is no information about the error.  I went to YouTube's TestTube site, and tried the new player - no difference.

I will try the tips mentioned here


Thank You

 

FWIW - I also loaded the new player (I think its supposed to be tweaked for 4K @ 60 fps, and HD stuff - it performed perfectly on chrome - I like the new look of it too, even if it is subtle.


Test Tube



#9 Nelsinho

Nelsinho

    Andromeda is my destiny

  • Joined: 13-January 04
  • Location: São Paulo city Brazil
  • OS: Windows 8.1 PRO x64

Posted 06 May 2015 - 13:50

I guess that's what happens when you want to run beta software! ;)

 

Expect issues and bugs.

yep FF x64 still in development v40A1 in 05.05.2015 here :)



#10 elenarie

elenarie

    Newbie .NET / game dev

  • Tech Issues Solved: 4
  • Joined: 23-March 14
  • OS: Windows 8.1 Pro x64
  • Phone: Lumia 920 Yellow

Posted 06 May 2015 - 13:58

Same happens to me in IE11 x64 sometimes.



#11 techbeck

techbeck

    It's not that I am lazy, it's that I just don't care

  • Tech Issues Solved: 17
  • Joined: 20-January 05

Posted 06 May 2015 - 14:01

Isnt 38 still in development?



#12 Jason S.

Jason S.

    Neowinian Senior

  • Tech Issues Solved: 6
  • Joined: 01-September 03
  • Location: Cleveland, Ohio

Posted 06 May 2015 - 14:03

OP - just throwing my 2c out there. I have the latest official build, v37, and have zero issues with Youtube. I even tried that Test Tube stuff you linked us to. It works great.

 

What i could try is v38 in a VM... i just think your computer might have another underlying issue that isnt related to FF directly.



#13 Hurricane Andrew

Hurricane Andrew

    Neowinian

  • Joined: 03-October 06
  • Location: Delaware
  • Phone: Galaxy S4

Posted 06 May 2015 - 14:18

No issues here with FF v38 and Youtube.



#14 purrcher

purrcher

    Neowinian

  • Joined: 10-May 09
  • OS: Windows & Linux
  • Phone: Android

Posted 06 May 2015 - 14:18

It sounds like the "mediasource:" script is being blocked on your system. Do you have a script blocker like noscripts installed? If so you need to allow "mediasource:" and then on youtube I think it will be "googlevideo.com" will show up and that will also need to be allowed to run html5 video's on youtube.



#15 PanzerFury

PanzerFury

    Neowinian

  • Joined: 26-November 12

Posted 06 May 2015 - 14:19

I don't think that newest versions of Firefox have MSE enabled by default, even on Windows.

 

You can check if your browser supports MSE extensions here https://www.youtube.com/html5

 

Anyway, to manually enable this feature, you have to go to address:  about:config

 

find the key: media.mediasource.enabled

 

and set it from false to true.

 

That should fix your problems.