Sign in to follow this  
Followers 0
Spyder

CD burner "not accessible. Incorrect function"

19 posts in this topic

Hi guys.. I've been trying to troubleshoot this for the past 2 hours with no luck so far, so I thought I'd turn to this resource in the hope that someone may have had the problem and has fixed it and can share how.

Anyways, the problem is this: When I put a blank CD in my burner, the my computer icon changes from "CD-RW Drive" to "CD Drive". The icon is just a normal drive instead of the proper icon that says CDR on it when you put in a blank CD.

Further to that, the autorun dialog doesn't pop up. If I double click the drive with the blank cd in it, I get "E:\ drive not accessible. Incorrect function"

Has ANYONE had this problem before and fixed it? If so, please say how you did so I can make things normal again. Thanks!

(PS. The properties of the drive has the Recording tab, so XP is detecting it as a burner fine. It also burns fine. To reiterate, the issue is that when I put in a blank CD, the drive changes to read "CD Drive" and doesn't display the correct icon.)

Share this post


Link to post
Share on other sites

That either means the CD burner or the CD media is .... BAD!

Share this post


Link to post
Share on other sites

the hardware and media is fine. I've uninstalled some burning software and I think that's what caused the problem. It must've removed a registry entry or something. I'm confident that a format would fix this tiny little issue, but I'd rather not go that far. I'd rather fix it if possible.

which is why I'm asking for help from those who might have previously had this problem. not random guesses.

Share this post


Link to post
Share on other sites

This often happens to me. I just ignore it and click on the drive, or use Nero.

Autoplay is an annoyance for me. And the icon changes or not as it likes, it does not affect the usefulness of the drive.

I would just ignore it..

:unsure:

Share this post


Link to post
Share on other sites

well see, i'm the type of person who cant ignore it. 1) its never done this before and 2) its not supposed to do this.

so it'll eat away at me until I fix it unfortunately. i'm just not a fan of "format to fix the problem" as most of the time I find a way to fix it without going that far.

Share this post


Link to post
Share on other sites

Go into the device manager and uninstall the cd drive's driver. then shutdown and restart. Windows should notice a new peice of hardware. Alas it is your cdrom. It should reinstall the driver for it.

I have never had that problem, but it sounds very much like a driver problem.

Share this post


Link to post
Share on other sites

good idea kongit but unfortunately i've tried that already during my troubleshooting. didn't work

Share this post


Link to post
Share on other sites

oh well. Windows sucks in the hardware department for long term use with out problems. Great at installing hard ware though.

Share this post


Link to post
Share on other sites

try deleting UpperFilters and LowerFilters from HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318} backup first, delete, then restart

edit: from both microsoft and roxio knowledge base

Share this post


Link to post
Share on other sites

thx mate, I've already tried that too.

Share this post


Link to post
Share on other sites

what burning software did you uninstall?

Share this post


Link to post
Share on other sites

roxio easy media creator 7. I'm only guessing that they're related as I didn't notice this issue prior to uninstalling it. (i've also posted on their forum)

Share this post


Link to post
Share on other sites

has anyone experienced this and fixed the problem?

Share this post


Link to post
Share on other sites

FYI.. I've fixed the icon when I insert a blank cd. It displays the cd icon with a CDR on it now. big thanks to dazzla. what fixed it was in REGEDIT, go to...

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\DriveIcons

in drive icons, there was an E and an F under that on my PC. each of those had "DefaultIcon" .. deleted both of those, rebooted and all is fixed.

so again, thanks to dazzla!

now i just need to fix the damn thing from changing to say CD Drive when I insert a blank cd

PS. i was wrong..roxio 7 didnt cause my problem. the icon issue was caused by Stardock Iconpackager. the other issue i dunno yet, but dazzla has it too and he's never used roxio.

sooo roxio users rejoice!

Share this post


Link to post
Share on other sites

ok maybe this is proper functionality. could anyone with a cdburner and XP confirm something for me.

open My Computer. Your burner says "CD-RW Drive" right? Put in a blank CD. Does the drive change suddenly to say "CD Drive"?

Somone please confirm. Thanks!

Share this post


Link to post
Share on other sites

It does change, but the icon changes to CDR for me;

im wondering if this problem is actually standard function and we've never noticed before?!

Share this post


Link to post
Share on other sites

Changing to "CD-Drive" is the standard function, although you can change it in the registry:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\DriveIcons\

Choose your drive and add the key "DefaultLabel" and change it to what you want.

post-11-1079819819.png

Share this post


Link to post
Share on other sites

I honestly wouldn't worry about it, my CDRW icons always change to CD Drive when I put in any type of media - including blank CDRs and RWs, like other folk said, use Nero, anyone who uses inbuilt XP crap should be shot *hides*.

Share this post


Link to post
Share on other sites
ok maybe this is proper functionality. could anyone with a cdburner and XP confirm something for me.

open My Computer. Your burner says "CD-RW Drive" right? Put in a blank CD. Does the drive change suddenly to say "CD Drive"?

Somone please confirm. Thanks!

Regarding the "Incorrect Function" error, I found this form and thread while looking for solutions to the same problem. My colleague found a solution here.

The procedure is:

-Right Click on the drive and choose Properties.

-Click the Recording tab

-Click the Enable CD Recording on this Drive checkbox and click Okay.

That did the trick for me. Roxio may turn that off if Drag-to-disc gets installed, but doesn't restore the setting when it's uninstalled. That's just a theory, though.

Edited by Ipsilon

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.