Jump to content

144 posts in this topic

Posted

the problem now is that:

i see your last instruction and also code for fix the version, but i receive error again :(
I was change delay time to 4, when i start the bat file i receive error about Crytography Service on inf file.... u?

Share this post


Link to post
Share on other sites

Posted

Hi lucifer1972

Yes I have installed successfully using the batch file below. This contains the same files as the one in this thread above but I have updated to the final release version. I think this should be used on English systems only. These inf files are from wmp11-windowsxp-x86-enu.exe version 11.0.5721.5145

I just tried a third time, after about 6 changes to the length of the sleep command it succeeded with sleep 1 which was also the default used on the first attempt! So I suggest trying again.

Or use one of the other two methods given in this thread. Once sp2 is released the compatibility hack seems much the easiest way to install wmp11 onto win2k3.

Kevin

Final Release Version of Batch File Installer -- [attachment=170069:attachment]

Share this post


Link to post
Share on other sites

Posted

i need to uninstall the wmp11 beta, is there a batch file for that?

my creative mp3 player needs wmp 10 to work apparently

Share this post


Link to post
Share on other sites

Posted

[quote name='kevin551' post='588106550' date='Dec 4 2006, 08:14']
Final Release Version of Batch File Installer -- [attachment=170069:attachment]
[/quote]


I confirm that this batch installer can be used on Windows 2003 Server SP1 Enterprise, with the Final version of WMP11 EN-US, with the following modifications:

====BEGIN install2.bat=====
@echo off && Title WMP11 Installer
cd %CD%
echo.
echo Installing Windows Media Player 11
copy 2k3.inf wmp11\update\update.inf

rem modification is:
net stop cryptsvc
net start cryptsvc

start wmp11\update\update.exe
sleep 1
del wmp11\update\update.inf
copy xp.inf wmp11\update\update.inf
reg import FV.reg
cls
echo.
echo Please wait for Windows Media Player 11 to finish installing and then
pause
cls
echo.
echo Preparing to install Windows Media Format 11 Runtime files
sleep 10
copy 2k32.inf wmfdist11\update\update.inf

rem modification is:
net stop cryptsvc
net start cryptsvc

start wmfdist11\update\update.exe
sleep 1
del wmfdist11\update\update.inf
copy xp2.inf wmfdist11\update\update.inf
=====END install2.bat=====

Share this post


Link to post
Share on other sites

Posted

:woot:

Thanks Almodo...got the final build installed completely....finally :D

Share this post


Link to post
Share on other sites

Posted

Yay ! I also can confirm that it worked on Windows 2003 Server Enterprise Ed SP1 - one thing to note though, don't be too hasty on the DOS window where the bat file is running. I found that the first part installs OK, then pressed ENTER twice in succession and that made the second part fall over with the "unable to verify the integrirty of the update.inf ......." message. I must learn to be patient ;)

Is there perhaps a .inf file for Windows 2000 server Build 5.00.2195 SP4 ?

thanks to all to get this working :) !!!!

Share this post


Link to post
Share on other sites

Posted

neato :)

Share this post


Link to post
Share on other sites

Posted (edited)

I confirm that this batch installer can be used.
[quote name='kevin551' post='588106550' date='Dec 4 2006, 10:14']Or use one of the other two methods given in this thread. Once sp2 is released the compatibility hack seems much the easiest way to install wmp11 onto win2k3.[/quote]
I modified yours ".bat", ".reg" and ".inf" files for installation Windows Media Player 11 on Windows Server 2003 x64 Edition SP1. These ".inf" files are from wmp11-windowsxp-x64-enu.exe version 11.0.5721.5145. See attachment "Installer_x64.zip". Installation WMP11 onto win2k3 x64 make as described in this thread. Edited by Serguei Leontiev

Share this post


Link to post
Share on other sites

Posted (edited)

Thanks guys - everything works fine!!! Edited by smiroshnick

Share this post


Link to post
Share on other sites

Posted

not working..i'm using windows 2003 server enterprise r2....and wmp 11 is a MOFO to me...HELP PLS !!!

i followed the steps...HELP!

Share this post


Link to post
Share on other sites

Posted

can someone point me to a version of media player 11 that will install or intergrate into the windows 2003 sp1 enterprise edition?
i've searched but can't make heads or tails of all the links ect..
thanks in advance.

Share this post


Link to post
Share on other sites

Posted

[quote name='cep_head' post='588256212' date='Jan 24 2007, 17:51']can someone point me to a version of media player 11 that will install or intergrate into the windows 2003 sp1 enterprise edition?
i've searched but can't make heads or tails of all the links ect..
thanks in advance.[/quote]
still looking for some info on this if anyone knows anything please post or pm me.
thanks

Share this post


Link to post
Share on other sites

Posted

[quote name='aqtpie' post='588186512' date='Jan 2 2007, 08:31']Yay ! I also can confirm that it worked on Windows 2003 Server Enterprise Ed SP1 - one thing to note though, don't be too hasty on the DOS window where the bat file is running. I found that the first part installs OK, then pressed ENTER twice in succession and that made the second part fall over with the "unable to verify the integrirty of the update.inf ......." message. I must learn to be patient ;)

Is there perhaps a .inf file for Windows 2000 server Build 5.00.2195 SP4 ?

thanks to all to get this working :) !!!![/quote]
Are you asking for WMP11 on Win2kSP4? It will never happen.

Share this post


Link to post
Share on other sites

Posted

Hi all,

Nice post / project!

I would like to know if i can install Windows Media Player 11 on Windows Server 2003 using the Dutch version.

I have a dutch OS SP1 Windows server.

Is this hard to make? e.g. do i have to change Us-Us to Nl-Nl ?

Would be great if someone knows how i can do this :)

Share this post


Link to post
Share on other sites

Posted

This is the Beta 2 version of Windows Media Player 11,
version 11.0.5705.5043 - and it seems to work perfectly
(no complaints here) but is there a final version of this
same installer for Server 2003?

I even ripped WMP10 out of Server 2003 and this Dick C Normus
installer still worked :D That is unprecedented!

The final version is 11.0.5721.5145 though, I hate using Beta's :blush:

Share this post


Link to post
Share on other sites

Posted

All, last night I followed the instructions using the 5145 release and the "installer.zip" (latest) and the installatoon went fine on my Windows 2003 SP1 R2 Small Business Server (that also acts as a music server). The only thing I noticed different to my Windows XP install is that the icons for the various music types (these are embedded in WMPLOC.DLL), remain from the WMPLAYER.EXE, but this is easily corrected in the Windows File Type dialogue. Otherwise all works perfectly, a big thanks to all those who did this before me.

Geoff.

Share this post


Link to post
Share on other sites

Posted

Hi everybody,

thank you for this solution. I had some issues with the SLEEP timing, too, but then I just did it all manually (Opening the update.inf, manipulating all values, saving, then undoing my changes. Then run update.exe, and as soon as that has started save the inf again, so no integrity check will fail).

WMP11 seems to be running fine on my 2k3 server now. But I cannot activate the Media Sharing. It just hangs when I try to.

Any ideas or insights?


Thanks!

Bye
Alexander

Share this post


Link to post
Share on other sites

Posted

Hi there,

I found the link to [url="http://www.tversity.com"]TVersity[/url] in another thread. That piece of software does exactly what I was trying to accomplish with WMP11 on Windows Server 2003. So there is now no need anymore for any WMP11, UPnP or SSDP hacks...


Bye
Alexander

Share this post


Link to post
Share on other sites

Posted

[quote name='Mr. Dick C. Normous' post='587514193' date='May 16 2006, 14:33']I will have to give that a try thechief55 :) I tried that but I don't remember if I used the same values or not. I alway got an Cryptographic Services error message. I'm working on something similar using control.xml right now.

EDIT: Tried it and I still get this. Any ideas?[/quote]


This installer is a modification of Mr. Dick Installer to than you dont need to copy update.inf, this bat do all the work ^^ (works with any language version of wmp11 ;) )

Steps (just like Mr. Dick said before):

1. Download and extract the Windows Media Player 11 installer using WinRar.
2. Delete everything in the mpsetup folder except for wmp11.exe and wmfdist11.exe.
3. Extract wmp11.exe and wmfdist11.exe using Winrar. Be sure to use the

Share this post


Link to post
Share on other sites

Posted

Hmm...
My practics....

W2003 x64 R2

1. download wmp11-windowsxp-x64-enu.exe from MS official site
2. rename wmp11-windowsxp-x64-enu.exe to wmp11-windowsxp-x64-enu.rar
3. extract all files to temporary folder c:/a
4. execute all exe files in temporary folder c:/a exlude setup_wm.exe
5. its all - wmp11 install and work fine

p.s. before procedure i run x64.reg file (may be help install - may be not)
Windows Registry Editor Version 5.00
[i]
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\MediaPlayer\Setup\Installed Versions]
"wmp.dll"=hex:00,00,0b,00,19,14,59,16
"wmploc.dll"=hex:00,00,0b,00,19,14,59,16
"wmplayer.exe"=hex:00,00,0b,00,19,14,59,16
[/i]

Share this post


Link to post
Share on other sites

Posted

I followed the above steps to the letter. I got the file off Microsoft's site, extracted to a folder. Then deleted everything except those two exe's, and then extracted both of those into the same folder they were in. Then extracted the installer you attached and ran install.bat

I get an error saying it the installer couldn't find file update.exe or something like that, and it loops telling me to press "any key" and keeps giving me the same error, not getting anywhere. What am I doing wrong?

Share this post


Link to post
Share on other sites

Posted

With the release of Server 2003 SP2, does anyone know if SP2 has built in support for WMP11?

Share this post


Link to post
Share on other sites

Posted

[quote name='M118LR' post='588395515' date='Mar 14 2007, 12:41']With the release of Server 2003 SP2, does anyone know if SP2 has built in support for WMP11?[/quote]
I was just about to ask that. It should, but I haven't seen any indication that it does.

Share this post


Link to post
Share on other sites

Posted

There's still no support for wmp11 in SP2.

Share this post


Link to post
Share on other sites

Posted

Hi, the mentioned method didn't work for my 2k3sp2 but I did find a working method.

[url="http://www.msblog.org/index.php/2006/12/17/install-windows-media-player-11-on-windows-server-2003/"]http://www.msblog.org/index.php/2006/12/17...ws-server-2003/[/url]

Now if you can't find the extracted folder, just extract the original setup file with winrar or whatever you use and follow the guide. I had to run the files in compatibility mode(xp) but everything installed fine and is working great :)

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.