Jump to content



Photo

Windows Media Player 11 on Windows Server 2003


  • This topic is locked This topic is locked
143 replies to this topic

#106 euroweld

euroweld

    Resident One Post Wonder

  • Joined: 26-April 07

Posted 26 April 2007 - 22:43

GREAT!!!!

THX... all others tools & hints are [XXXXXXXXX]

it works whit all languages!!!

but i ask me.... WHY SO COMPLICATED? why not a simple installer for server?

server2003 is perfect, wmp11 is perfect.... but microsoft??? no comment



thx......


#107 xanth

xanth

    Neowinian

  • Joined: 19-May 07

Posted 19 May 2007 - 22:02

OK, so the workaround install seems to work in 2003 x64 R2 (Included with Dell Poweredge 2900.) Now how do I get my Xbox 360 to make friends with my server. Basically how can I install uPnP and SPDDS services to allow WMP11 to share its media.

#108 coroners

coroners

    Resident One Post Wonder

  • Joined: 23-May 07

Posted 24 May 2007 - 15:08

Any idea on how to enable/install wmp11 plugin in firefox on win2003 server sp2? Installing wmp11 worked fine but I cant use it with firefox. *sob*

#109 f4af_billy

f4af_billy

    Neowinian

  • Joined: 25-April 05
  • Location: Lancashire, UK

Posted 03 June 2007 - 18:10

I found a fairly easy way to install WMP11 on 2003 w/SP2.

1. Extract the download executable (e.g., wmp11-windowsxp-x86-enu.exe) with WinZip or the equivalent.

2. Open the extracted folder and extract wmfdist11.exe and wmp11.exe to separate folders.

3. Run the compatibility wizard (start/Help and Support, search for "compatibility", select "Getting older programs to run on the Windows Server 2003 family of products : Windows"

4. Click "Program Compatibility Wizard"

5. Choose locate the program manually

6. Browse to the update.exe in the extracted wmfdist11.exe folder (e.g., c:\wmp11-windowsxp-x86-enu\wmfdist11\update\update.exe)

7. Choose XP compatibility and defaults for the rest of the screen.

8. Uncheck the restart now box.

9. Repeat steps 3 through 7 for the wmp11.

This worked on a machine that I just installed 2003 SP2 on via Windows Update, which cause my WMP10 to be uninstalled.

Good Luck


Just did it this way, works perfectly. thanks for posting

#110 takara_05

takara_05

    Neowinian

  • Joined: 23-May 07

Posted 07 June 2007 - 17:28

Hi, I got WMP11 to work on Server 2003 without any problems. But i can't get the Windows Media Player Network Sharing Service to work. I even installed the UPnP and the SSDP Service from a Windows XP on the Server 2003. But the SSDP Service refuses to start. Is there a way to enable the SSDP and the UPnP Service on Windows Server 2003, any?
Thanks in advance, Tak.

#111 B_Dog

B_Dog

    Resident One Post Wonder

  • Joined: 07-June 07

Posted 07 June 2007 - 22:50

I can assure you guys that the method Nick Acquaviva (2 posts above) reccommends does work. I've got Windows Server 2003 Enterprize SP2 R2 and have WMP11 running. Simply running compatibility mode on wmfdist11.exe doesn't work, it has to be done on the update.exe. Just follow Nick Acquaviva's instructions and all will be well. Windows Server 2003 is one of the best OS's I've used to date, down with Vista (even though I do like its style)!

Posted Image

Edited by B_Dog, 07 June 2007 - 23:00.


#112 takara_05

takara_05

    Neowinian

  • Joined: 23-May 07

Posted 08 June 2007 - 15:38

hm, that was more or less of zero help, i am sure everyone is able to get WMP 11 running on Server 2003. But the much more challenging task is to get the Windows Media Player Network Sharing Service to work.
I just found one post in a different forum from someone who claimed he got it running. But no further proof. So if anyone knows a method of getting the Windows Media Player Network Sharing Service, the UPnP and the SSDP Service to work under Server 2003, please share it with us!!!
Thanks in advance, Tak

#113 headcase

headcase

    Neowinian

  • Joined: 05-January 05

Posted 08 June 2007 - 21:23

What error did you get trying to start SSDP? I think I found the exact same thread today and tried to get them installed. Went so far as to copy the reg entries and files from a working xp sp2 machine and still get the 1803 error trying to start SSDP.

I can't find a lot of information. My first guess is svchost needs to be updated and I might give that a try on a test box. But I'm flying blind and just pulling stuff out of my a$$ trying to get it to work.

Would much rather use this than something like tversity to serve up files off of 2k3.


hm, that was more or less of zero help, i am sure everyone is able to get WMP 11 running on Server 2003. But the much more challenging task is to get the Windows Media Player Network Sharing Service to work.
I just found one post in a different forum from someone who claimed he got it running. But no further proof. So if anyone knows a method of getting the Windows Media Player Network Sharing Service, the UPnP and the SSDP Service to work under Server 2003, please share it with us!!!
Thanks in advance, Tak



#114 headcase

headcase

    Neowinian

  • Joined: 05-January 05

Posted 08 June 2007 - 23:27

Okay, got the services to run ... but haven't test connectivity yet (xbox360). There are two big reg entries that are missing ... I think, because I've now done so much tinkering that I hope I've got what's needed.

The two biggies are:
--and it'd probably help to just get them exported out a working xp sp2 reg--
hklm\system\currentcontrolset\enum\root\legacy_ssdpsrv. key 0000 gets created, but control under that doesn't. Need to add reg_sz ActiveService, value SSDPSRV. I'm not even sure this part is necessary.
hklm\software\microsoft\windows nt\currentversion\svchost ... add upnphost and SSDPSRV to LocalService. This I believe is the big one.

Have to do a full reboot. Just doing an explorer refresh didn't work for me.

I installed using the XtraServices.inf instructions, then exported reg entries from working xp sp2 for the services then did a full reg search on the xp sp2 box for ssdp and came up with those missing entries. Once added it started. Unfortunately, I also copied all of the dlls over from that xp box too, but they were the exact same vers that came off the xp sp2 disc I had handy.

Hope that helps.

#115 takara_05

takara_05

    Neowinian

  • Joined: 23-May 07

Posted 11 June 2007 - 19:46

woot, thanks headcase!!!
I finally got the service to work, now i only have to test the connectivity :) I will tell you if it worked later!

#116 headcase

headcase

    Neowinian

  • Joined: 05-January 05

Posted 13 June 2007 - 16:04

To add a little more juice to the instructions, in case anybody ever googles upon this thread. 1) you don't need to use the compat wizard, you can just right click on the update.exe files and go through the compat tab. Works fine. 2) when running wmp11 for the first time, *make sure* you select a music store to install. If you don't the DRM files won't get created, or if upgrading from WMP10, they'll be the wrong version. When trying to start the windows media sharing service you'll get an app event stating that the DRM files are corrupt. It also won't set the correct DRM reg entry. 3) permissions are a little messed up since this is a hack-a-thon. Or maybe it was me mis-understanding how the library monitored folders worked. WMP11's "my folders" = the All Users shared folders, not the current logged in user. 4) If you want to share files from the WMP11 library they have to already be network shared with everybody read only perms.

Maybe everybody already knew that? I'd never played with media connect before so those were some stumbling blocks for me.

#117 Sammyinnit

Sammyinnit

    Neowinian

  • Joined: 14-October 04
  • Location: England.
  • OS: Windows 7 x64
  • Phone: HTC EVO 3D/Google-Asus Nexus 7 2nd Gen Tablet

Posted 14 June 2007 - 01:24

Media player?

On a Server?

Good lord, what is this world come to.

#118 MtnDewCodeRedFreak

MtnDewCodeRedFreak

    Since May 2001

  • Joined: 04-August 03
  • Location: In a place where Code Red flows ...
  • OS: Windows 7 Ultimate SP1 x64
  • Phone: iPhone 5S

Posted 14 June 2007 - 06:38

I found a fairly easy way to install WMP11 on 2003 w/SP2.

1. Extract the download executable (e.g., wmp11-windowsxp-x86-enu.exe) with WinZip or the equivalent.

2. Open the extracted folder and extract wmfdist11.exe and wmp11.exe to separate folders.

3. Run the compatibility wizard (start/Help and Support, search for "compatibility", select "Getting older programs to run on the Windows Server 2003 family of products : Windows"

4. Click "Program Compatibility Wizard"

5. Choose locate the program manually

6. Browse to the update.exe in the extracted wmfdist11.exe folder (e.g., c:\wmp11-windowsxp-x86-enu\wmfdist11\update\update.exe)

7. Choose XP compatibility and defaults for the rest of the screen.

8. Uncheck the restart now box.

9. Repeat steps 3 through 7 for the wmp11.

This worked on a machine that I just installed 2003 SP2 on via Windows Update, which cause my WMP10 to be uninstalled.

Good Luck



It worked!

A zillion thanks to you!

#119 telugite

telugite

    Resident One Post Wonder

  • Joined: 01-September 06

Posted 04 August 2007 - 15:33

hklm\software\microsoft\windows nt\currentversion\svchost ... add upnphost and SSDPSRV to LocalService. This I believe is the big one.

Have to do a full reboot. Just doing an explorer refresh didn't work for me.



What do i need to add. is it a DWORD or string or a key and what are the values.

Can you be more detailed. I am getting error 1068 error now.

Thank You

#120 EniGmi

EniGmi

    Resident One Post Wonder

  • Joined: 10-August 07

Posted 10 August 2007 - 23:42

Hi All,

After going through this thread I now have WMP 11 running on Windows Server 2003 (with no SP)
This was achieved by using the modified install.bat by Almodo (the one that stops/starts the cryptsvc service) and the latest copy of the WMP 11 installer

I also have the following 3 services started up after following the info by headcase:
SSDP Discovery Service
Universal Plug and Play Device Host
Windows Media Player Network Sharing Service

As mentioned, to do this go here:
http://www.theelderg...ex.ph...w=&st=
and copy the code into the two inf files specified and then run the command he has after this code

The only registry change you then need to make to get these services running is to add to the
hklm\software\microsoft\windows nt\currentversion\svchost - 'LocalService' Key the extra values 'upnphost' and 'SSDPSRV'

This is NOT the same place as the folder also called LocalService in this part of the registry


However even after all this when running WMP 11 and then going to 'Media Sharing...' and ticking the box followed by OK to start up the sharing, WMP 11 hangs
for a while and then crashes to the desktop.

Looking in the event viewer shows the following error:
Faulting application wmplayer.exe, version 11.0.5721.5145, faulting module wmp.dll, version 11.0.5721.5145, fault address 0x003b042d.


I have tried searching for the 2003 Server using an Xbox 360 at various stages before WMP 11 crashes but it does not show up.

Is anyone else having the same problem as this?
I guess sharing from Windows 2003 using WMP 11 is not likely until MS fix it properly



Click here to login or here to register to remove this ad, it's free!