Jump to content



Photo

Windows Media Player 11 on Windows Server 2003


  • This topic is locked This topic is locked
143 replies to this topic

#121 Fonk

Fonk

    Neowinian

  • Joined: 26-January 07
  • Location: Netherlands

Posted 22 August 2007 - 16:26

Hi all,

Do not forget to change update.inf to:


[Version]
Signature="$Windows NT$"
InstallPlatform=0
CatalogFile=%SP_KB_TITLE%.cat
LanguageType=%LangTypeValue%


MaxNtMinorVersionToUpdate=3
MaxNtMajorVersionToUpdate=5
NtBuildToUpdate=2600
NtMinorVersionToUpdate=1
NtMajorVersionToUpdate=5
MaxNtBuildToUpdate=9999
MinNtServicePackVersion=0
MaxNtServicePackVersion=512

ThisServicePackVersion=512



What i like to know is:

If we install Windows media player 11 on windows server 2003 SP2,

then windows-update will not see this i think ?

So how about hotfixes ?

Or are *all* hotfixes in the latest windows media player 11 version (exe) ?

If not only way to manualy install the security / hotfix is downloading them from :

http://catalog.updat.../site/home.aspx

Search for Windows Media Player 11 XP

Then selecting all XP updates and downloading them.

Then all extracting them and go to

/update/

making update.exe compatible for XP

and changing update.inf to :

[Version]
Signature="$Windows NT$"
InstallPlatform=0
CatalogFile=%SP_KB_TITLE%.cat
LanguageType=%LangTypeValue%


MaxNtMinorVersionToUpdate=3
MaxNtMajorVersionToUpdate=5
NtBuildToUpdate=2600
NtMinorVersionToUpdate=1
NtMajorVersionToUpdate=5
MaxNtBuildToUpdate=9999
MinNtServicePackVersion=0
MaxNtServicePackVersion=512

ThisServicePackVersion=512 <-- don't know about this.

Hope we do not need to do it manually cause you have to change all update.inf to the above.
Then make the update.exe comparible with xp and they should install after you have windows media player 11 on windows server 2003 SP2

Is this correct? or are ALL the KBxxxxx updates found by windows update ?

Very important i think ?


Thnx


#122 martinii

martinii

    Neowinian

  • Joined: 07-November 07

Posted 07 November 2007 - 09:20

I found a fairly easy way to install WMP11 on 2003 w/SP2.

1. Extract the download executable (e.g., wmp11-windowsxp-x86-enu.exe) with WinZip or the equivalent.

2. Open the extracted folder and extract wmfdist11.exe and wmp11.exe to separate folders.

3. Run the compatibility wizard (start/Help and Support, search for "compatibility", select "Getting older programs to run on the Windows Server 2003 family of products : Windows"

4. Click "Program Compatibility Wizard"

5. Choose locate the program manually

6. Browse to the update.exe in the extracted wmfdist11.exe folder (e.g., c:\wmp11-windowsxp-x86-enu\wmfdist11\update\update.exe)

7. Choose XP compatibility and defaults for the rest of the screen.

8. Uncheck the restart now box.

9. Repeat steps 3 through 7 for the wmp11.

This worked on a machine that I just installed 2003 SP2 on via Windows Update, which cause my WMP10 to be uninstalled.

Good Luck


Hello

I tried to install WMP11 on my Windows 2003 SP2 with instructions above but I don't understand 8. I have no 'restart now' box in Program Compatibility Wizard :blink:

#123 cm2b

cm2b

    Resident One Post Wonder

  • Joined: 25-January 07

Posted 11 November 2007 - 18:12

Hello

I tried to install WMP11 on my Windows 2003 SP2 with instructions above but I don't understand 8. I have no 'restart now' box in Program Compatibility Wizard :blink:



I didn't get that option either when i followed the steps but i have wmp11 on my server now.

#124 martinii

martinii

    Neowinian

  • Joined: 07-November 07

Posted 14 November 2007 - 06:09

I didn't get that option either when i followed the steps but i have wmp11 on my server now.


How did You do this?

#125 martinii

martinii

    Neowinian

  • Joined: 07-November 07

Posted 03 December 2007 - 19:35

I get an error: Posted Image

#126 Arendor

Arendor

    Resident One Post Wonder

  • Joined: 14-January 08

Posted 14 January 2008 - 03:41

How did you get those services listed in the Services window? I saw you guys talking about another thread but there was no trace of URL... Could you please share with me the details how to get all those services running?

Thanks!


woot, thanks headcase!!!
I finally got the service to work, now i only have to test the connectivity :) I will tell you if it worked later!



#127 aprmike

aprmike

    Neowinian

  • Joined: 14-January 08

Posted 14 January 2008 - 18:10

The "restart now" option is not part of the compatability wizard process, it appears after the compatability wizard has launched the exes. It runs the normal setup as though you were on xp and its on the final page with the Finish button on it. I doubt a restart between each exe would cause a problem, its just so you can run them both one after the other. :)

#128 jimcpl

jimcpl

    Resident One Post Wonder

  • Joined: 15-January 08

Posted 15 January 2008 - 05:35

Hi,

New here... I can't get past the first part of this, as I can't extract the .exe that I downloaded. I've tried both Winzip and WinRAR with no success.

Does anyone have any ideas why I can't unzip the .EXE?

Also, BTW, I'm running Win2K3 Enterprise SP2. Assuming that you all can help me extract the .EXE, will this work on my machine?

Thanks,
Jim

#129 aprmike

aprmike

    Neowinian

  • Joined: 14-January 08

Posted 15 January 2008 - 12:44

jimcpl, I just used winrar and it unzipped fine (this was on an xp machine, then I copied it back to the server). I have MP11 running on 2K3 R2 x64 SP2, just standard but Enterprise will be no different. The annoying this is that 2k3 doesn't sllow media sharing, so for me the whole exercise was a bit pointless! Have fun!

#130 PS6155

PS6155

    Resident One Post Wonder

  • Joined: 22-February 08

Posted 22 February 2008 - 23:46

How to install Windows Media Player 11 on Windows (Enterprise) Server 2003 SP2

I had to do this today on a newly installed machine, and couldn't remember exactly how I did it last time. When I read through this forum thread, I saw that no one post had a complete set of directions. As I detest experimenting to rediscover something I've forgotten :wacko: , I thought I'd do a thorough description that covers ALL the steps. :) This install was over a fresh install of the OS with all current patches.

How to install Windows Media Player 11 on Windows (Enterprise) Server 2003 SP2

The attached screen shot should help.

1. Download the program file "wmp11-windowsxp-x86-enu.exe"

2. Create a folder named "wmp11-windowsxp-x86-enu"

3. Move the program file into the folder.

4. In the folder, use <Ctrl>+<Shift" to make a shortcut to the program file.

5. Open the properties of the shortcut and change the target, adding the switch /C AND QUOTES
so it reads:
"F:\Windows MP11\wmp11-windowsxp-x86-enu.exe" /C. Save it.

6. Launch the shortcut. When prompted for a location, browse to the same folder
ie "X:\Windows MP11\wmp11-windowsxp-x86-enu", where X: is your drive letter.
Locate the two programs "wmfdist11.exe" and "wmp11.exe" among the extracted files.
---
7. Make a new folder "F:\wmfdist11".

8. Open the Explorer, and expand the view so you can see the top level folders on your drive.

9. Launch the program wmfdist11.exe. When you get an error message, stop! Look at the root of that drive.
You will see a folder named with a unique random number, something like "bc2ba4075f9324e762eae8f7e5"

10. Copy all the files except the one named "$shtdwn$.req" from this folder into the wmp11 folder.
---
11. Make a new folder named "F:\wmp11".

12. Open the Explorer, and expand the view so you can see the top level folders on your drive.

13. Launch the program wmp11.exe. When you get an error message, Stop! Look at the root of that drive.
You will see a folder named with a unique random number, something like "8a4cb3075f9324e762eae8f9f2"

14. Copy all the files except the one named "$shtdwn$.req" from this folder into the wmp11 folder.
-------
15. In each of the two folders, "wmfdist11" and "wmp11", you will see a subfolder named "Update",
and within each of these a file named "Update.exe". Change the properties of each update.exe to run in
compatibility mode for Windows XP.

16. Run "F:\wmfdist11\Update\update.exe".

17. Run "F:\wmp11\Update\update.exe".

Attached Images

  • WMP11_on_W2K3S.JPG

Edited by PS6155, 22 February 2008 - 23:55.


#131 Nextnx

Nextnx

    Resident One Post Wonder

  • Joined: 06-March 08

Posted 06 March 2008 - 22:58

Well to summen up heres what I did..

[Install WMP11]
Use the trick by Nick Acquaviva's
http://www.neowin.ne...amp;p=588446611

[UPNP and SSDP]
This is my trimmed version, which only install UPNP and SSDP. (Credit to steven2004)
- copy paste below into notepad and save as XtraServices.inf to c:\windows\inf
[version]
signature="$WINDOWS NT$"
ClassGUID={00000000-0000-0000-0000-000000000000}
LayoutFile=layout.inf
[DestinationDirs]
UPNP.SysFiles=11
UPNP.XMLFiles=11,icsxml
[Optional Components]
UPNPSvc
[UPNPSvc]
OptionDesc=%UPNP_DESC%
Tip=%UPNP_TIP%
IconIndex=93
CopyFiles=UPNP.SysFiles,UPNP.XMLFiles
Uninstall=UPNP.Remove
RegisterDlls=UPNP.RegisterDlls
AddService=upnphost, 0x410,UPNP_upnphost_Svc
AddService=SSDPSRV, 0x410,UPNP_SSDP_svc,  UPNP_Evt
SizeApproximation=678976
[UPNP.Remove]
UnregisterDlls=UPNP.UnRegisterDlls
DelFiles=UPNP.SysFiles,UPNP.XMLFiles
DelService=upnphost
DelService=SSDPSRV
[UPNP.RegisterDlls]
11,, upnp.dll, 1
11,, upnphost.dll, 1
11,, upnpcont.exe,,,"/regserver"
[UPNP.UnRegisterDlls]
24,%lite_path%,%lite_prog%,,,"stop upnphost"
24,%lite_path%,%lite_prog%,,,"stop SSDPSRV"
11,, upnp.dll, 1
11,, upnphost.dll, 1
11,, upnpcont.exe,,,"/unregserver"
[UPNP.SysFiles]
ssdpsrv.dll,,,1
ssdpapi.dll,,,1
upnp.dll,,,1
upnphost.dll,,,1
upnpcont.exe,,,1
udhisapi.dll,,,1
upnpui.dll,,,1
[UPNP.XMLFiles]
cmnicfg.xml
ipcfg.xml
osinfo.xml
potscfg.xml
pppcfg.xml
[UPNP.SysFiles.Security]
"D:P(A;;GRGX;;;BU)(A;;GA;;;BA)(A;;GA;;;SY)(A;;GRGX;;;WD)"
[UPNP_upnphost_Svc]
Description=%UPNPHOST_Desc%
DisplayName=%UPNPHOST_Display%
ServiceType=0x20
StartType=3
ErrorControl=1
StartName="NT AUTHORITY"\LocalService
ServiceBinary=%11%\svchost.exe -k LocalService
AddReg=upnphost.AddReg.Secure, upnphost.AddReg
Dependencies=SSDPSRV
Security="D:(A;;GA;;;SY)(A;;GA;;;BA)(A;;GA;;;AU)(A;;GA;;;PU)(A;;CCDCLCSWLOCRRC;;;LS)"
[upnphost.AddReg]
HKR, Parameters, ServiceDll, 0x20000, "%%SystemRoot%%\System32\upnphost.dll"
HKLM, "Software\Microsoft\UPnP Device Host\HTTP Server", "MaxConnections", 0x00010001, 0x00000050
HKLM, "Software\Microsoft\UPnP Device Host\HTTP Server\VROOTS",,0x0010
[upnphost.AddReg.Secure]
HKLM, "Software\Microsoft\UPnP Device Host",,0x10
[upnphost.AddReg.Secure.Security]
"D:PAR(A;CI;KA;;;BA)(A;CIIO;KA;;;CO)(A;CI;KA;;;LS)(A;CI;KA;;;SY)(A;CI;KR;;;BU)"
[UPNP_SSDP_svc]
Description=%UPNP_Desc%
DisplayName=%UPNP_Display%
ServiceType=0x20
StartType=3
StartName="NT AUTHORITY"\LocalService
ErrorControl=1
ServiceBinary=%11%\svchost.exe -k LocalService
Security="D:(A;;GA;;;SY)(A;;GA;;;BA)(A;;GA;;;AU)(A;;GA;;;PU)(A;;RPWPDTRC;;;LS)"
AddReg=UPNP.AddReg
[UPNP.AddReg]
HKR, Parameters, ServiceDll, 0x20000, "%%SystemRoot%%\System32\ssdpsrv.dll"
[SourceDisksNames]
1=,,,i386
[SourceDisksFiles]
sp1.cab=1,,
sp2.cab=1,,
[StringHunt]
shl_img.inf
msagent.inf
pchealth.inf
wordpad.inf
msinfo32.inf
syssetup.inf
netupnph.inf
[Strings]
KEY_RUN="Software\Microsoft\Windows\CurrentVersion\Run"
KEY_RUNONCE="Software\Microsoft\Windows\CurrentVersion\RunOnce"
KEY_APPPATHS="Software\Microsoft\Windows\CurrentVersion\App Paths"
KEY_UNINSTALL="Software\Microsoft\Windows\CurrentVersion\Uninstall"
KEY_SAFEBOOT="System\CurrentControlSet\Control\SafeBoot"
KEY_PFPROFILE="Software\Policies\Microsoft\Windows\System\PCHealth"
KEY_SVCHOST="Software\Microsoft\Windows NT\CurrentVersion\Svchost"
KEY_LAME="SOFTWARE\Microsoft\PCHealth\Clients\Dialog Comments"
KEY_COMMENT_LINK="Control Panel\Desktop"
______LitePC_Local_Strings______=""
UPNP_DESC="Universal Plug and Play"
UPNP_TIP="Support to host Universal Plug and Play devices and to discover UPnP devices on your network."
UPNPHOST_Display="Universal Plug and Play Device Host"
UPNPHOST_Desc="Provides support to host Universal Plug and Play devices."
UPNP_Display="SSDP Discovery Service"
UPNP_Desc="Enables discovery of UPnP devices on your home network."
LCID="0409"
UILanguageID=1033
MsSHARED="Microsoft Shared"
OLDDB="Ole DB"
ADO="ado"
MSADC="msadc"
DAO="DAO"
MSSOAPBIN="MSSoap\Binaries"
MSSOAPBINRES="MSSoap\Binaries\Resources\1033"
MSInfo32_DESC="System Information"
MSInfo32_INFOTIP="Displays current system information."
SystemTools_GROUP="Accessories\System Tools"
MSINFOPATHL="Microsoft Shared\MSInfo"

- then copy and paste this into notepad and save as c:\upnp.inf
[Version]
Signature="$Windows NT$"
[Global]
WindowTitle="Onemancan"
WindowTitle_Standalone="Onemancan"
[Components]
UPNPSvc=ocgen.dll,OcEntry,"XtraServices.inf",,7

- Run this
sysocmgr.exe /i:c:\upnp.inf
Have a XP sp2 disk ready, it will need it.

- apply this fix (Credit to headcase)
Use regedit
Find: hklm\software\microsoft\windows nt\currentversion\svchost
Edit: 'LocalService' Key and add the 'upnphost' and 'SSDPSRV' (include an empty line afterwards)

[Reboot]
Yes you'll need to reboot since the installed ssdp driver isnt initialized yet by windows

Works on W2003 SP2 std. ed.

#132 freethinker

freethinker

    Resident One Post Wonder

  • Joined: 28-March 08

Posted 28 March 2008 - 12:50

- apply this fix (Credit to headcase)
Use regedit
Find: hklm\software\microsoft\windows nt\currentversion\svchost
Edit: 'LocalService' Key and add the 'upnphost' and 'SSDPSRV' (include an empty line afterwards)

[Reboot]
Yes you'll need to reboot since the installed ssdp driver isnt initialized yet by windows

Works on W2003 SP2 std. ed.



Step by step on this part:

Start > Run > Regedit

Navigate down through

HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > Windows NT > CurrentVersion > SvcHost

On the right hand screen double click on LocalService

Add the values

upnphost
SSDPSRV

Ensure there is a blank line after that last value.


Press OK, reboot, go and start the services.

_________________________________________________________________


My xbox isn't showing up right now but I am getting to the proper screen where it should be and WMP11 isn't crashing. w00t. Seems I'm nearly there.

Update: I went to the Xbox and tried to see the server as a media source and found it, tried to share and it said the console wasn't enabled from the machine. Back to the server and the xbox showed up.

Edited by freethinker, 28 March 2008 - 13:01.


#133 RickoT

RickoT

    RickoT

  • Joined: 27-November 03
  • Location: Boise, ID

Posted 06 April 2008 - 06:46

My xbox isn't showing up right now but I am getting to the proper screen where it should be and WMP11 isn't crashing. w00t. Seems I'm nearly there.

Update: I went to the Xbox and tried to see the server as a media source and found it, tried to share and it said the console wasn't enabled from the machine. Back to the server and the xbox showed up.


Yah this is right where I am, I see the media share on my xbox but then when I go to browse it says that the xbox has lost connection to the resource or something like that. I went into media player and its now an approved device but it still does it. I also dont see the shared media on any of my vista machines running wmp 11. The media is shared, however I find myself wondering if the permissions on the shares need to be adjusted?

#134 DavidIQ

DavidIQ

    Resident One Post Wonder

  • Joined: 13-April 08

Posted 13 April 2008 - 16:01

This is entirely too much work. Was looking for a solution to doing this and stumbled upon this forum but after reading through all of the ideas on how to do this I figured it would just be easier to use the compatibility tab in the exe properties and be done with it. So here's what I did:

1. Download wmp11 and extract contents to your folder of choice using winRAR or WinZip or whatever other method you'd like to use.
2. Right-click on each .exe file individually and select properties then click on the Compatibility tab, check the box that says "Run this program in compatibility mode for:" and select Windows XP from the drop-down, click OK, and run the sucker. THE ONLY ONE YOU SHOULD NOT RUN IS SETUP_WM.EXE. Also you'll be presented with the option to Restart. You can bypass this until you're done running all of the executables and THEN reboot.

Not sure if there should be an order that the exe's should be run in but this got Windows Media Player installed and working on my Windows Server 2003 SP2 and required very little effort.

#135 Ping.

Ping.

    Neowinian

  • Joined: 09-July 05

Posted 23 April 2008 - 11:29

Hi, the mentioned method didn't work for my 2k3sp2 but I did find a working method.

http://www.msblog.or...ws-server-2003/

Now if you can't find the extracted folder, just extract the original setup file with winrar or whatever you use and follow the guide. I had to run the files in compatibility mode(xp) but everything installed fine and is working great :)


Deff the best I found...Thanks :D



Click here to login or here to register to remove this ad, it's free!