Jump to content



Photo

svchost.exe (LocalSystemNetworkRestricted)


  • Please log in to reply
10 replies to this topic

#1 Wheazel

Wheazel

    Whist-Online Developer

  • Joined: 10-October 03
  • Location: Belgium, Aalst

Posted 08 March 2007 - 18:24

I have Vista 32bit, fully updated.
Every 2 hours or so, I have a serious performance hit due to a process called svchost.exe (LocalSystemNetworkRestricted).

Look at the attached picture for a clue. It scans files on the harddrive. Anyone have an idea how to keep this from happening? Or whats causing it?
Googling for it showed no relevant results :(

Thx!



Posted Image
Screenshot is in Dutch, but Schijf = Disk, Lezen = read and Schrijven = Write ;)

Edited by Wheazel, 08 March 2007 - 18:30.



#2 Danny Kirkham

Danny Kirkham

    Neowinian

  • Joined: 30-March 07

Posted 30 March 2007 - 14:24

I'm getting this problem too, it's really annoying.

#3 Darkness2k

Darkness2k

    The Lord of Darkness

  • Joined: 15-July 01
  • Location: England
  • OS: Windows 8.1 Pro
  • Phone: Yes

Posted 30 March 2007 - 14:29

svchost is a process that is part and parcel of the services running on your PC (i.e. things listed under services.msc).

Are you "scheduled" to run something every 2 hours (such as indexing or defragmentation)?

#4 Northgrove

Northgrove

    Philosophizing Developer

  • Joined: 29-December 02
  • Location: Sweden
  • OS: OS X 10.8
  • Phone: iPhone 5

Posted 30 March 2007 - 14:31

When you have the problem, try pulling up the Services window (to quickly get there, try typing services.msc in the Start Menu search box and then hit Enter). When you're there, and you have this access going on, try stopping the SuperFetch service. If that seemed to change the drive accesses, that was it. Otherwise it could be search indexing, but my bets are on SuperFetch for now -- another hint of that is that it's accesing your disk at "Achtergrond" priority = "Background" priority.

SuperFetch on Wikipedia and Microsoft:
- http://en.wikipedia....etch#SuperFetch
- http://www.microsoft...superfetch.mspx

It tries to analyze your usage patterns and preload files into RAM that you're "likely" (as deemed by Vista) to use soon. It's a new service in Vista that can safely be kept disabled if you wish, although that may impact performance.

Edited by Jugalator, 30 March 2007 - 14:37.


#5 k22

k22

    Neowinian

  • Joined: 28-February 02

Posted 30 March 2007 - 21:15

cmd
tasklist /svc /FI "PID eq ####" [Enter] where #### is the PID of the instance of svchost.exe that is causing all of the activity. quotes are necessary, leave them. the culprit will be one of the services returned by this command.

cmd
net stop servicename [Enter] where servicename is one of the names listed in the output of the command above.

#6 Mordkanin

Mordkanin

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 15-February 04

Posted 31 March 2007 - 00:23

k22, Vista has this built into the task manager now.

In the task manager, you can right click any svchost.exe file, and choose "Go To Services", to see exactly what services are being hosted in it.

From the services tab, you can stop any service you want. Just right click it and choose stop.

#7 Danny Kirkham

Danny Kirkham

    Neowinian

  • Joined: 30-March 07

Posted 31 March 2007 - 19:47

I turned Superfetch and Search indexing off, and I think it has fixed, so thanks

#8 elric

elric

    Neowinian

  • Joined: 30-June 08

Posted 30 June 2008 - 14:42

i have the same problem with you, and i've realized that my new program "perfect disk" led to it.
it's a disk defragmentation program.
do you have a similar program with me?


i'm a Chinese .i'm sorry about my poor English.

#9 elric

elric

    Neowinian

  • Joined: 30-June 08

Posted 30 June 2008 - 14:49

turn Superfetch off would have nagative effect on your computer unless it has a poor configuration

#10 soldier1st

soldier1st

    Software Tester/Tech/Linux Lover

  • Tech Issues Solved: 1
  • Joined: 21-December 03
  • Location: Guess Where
  • OS: Windows 7,Android,Linux Mint
  • Phone: HTC Incredible S

Posted 30 June 2008 - 17:14

superfectch should not be causing the problem and neither should the indexing,how much memory do you have?also what are your system specs?it could be a driver problem or malware.i bet it is a driver problem.turning superfetch off is silly as it helps your system stay responsive and indexing and superfetch run at low i/o.

#11 Michael REMY

Michael REMY

    Neowinian

  • Joined: 22-August 10

Posted 15 February 2011 - 21:31

hi !

i have this problem too and i am under windows 7 x64 pro.
now, this process consums 158Mo while i have only one application 's running : seamonkey my browser.
here's a screen cap : http://www.michael-r..._restricted.jpg
even i have a huge cpu (i7-975), i feel a low period now....
very strange....

anyone know what it is really ?



Click here to login or here to register to remove this ad, it's free!