Sign in to follow this  
Followers 0

Computers can't see each other on lan

16 posts in this topic

Posted

Athlon 64x2 running Vista Home Premium networked with P4 XP SP2 through Linksys WRT54G router (wired connection). Network name is MSHOME on both computers. Both computers can ping router, but not the other computer. Norton Integrated Security runs on both computers. NIS map on Atjhon shows both computers, but P4 is offline. NIS map on P4 shows both compouters online. When I click "repair" on P4 interface I get message, "TCP/IP is not enabled for this connection".

How can I get the computers to see one another?

gaius5

Share this post


Link to post
Share on other sites

Posted

check your firewall

Share this post


Link to post
Share on other sites

Posted

IF it says TCP/IP is not enabled, you should make sure TCP/IP is bound to that network adapter.

Go to the properties of your NIC and make sure it looks like the picpost-234193-1201617019.jpg

Beyond that i've seen PC's that had incorrect network drivers loaded, do this. You should check your device manager and make sure there is no "Yellow Exclimation" marks.

Start-->Run-->devmgmt.msc

Share this post


Link to post
Share on other sites

Posted

If you can't ping the other computers, verfy NIS or Windows firewall (if that's enabled) isn't blocking ICMP packets. Also, if the machines are wireless, trying disaplying "loopback" in your routers config.

Share this post


Link to post
Share on other sites

Posted (edited)

If you can't ping the other computers, verfy NIS or Windows firewall (if that's enabled) isn't blocking ICMP packets. Also, if the machines are wireless, trying disaplying "loopback" in your routers config.

If TCP/IP is not Enabled, he's not going to be able to ping anything.

{EDIT} I guess it does say in the OP that both computers can ping the router.. I find that difficult to believe if TCP/IP is not enabled on one of the PC's

Edited by compass4

Share this post


Link to post
Share on other sites

Posted

If TCP/IP is not Enabled, he's not going to be able to ping anything.

If TCP/IP wasn't enabled, he wouldn't have been able to ping the router.

Share this post


Link to post
Share on other sites

Posted

Sounds like you need to install the LLTD patch on the XP machine. Get it here if it's not already installed.

Ad

Share this post


Link to post
Share on other sites

Posted

another reason to hate firewalls behind firewalls. The firewall is doing exactly what is intended, block other computers from communicating directly with it.

Turn off norton and see if they work just fine. After thatn remove it and run normal windows firewall enabling file sharing and you should be more than good to go.

Share this post


Link to post
Share on other sites

Posted

Another way to find your computer in the workgroup, since that is what you're using, is net view. Try Run-->cmd-->net view. This should display a listing of all the machines connected to your workgroup.

Share this post


Link to post
Share on other sites

Posted

another reason to hate firewalls behind firewalls. The firewall is doing exactly what is intended, block other computers from communicating directly with it.

Turn off norton and see if they work just fine. After thatn remove it and run normal windows firewall enabling file sharing and you should be more than good to go.

Yes, the OP should at least temporarily disable his software firewalls. His router will have a NAT firewall to keep him protected from outside intrusions.

Share this post


Link to post
Share on other sites

Posted

I thank you all for your suggestions and have tried them all. Now I can ping both computers from one another, but the computers still can't see one another on the lan. In fact, the XP computer doesn't even show itself when I select, "View workgroup computers".

On Vista run cmd net view displays only Athlon-PC (the Vista computer). On XP I get, "There are no entries in the list".

It seems the problem is on the XP computer, but I don't now what else to try.

btw The XP can connect to the Internet without any trouble.

gaius5

Share this post


Link to post
Share on other sites

Posted

Have you simply tried running the Network setup wizard? Are you positive you enabled sharing on both PC's? If all fails and you still can't determine the problem, start from scratch using this tutorial:

http://www.microsoft.com/technet/archive/w...1.mspx?mfr=true

Good Luck!

Share this post


Link to post
Share on other sites

Posted

I thank you all for your suggestions and have tried them all. Now I can ping both computers from one another, but the computers still can't see one another on the lan. In fact, the XP computer doesn't even show itself when I select, "View workgroup computers".

On Vista run cmd net view displays only Athlon-PC (the Vista computer). On XP I get, "There are no entries in the list".

It seems the problem is on the XP computer, but I don't now what else to try.

btw The XP can connect to the Internet without any trouble.

gaius5

what happens when you do the following

start, run, \\x.x.x.x (where x.x.x.x is the IP of the other machine)

Share this post


Link to post
Share on other sites

Posted

what happens when you do the following

start, run, \\x.x.x.x (where x.x.x.x is the IP of the other machine)

if they can ping each other, that should allow you to access the computers :yes:

but it doesn't solve the problem of seeing the computers in the network windows (unfortunately) but it's better than nothing

Share this post


Link to post
Share on other sites

Posted

what happens when you do the following

start, run, \\x.x.x.x (where x.x.x.x is the IP of the other machine)

Windows cannot access \\192.168.1.101

Share this post


Link to post
Share on other sites

Posted (edited)

Windows cannot access \\192.168.1.101

is file and print sharing enabled? if so, then you have a firewall problem.

have you done any manual IP configuration or is everything done from DHCP - the machines should be on the same subnet.

Edited by k22

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.