Jump to content



Photo

Issue with Windows 7 Beta and CHKDSK


  • Please log in to reply
16 replies to this topic

#1 rollinup

rollinup

    Hubert Cumberdale.

  • Joined: 24-June 04
  • Location: Ottawa, Ontario, Canada

Posted 13 January 2009 - 15:59

I installed Windows 7 on a partition with no problem at all. Everything worked flawlessly until my most recent reboot.

Every time I select Windows 7 to boot from, it does a disk check. It will NOT let me do anything to skip it as it would normally (press any key to skip CHKDSK). It completes the CHKDSK operation, reboots, select windows 7...it starts all over again. It's a consistant loop and I'm completely unaware as to how I would go around fixing it.

If all else fails I'm just going to do another clean installation, but for the moment it's getting on my nerves.

Any ideas as to what may have caused this?

Thanks,
Rollinup


#2 0sit0

0sit0

    Live and let live

  • Joined: 24-October 01

Posted 13 January 2009 - 16:04

this might help?

http://www.quarterto...ead.php?t=48539

Instead run from the Windows 7 cd?

#3 sweetleaf

sweetleaf

    Neowinian

  • Joined: 18-December 08

Posted 13 January 2009 - 16:05

Sounds like some corrupt files need to boot windows 7.

#4 Lee G.

Lee G.

    Neowinian Senior

  • Joined: 28-October 04
  • Location: London, UK
  • OS: Windows 8.1

Posted 13 January 2009 - 23:43

Mine's doing exactly the same thing.

#5 Covenn

Covenn

    Resident One Post Wonder

  • Joined: 14-January 09

Posted 14 January 2009 - 17:41

My test system did the exact same thing yesterday, when I powered it up.

I was able to skip the CHKDSK, but upon booting into windows, I found that my secondary partition (D:) had been totally corrupted. I had to delete the partition and re-build it... thankfully there wasn't anything of importance on there.

#6 Loso

Loso

    Neowinian

  • Joined: 26-October 08
  • Location: Toronto

Posted 14 January 2009 - 17:43

i have this same problem and been searching for a solution but not luck

#7 jpmermoz

jpmermoz

    Neowinian

  • Joined: 15-January 09

Posted 15 January 2009 - 14:25

Hi, I had the exact same problem, what I did was just enter Windows 7 with "The last known good boot" option.
After that I was abre to use the OS, but I had some problems after that, like messages saying "Corrupt files", and somes url's didn't load.
Later!

PD: If you guys find a better solution, please tell it here :)

#8 jpmermoz

jpmermoz

    Neowinian

  • Joined: 15-January 09

Posted 15 January 2009 - 23:59

Hi, I had the exact same problem, what I did was just enter Windows 7 with "The last known good boot" option.
After that I was abre to use the OS, but I had some problems after that, like messages saying "Corrupt files", and somes url's didn't load.
Later!

PD: If you guys find a better solution, please tell it here :)


I forgot one thing, after that, go to "start button" and write on the box chkntfs /X C: (In my case C: is where Windows 7 is installed), and afther that, you'll never have that problem.

#9 P00rSpy

P00rSpy

    Neowinian

  • Joined: 27-January 07

Posted 16 January 2009 - 00:11

Have lost a few .ini files and registry setting for some app of my d: drive, checkdisk just doesn't start, and there's error writing on the d: drive!

Seem like some serious bug somewhere...

#10 Steven77

Steven77

    Neowinian

  • Joined: 27-December 08

Posted 16 January 2009 - 00:19

It did that to me when i tried formatting an NTFS partition for W7 with a third party program. I had to let W7 create it's own partition for it to stop.

#11 jakem1

jakem1

    Neowinian Senior

  • Tech Issues Solved: 3
  • Joined: 17-November 06

Posted 16 January 2009 - 01:22

I had chkdsk pop up just before logging into my Vista partition the other day. It only lasted for a second but it did surprise me.

#12 Lee G.

Lee G.

    Neowinian Senior

  • Joined: 28-October 04
  • Location: London, UK
  • OS: Windows 8.1

Posted 16 January 2009 - 14:17

I tried booting into Windows 7 by selecting the "last known good configuration" option, and it worked. Although I still got some messages about the drive having some corruptions, so I had to run chkdsk again, and this time the "last known good configuration" didn't work - it still ran chkdsk. So in the end I formatted my Windows 7 partition and reinstalled. It's fully working now.

#13 jpmermoz

jpmermoz

    Neowinian

  • Joined: 15-January 09

Posted 17 January 2009 - 16:21

Ok, I found the solution to this problem.
Before installing windows 7, what we have to do is format the disk where we're going to make the installation using windows 7 dvd, not a program like norton or something like that.
I did that and now i'm not having more troubles :)

#14 wguimb

wguimb

    Wally

  • Joined: 09-December 08
  • Location: Houston, Texas USA

Posted 26 January 2009 - 01:39

I have been using Windows 7 since build 6801. I am currently using build 7000 just as most of you are. In Beta 1, CHKDSK is broken. I have submitted a bug to MS on this.

Here is what the bug report says:

Bug ID: 405406
Schedule Disk Check does not occur on reboot
Description
Schedule Disk Check does not occur on reboot. Asking for a disk check or CHKDSK is ignored on restart of Windows 7.
>>>>> Additional information entered by submitter <<<<<
Please see the IssueSteps.zip file for repro steps as recorded by the person submitting this bug.
Repro Steps
Attempting to use System Restore and it indicates there is an error on Disk C. I select the option to do a disk check on restart. However, no checking occurs on restart.

No one has entered a bug report about the CHKDSK loop issue. I will if someone will provide me the repro steps and a proper description of the issue.

#15 spruce

spruce

    Neowinian

  • Joined: 23-August 05

Posted 27 January 2009 - 18:35

My CHKDSK is working fine but AVG antivirus was causing a dirty shutdown, as a result files were being corrupted, check in Computer Managment/Event Viewer/Windows Logs/System for critial errors, they were at the very start of the boot process and were being caused by AVG, shut AVG it off and no more problems.


Forgot, running 64 bit Win 7