Jump to content



Photo

Windows 7 not connecting to wep wifi


  • Please log in to reply
22 replies to this topic

#16 OP RayJai

RayJai

    Neowinian

  • Joined: 27-March 05

Posted 12 February 2010 - 16:09

doesn't work.
it says something about home groups and stuff.
and i have to leave it or i already have one set?


#17 +BudMan

BudMan

    Neowinian Senior

  • Tech Issues Solved: 100
  • Joined: 04-July 02
  • Location: Schaumburg, IL
  • OS: Win7, Vista, 2k3, 2k8, XP, Linux, FreeBSD, OSX, etc. etc.

Posted 12 February 2010 - 19:33

What?? WTF does home groups have to do with setting up a wireless connection?

Can you give us the details of exactly what your doing and what exact errors your getting.

#18 rjwtac

rjwtac

    Resident One Post Wonder

  • Joined: 30-April 10

Posted 01 May 2010 - 00:13

A google seems to show quite a few people having issues with it - is yours win7 64 or 32 bit? What driver are you using for your wireless card? A MS one? Or one by the maker of the card?

If your manually setting up the network, and putting in the actual HEX key and picking the correct index setting - it should work.

On your wireless router you should see something sim to this.



Verify that your putting in the ACTUAL key ie in this example the 62CA15E1EA vs the test123 which the router used to generate the key. Also verify that the index one used matches up, see how its using index 1, verify that your putting that in you wireless settings on the machine and using the correct key for index 1.

Make sure you remove any auto created networks for your SSID and create the manual one where you select open and wep and use the actual HEX KEY vs any sort of passphrase or ascii password you use to create the keys.



Hi:
I don't have a win 7 but based on the jpeg u posted; can you pls tell me whether there is an option under 'Encryption' for 26 hex digits. The reason I ask this is because the wep key index 1 on the AP has a WEP key with 26 hex chars as I have chose 128 key bit.
Can you please let me know
Thanks.

#19 alfaaqua

alfaaqua

    Neowinian

  • Joined: 09-March 10

Posted 01 May 2010 - 00:21

I believe the setting is actually "Shared" instead of No Auth....


And I can confirm it:

In Open System authentication, the WLAN client need not provide its credentials to the Access Point during authentication. Thus, any client, regardless of its WEP keys, can authenticate itself with the Access Point and then attempt to associate. In effect, no authentication (in the true sense of the term) occurs. After the authentication and association, WEP can be used for encrypting the data frames. At this point, the client needs to have the right keys.

In Shared Key authentication, the WEP key is used for authentication. A four-way challenge-response handshake is used:

1.The client station sends an authentication request to the Access Point.
2.The Access Point sends back a clear-text challenge.
3.The client has to encrypt the challenge text using the configured WEP key, and send it back in another authentication request.
4.The Access Point decrypts the material, and compares it with the clear-text it had sent. Depending on the success of this comparison, the Access Point sends back a positive or negative response.
After the authentication and association, the pre-shared WEP key is also used for encrypting the data frames using RC4 .

At first glance, it might seem as though Shared Key authentication is more secure than Open System authentication, since the latter offers no real authentication. However, it is quite the reverse. It is possible to derive the keystream used for the handshake by capturing the challenge frames in Shared Key authentication.[2] Hence, it is advisable to use Open System authentication for WEP authentication, rather than Shared Key authentication. (Note that both authentication mechanisms are weak.)


Set it to Shared.

#20 +BudMan

BudMan

    Neowinian Senior

  • Tech Issues Solved: 100
  • Joined: 04-July 02
  • Location: Schaumburg, IL
  • OS: Win7, Vista, 2k3, 2k8, XP, Linux, FreeBSD, OSX, etc. etc.

Posted 02 May 2010 - 12:39


can you pls tell me whether there is an option under 'Encryption' for 26 hex digits. The reason I ask this is because the wep key index 1 on the AP has a WEP key with 26 hex chars as I have chose 128



Yes you can do 128 -- did not see the point in just making the numbers longer ;) But here

128bitkeys.jpg

Well I now have a windows 7 laptop -- so can do some testing on this now.. I find it unlikely that I will run into any problems connecting to wep.. But will give it a test here in a bit.

#21 +BudMan

BudMan

    Neowinian Senior

  • Tech Issues Solved: 100
  • Joined: 04-July 02
  • Location: Schaumburg, IL
  • OS: Win7, Vista, 2k3, 2k8, XP, Linux, FreeBSD, OSX, etc. etc.

Posted 02 May 2010 - 13:16

Ok I just did some testing with both open and shared types of wep.. With open win7 connected just fine - asked for key, bing bang zoom in!!!

askedforkey.PNG

Now I set the wireless accesspoint to "shared" security -- and now it had a problem, did not ask for key and would not connect.. But here is what ticks me off about users, if you would of freaking bothered to run the tools there -- ie when it did not connect it popped up a windows asking if you wanted to diagnose, troubleshoot the problem.

troubleshoot.PNG

It then CLEARLY TELLS you wireless is set for SHARED and not to use it, if you want to continue using it then you need to create a MANUAL profiles -- its right there!!! tells you EXACTLY WTF to do!!!!

tellsyouywhattodo.PNG

So -- I manually create a profile, setting it to shared and putting in my key, etc.

setprops.PNG

Couple seconds later - bing bang zoom Im connected to the WEP Shared auth network.

connectedshared.PNG

So from this testing -- clearly window7 supports connecting to WEP, JFC it even tells why it doesn't connect if you have it set to SHARED and what to do.. Even better is tells you should prob use WPA or WPA2 ;) So if set to open it connects straight away with no issues if you put in the correct KEY! If shared wep it tells you can not auto setup the profile and for you to do it manually, etc. even offers to walk you though how to do that, etc. etc.

So I would have to chuck up this whole thread, and the links on the google with users having issues with wep on win7 to pretty much user error!

edit: Again your best best would be to move to WPA/WPA2 anyway!!! But if your going to use WEP, on your wireless router set it OPEN vs shared an then you wont have to manually created the profile.

Edited by BudMan, 02 May 2010 - 13:23.


#22 polime

polime

    Resident One Post Wonder

  • Joined: 27-March 12

Posted 27 March 2012 - 05:33

hi there, i'm having the same problem here but i already do all the step you tell me but still cannot connect to it

#23 MalwaresUcksbaDly

MalwaresUcksbaDly

    Neowinian

  • Joined: 03-April 12
  • Location: earth
  • OS: linux
  • Phone: android & iOS

Posted 06 April 2012 - 14:25

riding the neco wave

polime have you considered freeRadius?