Jump to content
Sign in to follow this  
Followers 0

Removing Games Explorer?

19 posts in this topic

Posted

Hey guys, was wondering if anyone knows how I can disable Games Explorer from adding new games I install to it or how to remove it completely.

Tried Google but haven't had any luck yet.

Thanks in advance!

Share this post


Link to post
Share on other sites

Posted

I don't know how either but just curious as to why you'd want to remove it since it's not like you gotta use it?

Share this post


Link to post
Share on other sites

Posted

[quote name='SHoTTa35' date='30 March 2010 - 01:42' timestamp='1269909769' post='592410450']
just curious as to why you'd want to remove it since it's not like you gotta use it?
[/quote]
[quote]It seems that perfection is reached not when there is nothing left to add, but when there is nothing left to take away.[/quote]
http://en.wikipedia.org/wiki/KISS_principle

[url="http://en.wikipedia.org/wiki/Obsessive-compulsive_disorder"][color="#FFFFFF"]OCD[/color][/url]

Share this post


Link to post
Share on other sites

Posted

in programs and features on the left you will see turn windows features on or off. open that and uncheck "games" and then click ok. it will ask you to reboot for the changes to take effect.

Share this post


Link to post
Share on other sites

Posted

[quote name='billstelling' date='29 March 2010 - 21:45' timestamp='1269913511' post='592410590']
in programs and features on the left you will see turn windows features on or off. open that and uncheck "games" and then click ok. it will ask you to reboot for the changes to take effect.
[/quote]

I don't think that is what he means. He wants to disable Games Explorer entirely. I don't think there is a way. You can hide it thought. Right click on the Start Menu ----> Properties------>Click the Start Menu tab, then click on the Customize button. Scroll down to Games, Choose "Don't Display this item". Click Apply, then OK. Gone.

I think that's the best you're going to do short of modifying Explorer itself, which I can't for the life of me understand why. It's built into Windows to centralize where game shortcuts are, so I think you'd FUBAR your install if you did that. Create shortcuts on your desktop and follow the about, and you'll be all set.

Share this post


Link to post
Share on other sites

Posted

Threads like this makes me go wtf.

Share this post


Link to post
Share on other sites

Posted

[quote name='billstelling' date='30 March 2010 - 11:45' timestamp='1269913511' post='592410590']
in programs and features on the left you will see turn windows features on or off. open that and uncheck "games" and then click ok. it will ask you to reboot for the changes to take effect.
[/quote]

I have a question for you:

Can you read?

Share this post


Link to post
Share on other sites

Posted

[quote name='av3n' date='29 March 2010 - 22:33' timestamp='1269898430' post='592409824']
Hey guys, was wondering if anyone knows how I can disable Games Explorer from adding new games I install to it or how to remove it completely.

Tried Google but haven't had any luck yet.

Thanks in advance!
[/quote]

I wanted to disable it too. The issue is that every time you launch an application, Windows searches C:\Windows\System32\GameUXLegacyGDFs.dll (check its resources with something like CFF Explorer) for the executable you're about to run. If it is found, rundll32.exe will be launched from the program itself, loading gameux.dll. I just moved to a new house and i had not internet, so Games Explorer was just freezing all my games trying to download informations about them. The only way i found to "disable" it is to delete some keys from the registry. Actually, it will not disable it, but it will prevent it from blocking your games (more than enough for me).
If you are happy with this, just delete everything under HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\GameUX, just leave Games and MachineSettings.

Edit: it will also remove all non-Windows games from Games Explorer, and prevent it from adding more.

Alex
1 person likes this

Share this post


Link to post
Share on other sites

Posted

[quote name='Togusa' date='03 May 2010 - 16:30' timestamp='1272900615' post='592577038']
I wanted to disable it too. The issue is that every time you launch an application, Windows searches C:\Windows\System32\GameUXLegacyGDFs.dll (check its resources with something like CFF Explorer) for the executable you're about to run. If it is found, rundll32.exe will be launched from the program itself, loading gameux.dll. I just moved to a new house and i had not internet, so Games Explorer was just freezing all my games trying to download informations about them. The only way i found to "disable" it is to delete some keys from the registry. Actually, it will not disable it, but it will prevent it from blocking your games (more than enough for me).
If you are happy with this, just delete everything under HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\GameUX, just leave Games and MachineSettings.

Edit: it will also remove all non-Windows games from Games Explorer, and prevent it from adding more.

Alex
[/quote]

You do know that some games are [b][u]ONLY[/u][/b] added to the Games Explorer on install.

So, by removing the ability to add games into the Games Explorer, it effectively removes easy access to those games unless you either manually create shortcuts or use the Start Menu.

[quote name='Xilo' date='30 March 2010 - 23:00' timestamp='1269986437' post='592414152']
Threads like this makes me go wtf.
[/quote]

+1, Why disable it, you don't have to use it.

Share this post


Link to post
Share on other sites

Posted

[quote name='neo158' date='03 May 2010 - 19:03' timestamp='1272909803' post='592577650']
You do know that some games are [b][u]ONLY[/u][/b] added to the Games Explorer on install.

So, by removing the ability to add games into the Games Explorer, it effectively removes easy access to those games unless you either manually create shortcuts or use the Start Menu.

+1, Why disable it, you don't have to use it.
[/quote]

It's clear that you didn't read what i wrote :) Games Explorer was [b]freezing[/b] my games, waiting for rundll32.exe/gameux.dll to download game's infos from internet.
Also, check out that registry key, and you'll see that the game is added (again) every time you launch it (whether it is hidden or not in Games Explorer).
Why do you speak, if you don't know? :p

Alex

Share this post


Link to post
Share on other sites

Posted

if your saying it hanging when you launch your games because you do not have internet access at the time you launch the games -- why don't you just set it not to check the internet, don't download box art, etc.

[attachment=261456:gamesexplorer.jpg]

Kind of hard for me to check now -- but if your saying it hangs when no internet, very easy for anyone to duplicate - and then look for fix.. I dbout you have to delete **** from the reg to get it not to check online, etc.. Will check when at home and can disable it internet access, etc. But have you tried these settings?

Share this post


Link to post
Share on other sites

Posted

[quote name='BudMan' date='04 May 2010 - 16:18' timestamp='1272986323' post='592581976']
if your saying it hanging when you launch your games because you do not have internet access at the time you launch the games -- why don't you just set it not to check the internet, don't download box art, etc.

[attachment=261456:gamesexplorer.jpg]

Kind of hard for me to check now -- but if your saying it hangs when no internet, very easy for anyone to duplicate - and then look for fix.. I dbout you have to delete **** from the reg to get it not to check online, etc.. Will check when at home and can disable it internet access, etc. But have you tried these settings?
[/quote]

Here's the video, so that you can see that those options are useless :) you can clearly see that the only way for me to start the game is to "break" Games Explorer.
Edit: uploaded a higher resolution version
[url="http://www.youtube.com/watch?v=FUqMmlYbaYU"]http://www.youtube.com/watch?v=FUqMmlYbaYU[/url]

Alex

Share this post


Link to post
Share on other sites

Posted

Well when I get home I can surely try and duplicate that problem.

Share this post


Link to post
Share on other sites

Posted

[quote name='BudMan' date='04 May 2010 - 17:26' timestamp='1272990404' post='592582290']
Well when I get home I can surely try and duplicate that problem.
[/quote]

Well i don't think you'll find hard to duplicate it, just remember to disconnect from internet :p also, make sure you use one of the games that are listed in "c:\windows\system32\GameUXLegacyGDFs.dll" (the list is formed by multiple entries in the resource data directory of the executable in plain XML syntax, just use a PE editor). I didn't try with non-legacy games.

I don't think it's relevant (i think all versions give the same issue, in the same environment) but i'm using Windows 7 x64 RTM with all the latest patches installed, and the account i am using does not have administrator privileges.

Note: the HD video has finished processing, here's the link again: [url="http://www.youtube.com/watch?v=FUqMmlYbaYU"]http://www.youtube.com/watch?v=FUqMmlYbaYU[/url]

Alex

Share this post


Link to post
Share on other sites

Posted (edited)

Yeah running win7 x64 as well - fully patched.. And sure I can run with a non admin account - but that should have little issues.. I even have unreal tournament laying around somewhere I could install to test with ;)

edit: quick question for you - what are you using to grab the screen videos? Edited by BudMan

Share this post


Link to post
Share on other sites

Posted

Ok I was able to duplicate your problem -- but only on the install of the game, when it goes to create the entry into game explorer.. Once the entry is there, and you tell it to not update and not download box art, etc. the game launches just fine without net as wth.

Hmmmm -- I see how that could cause some people some problems sure... Pretty ****ty bug for those that don't have internet... Hmmmm have to look into this one some more.

Share this post


Link to post
Share on other sites

Posted

[quote name='BudMan' date='05 May 2010 - 03:05' timestamp='1273025125' post='592584198']
Ok I was able to duplicate your problem -- but only on the install of the game, when it goes to create the entry into game explorer.. Once the entry is there, and you tell it to not update and not download box art, etc. the game launches just fine without net as wth.

Hmmmm -- I see how that could cause some people some problems sure... Pretty ****ty bug for those that don't have internet... Hmmmm have to look into this one some more.
[/quote]

Yup, that is what i thought, permissions are not a problem here :) Well, did you see how smooth the video is? :p That's Fraps, and although it has not born as a screen recorder, it serves this purpose very well. Just remember you have to use Vista or 7 to use (works by hooking Aero, so if you don't have it or it is not enabled you can't record your desktop).
Anyway, which game did you try? Was it inside the list i was speaking about before?

Alex

Share this post


Link to post
Share on other sites

Posted

Yeah I was using the UT 2004, vs having to open up that dll (even though I did), you can view the applications using the compatibility administrator. I was looking to see if I could just disable the compatibility fix gameUX for that title -- but that did not seem to work either.

[attachment=261568:applications.jpg]

Even if it did -- is well beyond what you would expect a normal user to be able to do, etc.

But in the comp admin you can view the global database and every application where there are fixes, and as you can see for ut2004.exe you see the gameUX one.. Now I didn't try this last night - but a easy work around for users might be to just change the name of the .exe so that the fixes are not applied, etc And does not try to add it to game explorer

Share this post


Link to post
Share on other sites

Posted

[quote name='BudMan' date='05 May 2010 - 19:44' timestamp='1273085098' post='592587226']
Yeah I was using the UT 2004, vs having to open up that dll (even though I did), you can view the applications using the compatibility administrator. I was looking to see if I could just disable the compatibility fix gameUX for that title -- but that did not seem to work either.

[attachment=261568:applications.jpg]

Even if it did -- is well beyond what you would expect a normal user to be able to do, etc.

But in the comp admin you can view the global database and every application where there are fixes, and as you can see for ut2004.exe you see the gameUX one.. Now I didn't try this last night - but a easy work around for users might be to just change the name of the .exe so that the fixes are not applied, etc And does not try to add it to game explorer
[/quote]

Could work for some games, but others exports functions from the main executable to other modules! You would have to check all executable images (dlls, exes) for xrefs! :p

Alex

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.