Jump to content



Photo

Razer Imperator Mouse Problem!


  • Please log in to reply
5 replies to this topic

#1 Q9650

Q9650

    { Windows 8 Pro x64 User }

  • Joined: 08-April 09
  • Location: Malta

Posted 30 September 2010 - 16:19

I have a Razer Imperator laser mouse and my issue is that sometimes it seems to enter sleep mode when windows 7 loads up the mouse wheel blue led and pulsating razer logo are turned off and the mouse pointer is stuck..then if I press any mouse buttons or just move the mouse the led`s light up and the pointer start to work fine!

Firmware is 1.04 also tried 1.13 but still the same!

any1 has experienced the same issue on this mouse?


#2 Nagisan

Nagisan

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 02-June 06

Posted 30 September 2010 - 16:22

No issues here (1.13 firmware and OS), but I do not often use Sleep mode. Do you have the drivers installed? Have you tried with and without the drivers?

#3 djzic

djzic

    In The 4GHz Club :D

  • Joined: 02-April 10
  • Location: England, UK

Posted 30 September 2010 - 19:50

Maybe it's meant to be like that?

#4 OP Q9650

Q9650

    { Windows 8 Pro x64 User }

  • Joined: 08-April 09
  • Location: Malta

Posted 01 October 2010 - 06:08

No issues here (1.13 firmware and OS), but I do not often use Sleep mode. Do you have the drivers installed? Have you tried with and without the drivers?


I tried everything with latest mouse drivers v1.02 and without! I just turned on my pc right now and the mouse is again not lit/working! i have to slightly move it to start working again and become lit...i hate it !!

#5 Nagisan

Nagisan

    Neowinian Senior

  • Tech Issues Solved: 1
  • Joined: 02-June 06

Posted 01 October 2010 - 13:22

It sounds like the mouse is going into a sleep mode, moving it wakes it up, what exactly is wrong with that?

Anyway, try another mouse that has some form of lights and see if it exhibits the same behavior.

You can also try going into your device manager, opening up the properties of your mouse (by double clicking it) and going to the Power Management tab, make sure "Allow the computer to turn off this device to save power" is not checked (if its like mine, the option will be grayed out anyway). Another thing you can try is going into your power options, then Advanced power settings, under USB Settings -> USB selective suspend settings try changing it to Disabled (if its enabled) and see if the behavior stops or not.

It sounds like a system issue not a mouse issue though, so I'm willing to bet its something that needs changing in your system configuration to "fix" the minor issue.

#6 ryan1431

ryan1431

    Resident One Post Wonder

  • Joined: 11-May 13

Posted 11 May 2013 - 03:28

download the drivers then load the imperator configurator. once its done loading with the mouse, click on the lighting tab and disable the lighting for the mouse. The lighting uses most power so your computer is most likely sleeping/shutting it off until it reboots.

this should fix your problem as it did for me.

have a good one mate :)



Click here to login or here to register to remove this ad, it's free!