Jump to content



Photo

IE9 and HughesNet Internet


  • Please log in to reply
3 replies to this topic

#1 +LightEco

LightEco

    Neowinian

  • Tech Issues Solved: 1
  • Joined: 17-November 06
  • Location: San Francisco, CA
  • OS: Win 8

Posted 11 February 2011 - 05:57

I'm having an issue with IE9 and my internet provider HughesNet. It seems that the HughesNet has a redirect setup so that if you typed in the address bar in IE7/IE8, they would redirect you to a "Search Assist" page that uses ask.com. This was never a problem because I used the search box and was sent straight to google. Now, IE9 eliminates that box and you have to search through the address bar. Whenever I search with google, I get sent to the searchassist page and can't actually do anything. It seems that HughesNet looks for the "sourceid=ie7" and possibly the "IE-Address" from the Google address.

(google.com/search?q=test&sourceid=ie7&rls=com.microsoft:en-us:IE-Address&ie=&oe=)

If I make my own search provider and change the source to chrome, search works properly, but I lose instant search and suggestions.

To make matters worse, HughesNet has an "opt out" link on the search assist page, but all that does it stick a cookie in your browser and redirects you to search assist, checks the cookie, and then does a new search on google for you. This takes MUCH longer for everything to redirect and load.

Does anyone have any suggestions on how to bypass this whole system? This is the main reason I can't use IE9 at all on my systems.

Thanks!


#2 OP +LightEco

LightEco

    Neowinian

  • Tech Issues Solved: 1
  • Joined: 17-November 06
  • Location: San Francisco, CA
  • OS: Win 8

Posted 11 February 2011 - 06:21

UPDATE: I found a fix.

I changed the following registry key for the default Google search to always say the search comes from the context menu instead of the address bar.

HKEY_CURRENT_USER/Software/Microsoft/Internet Explorer/Search Scopes/(Google's Entry)

Changed the URL entry from

http://www.google.co...oft:{language}:{referrer:source}&ie={inputEncoding?}&oe={outputEncoding?}

to

http://www.google.co...oft:{language}:IE-ContextMenu&ie={inputEncoding?}&oe={outputEncoding?}

Just a heads up for anyone who might also have HughesNet and want normal Google back.

#3 TEX4S

TEX4S

    Neowinian Senior

  • Joined: 06-October 04
  • Location: DFW

Posted 11 February 2011 - 06:45

UPDATE: I found a fix.

I changed the following registry key for the default Google search to always say the search comes from the context menu instead of the address bar.

HKEY_CURRENT_USER/Software/Microsoft/Internet Explorer/Search Scopes/(Google's Entry)

Changed the URL entry from

http://www.google.co...oft:{language}:{referrer:source}&ie={inputEncoding?}&oe={outputEncoding?}

to

http://www.google.co...oft:{language}:IE-ContextMenu&ie={inputEncoding?}&oe={outputEncoding?}

Just a heads up for anyone who might also have HughesNet and want normal Google back.


Your ISP redirects to known adware/spyware ?

Have you run malwarebytes on your machine ?

HughesNet - arent they the douches who have Satellite internet @ $150/mo for 500kbps ?

#4 Mike Allen

Mike Allen

    Neowinian Senior

  • Joined: 05-May 05
  • Location: Where it's blue states against red states

Posted 11 February 2011 - 06:47

I used to be unfortunate to have HughesNet and I don't remember such behavior.



Click here to login or here to register to remove this ad, it's free!