Critical Flaws Found In Mozilla Products

After releasing their much awaited preview release of Firefox 1.0, the Mozilla Foundation has issued a warning about seven critical security issues with three of its flagship products.

Any product versions prior to Mozilla 1.7.3, Firefox 1.0PR and Thunderbird 0.8 are considered vulnerable. Mozilla recommends that all users upgrade their affected software to prevent exploitation of their systems.

All current releases of mentioned software are considered "patched" against these new found vulnerabilities. Users of affected software should download the most recent version of their products as soon as possible to ensure their continued safe functionality.

View: Mozilla Foundation

View: Neowin Forum Discussion

News source: Internetnews.com

Report a problem with article
Previous Story

GMNotifier 1.0

Next Story

Quantum Security Realised

2 Comments - Add comment