Windows 7 Remote Desktop Connection - how to disable the login screen?


Recommended Posts

Malechai

Hey guys I'm really hoping someone can help me here.

So the situation is that I'm on Windows 7 using RDC to remote into 2 virtual Windows 7 images. One is english, one is french.

When I use RDC to connect to the english image, an RDC window opens with a Windows 7 login screen that has 2 clickable options - my account with a picture and another options that says "Other user"

When I use RDC to connect to the french image, no RDC window opens - I get a Windows Security box that asks for me to enter my credentials and then loads directly into that related account on the virtual image.

I would like the english to be the same as the french. I don't want the login screen. Does anyone know how to make these the same?

It used to be the same and suddenly it changed. I suspect its a setting somewhere but I'm coming up short on finding it.

Thanks

Link to post
Share on other sites
+LogicalApex

In Settings (Windows Key + Pause then hit Remote Settings) you need to ensure Network Level Authentication is on. This would be done on the machine you are connecting to.

Link to post
Share on other sites
cybertimber2008

OR

Open Remote Desktop Connection. Expand options.

Under "Logon settings" I think on your French connection you have the Computer and User name entered... while on your english version you just have Computer.

Double check NTLM and the logon settings.

Link to post
Share on other sites
Malechai

Thank you for your replies guys!

In Settings (Windows Key + Pause then hit Remote Settings) you need to ensure Network Level Authentication is on. This would be done on the machine you are connecting to.

I confirmed that both images are set to not use NLA. If I change them to use NLA, I can't connect to the images at all.

OR

Open Remote Desktop Connection. Expand options.

Under "Logon settings" I think on your French connection you have the Computer and User name entered... while on your english version you just have Computer.

Double check NTLM and the logon settings.

I checked both as I have saved .rdp files on my desktop and both have the computer name and user name saved.

Saved logon settings on each shortcut match, save the computer names.

You refer to NTLM - where would I double check this and what am I looking for? Discrepancies between each?

Link to post
Share on other sites
+BudMan

We had a thread very sim to this a while back, here was my answer

http://www.neowin.net/forum/topic/1039695-rdp-windows-server-2008/page__view__findpost__p__594460433

Take a look at the link to the MS site for more detail.

In that thread they WANTED the login screen and were not seeing it, but the MS article should give you the details needed to have it work the way you want.

What RDP client are you using btw?

Link to post
Share on other sites
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.