• 0

(DD-WRT) Linking wired routers to extend wireless range...


Question

htcz

I have 2 DD-WRT routers linked together following this guide: http://www.dd-wrt.com/wiki/index.php/Wireless_Access_Point I thought this worked.....but now Im not sure

Now from what I understand (and by logic) I should still be able to access this router at 192.168.1.2 as it is its IP. When I try to ping it (that second router), it says:

Reply from 192.168.1.13: Destination host unreachable.

Now that xx.xx.xx.13 is the PC Im currently on's IP address. I can access my primary one at 192.168.1.1

My DHCP pool is from 192.168.1.100 to 192.168.1.149 so that 192.168.1.2 will never be assigned.

So is it working, is it not working, is this suppose to be like this, etc....

(BTW, I do know that this slows down my wireless network but due to my physical house structure, I have no choice)

Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0
lars77

The link talks about setting a router in AP-only mode. You don't really need DD-WRT for that, with most routers nowadays it isn't too hard to make them operate in AP mode. It also won't slow down your wireless network if they're on different channels anyway (unless you're totally talking about some other setup?).

But yeah, based on the above you should be able to ping both routers from your computer. Offhand it sounds like your AP-mode router isn't configured to be on the same network? Taking a wild guess, maybe you have the network cables plugged in wrong?

So for your AP router the general setup should be:

- It won't have any network cables connected to its WAN port (typically)

- It'll still need to be networked to the rest of the network, usually with a network cable connected to one of the LAN ports

- DHCP should be disabled

- Firewall is disabled (it'd usually be disabled for LAN connections anyway)

- Local IP should be set, its gateway/DNS is usually set to the main network router's IP (for extra credit set the local IP to DHCP & let the network router assign it via DHCP, but only do this if you know how to handle static IPs via DHCP server)

- For the wireless, if the main router also has wireless, then both AP & router should be the same SSID, same passphrase, same security, just different channels.

I don't think there's anything else you really need to do offhand.. if it is set up right you should definitely be able to ping both router & AP.

Maybe you can try to descibe the setup a bit better? This is sort of how you should be set up, I'm guessing:

Router1 (using as your main network router):

Local IP: 192.168.1.1, subnet: 255.255.255.0, DNS: Probably whatever you're getting from your WAN/internet

WAN: Enabled for whatever internet you have with the WAN port plugged into your cable/DSL/whatever

LAN: One of the LAN ports should have a network cable plugged in, running to Router2

DHCP: Enabled (192.168.1.100 - 149 should be fine)

Wireless: If it's enabled should be same SSID/Passphrase/Security as Router2, but different channel

Router2 (using as an AP only):

Local IP: 192.168.1.2, subnet: 255.255.255.0, Gateway: 192.168.1.1, DNS: 192.168.1.1

WAN: Disabled, with nothing plugged into the WAN port

LAN: One of the LAN ports should have a network cable plugged in, running to Router1

DHCP: Disabled

Wireless: If it's also enabled on Router1 then should have same SSID/Passphrase/Security as Router1, just a different channel

Link to post
Share on other sites
  • 0
htcz

The only thing I see different is that both are on the same wireless channel because I thought the configuration asked for that (it made no sense, I know but I did it anyways).

Ill try doing 30/30/30 and start from scratch....

Link to post
Share on other sites
  • 0
+BudMan

What channel the wireless is on would have nothing to do with you pinging the lan IP.

Is your .13 box wired or wireless when your trying to ping the .2 address?

Did you go the adding wan port to the bridge route, or did you just use a lan port on this 2nd router that your wanting to use as AP?

My guess is you used wan port and did not get added, or IP did not get set to .2, etc.

Link to post
Share on other sites
  • 0
htcz

The .13 is wired.

Ill "fix" that channel thing and retry again with what has been commented...

Link to post
Share on other sites
  • 0
htcz

Fixed :) I entered all that was written in this thread and now I can access both routers. Thank you :)

Link to post
Share on other sites
  • 0
+BudMan

Using the wan port as a lan port is optional - so which route did you go?

Link to post
Share on other sites
  • 0
htcz

Using the wan port as a lan port is optional - so which route did you go?

Did not change anything at all. 30/30/30 and left the router how it was: 1 cable in LAN1 and another in LAN4. The WAN port stayed empty as before.

Must have been something I touched accidentally. Thanks to all :)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.