"This site is running TeamViewer"


Recommended Posts

Zoom7000

Whenever I type "Home" or "http://home" either on Firefox, Chrome or Safari on my MacBook (10.7.4) I get a page that says:

This site is running TeamViewer.

Free Port 80 for other applications in advanced settings.

I've searched Google and found this page on TeamViewer's support page telling you how to remove it. The trouble is, the Mac version of TeamViewer doesn't have this option. Even more strangely I have completely uninstalled TeamViewer and I still get that message.

Any ideas how I can get rid of it?

Link to post
Share on other sites
Miuku.

Perhaps it has copied the .htm(l) files to your public web server directory?

Link to post
Share on other sites
Zoom7000

My Public folder only has the system built in "Drop Box" folder and I don't actually have web server running on the MacBook.

Link to post
Share on other sites
Miuku.

Sorry it took me a while to reply - watching footie :p

Anyway, open terminal, type sudo -s and it'll ask for your password, then type: lsof -i | grep -i listen

It should show you what application is listening to Port 80. Also check System Preferences / Sharing and see if you have Web Sharing on, the files for it are located in /Library/WebServer/Documents (from memory)

Link to post
Share on other sites
Zoom7000

lol, watching footie here too! :p

This is the result of the command

bash-3.2# lsof -i | grep -i listen
launchd	 1	   root   19u  IPv6	 0t0	TCP localhost:ipp (LISTEN)
launchd	 1	   root   20u  IPv4	 0t0	TCP bebox.config:ipp (LISTEN)
Dropbox   185	   Zoom   19u  IPv4 	 0t0	TCP *:17500 (LISTEN)
Dropbox   185	   Zoom   24u  IPv4 	 0t0	TCP bebox.config:26164 (LISTEN)
bash-3.2#

I've snipped the hex stuff after the IPv6/4.

Also, web sharing is definitely switched off in System Preferences

Link to post
Share on other sites
Tekkerson

Are you sure you're not running teamviewer?

Link to post
Share on other sites
Miuku.

That's really weird - there's no service listening to port 80 according to that.

Are you sure it's not cached? Try another browser? Telnet to port 80?

Link to post
Share on other sites
Zoom7000

Are you sure you're not running teamviewer?

I've completely uninstalled TeamViewer and it's not running on my Mac.

That's really weird - there's no service listening to port 80 according to that.

Are you sure it's not cached? Try another browser? Telnet to port 80?

I'm getting the same result with all 3 browsers. (Firefox, Chrome and Safari) All caches cleaned using CCleaner. Telnet to port 80 just says "nodename nor servname provided, or not known"

Link to post
Share on other sites
Sophism

Try "telnet localhost 80"

Link to post
Share on other sites
Zoom7000

127.0.0.1 doesn't get anywhere. Which sounds right as I don't have a web server running.

telnet localhost 80 just results in Connection Refused.

Link to post
Share on other sites
Miuku.

Right, so the thing is "Home" is actually resolving to something.

Open a terminal and ping home and nslookup home

Link to post
Share on other sites
Zoom7000

OK, this is starting to make sense now...

nslookup home results in the IP address of my router. I just updated the firmware yesterday as my ISP are making changes to the core network and they have started using TeamViewer for their remote support. So I guess this is pretty much their doing!

The interesting question is, I stumbled across this because I tried to get to Firefox's new Home Page by typing "Home" in to the address bar. So, how do I access it, if it points to the router?

Link to post
Share on other sites
Miuku.

about:home ?

Link to post
Share on other sites
Zoom7000

I guess that works. Thanks for your help tonight! :)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.