Sign in to follow this  

PC will not shutdown unless keyboard is unplugged

Recommended Posts

jnelsoninjax    8,948

I have discovered by total accident that my system will not shutdown unless the keyboard is unplugged. When the keyboard is plugged in the system will restart when I call for a shutdown. I have checked the device manager and disabled the keyboards ability to wake the system, but that has not seemed to make any difference. Anyone have any ideas/thoughts/suggestions as to what I can check? TIA

Share this post


Link to post
Share on other sites
cork1958    1,087

On an older machine, I had accidentally hit the Windows key on keyboard one time while that computer was shutdown. Was trying to figure out why light on keyboard and optical mouse always stayed on, even with machine off.

Next time I tried to restart it, it just kept restarting. I forced the power off and then hit the Windows key while it was off. Fixed that problem, but never have figured out why those 2 lights stay on? Some crappy ASUS motherboard issue, I think.

So, I guess I'm saying try hitting the Windows key while machine is off or maybe while it's trying to start.

Share this post


Link to post
Share on other sites
jnelsoninjax    8,948

Anyone else have any other ideas?

Share this post


Link to post
Share on other sites
StevenJ    93

USB or PS/2?

Share this post


Link to post
Share on other sites
Hum    6,930

Shake out, clean the keyboard -- a key may be stuck.

Try another keyboard.

Add or Remove any keyboard drivers -- for instance, you have a Logitech driver.

Reinstall, Update USB drivers.

Share this post


Link to post
Share on other sites
f0rk_b0mb    698

I had this problem with my Logitech Keyboard. I figured out it was because I was in AHCI mode. I have a Crappy OCZ Vertex and it only seems to work well in the default SATA/IDE mode. Disable AHCI and try again. It fixed it for me. Hope this helps. :)

  • Like 1

Share this post


Link to post
Share on other sites
jnelsoninjax    8,948

It is a logictech, and I do have the hdd's in AHCI mode, so I can not really disable AHCI at the moment. I have just recently (~a week) installed the keyboard drivers, so I know that they are up to date.I am downloading the chipset drivers from AMD and will see it it helps, these drivers were released 8/15/2012 so it is possible that they will help something!

  • Like 1

Share this post


Link to post
Share on other sites
Hum    6,930

I would try removing the Logitech drivers, and see if it behaves any differently.

You can always Reinstall.

  • Like 1

Share this post


Link to post
Share on other sites
jnelsoninjax    8,948

Well I just installed the AMD chipset drivers, and windows refuses to run. I finally got it run by booting last known good config. How can I uninstall the chipset drivers? The only thing showing in device manager is the CCC, and the only option for that is repair. Also, this issue with the shutting down, only happens when the Logitech G110 is plugged in, I have another logitech keyboard (K120) and windows will shut down fine.

Share this post


Link to post
Share on other sites
Hum    6,930

You can usually Roll back drivers from the Device Manager.

And it sounds like the other keyboard has a defect.

Share this post


Link to post
Share on other sites
Praetor    987

I've seen lots of weird things in IT like this one; if it isn't AHCI then the keyboard has an defect.

Share this post


Link to post
Share on other sites
f0rk_b0mb    698

I have the same keyboard as you. Instead of downloading the (Legacy) drivers, get the (Current) ones here. (Under downloads tab. select OS, 64/32 bit, etc.)

http://www.logitech....g-keyboard-g110

It is a very buggy keyboard--I just bought it to replace my POS Dell one. I have the same problems as you sometimes. Try a different usb port too. Do you have another computer? Install the drivers on that one, plug it in and test it. If it works with that machine, it might be your motherboard not likeing it or a software issue. Also, try a full format. Update your bios, install windows 7, Google all of your devices and download the current driver, Do your Windows updates, and see if that helps.

Share this post


Link to post
Share on other sites
pes2013    85

Open cmd and put

shutdown /t 1 /f /s

Tell us if it shuts down...

Share this post


Link to post
Share on other sites
jnelsoninjax    8,948

I have the same keyboard as you. Instead of downloading the (Legacy) drivers, get the (Current) ones here. (Under downloads tab. select OS, 64/32 bit, etc.)

http://www.logitech....g-keyboard-g110

It is a very buggy keyboard--I just bought it to replace my POS Dell one. I have the same problems as you sometimes. Try a different usb port too. Do you have another computer? Install the drivers on that one, plug it in and test it. If it works with that machine, it might be your motherboard not likeing it or a software issue. Also, try a full format. Update your bios, install windows 7, Google all of your devices and download the current driver, Do your Windows updates, and see if that helps.

Thanks, I'll try the drivers suggested, as for different USB port, I have tried front and rear, and just completed a format and install a week ago.

Share this post


Link to post
Share on other sites
pes2013    85

Open cmd and put

shutdown /t 1 /f /s

Tell us if it shuts down...

Did you try this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.