Sign in to follow this  

Task Manager reporting wrong CPU frequency

Recommended Posts

neo1911    795

Don't know if this is a bug or a feature but the Windows 8 Task Manager always shows frequency higher than CPU-Z.

When I do CPU intensive task, it shows 5.10 Ghz frequency which is obviously wrong as my i5-3550 has maximum frequency limit of 4.10 Ghz.

fmrpM.jpg

Anyone noticed this? Clean re-install nor updating BIOS helped.

Share this post


Link to post
Share on other sites
ILikeTobacco    839
...

I am noticing the Maximum speed as being 4.1. Possible it throttles up and down to save energy?

Share this post


Link to post
Share on other sites
Astra.Xtreme    2,094

Well your CPU will automatically underclock itself when it's not being used, so that part is probably correct.

But when it displays 5.1GHz, I have no idea what's going on there. Does CPU-Z show the same thing?

  • Like 1

Share this post


Link to post
Share on other sites
neo1911    795

CPU-Z shows 4.1 Ghz. Windows task manager shows 4.8 Ghz or 5.1 Ghz depending on it's mood.

Share this post


Link to post
Share on other sites
xendrome    4,382

This is normal if speedstep is on and you are using Balanced as your power plan AFAIK.

The CPU will clock down, then clock up to it's standard operating speed. That CPU operates at 3.30Ghz, and Turbos up to 3.7Ghz. Run prime95 on it and you should see it go up to 3.7Ghz.

I don't see where it says 5.1ghz but I don't know why it's showing 4.1Ghz unless you overclocked it

Share this post


Link to post
Share on other sites
Astra.Xtreme    2,094

CPU-Z shows 4.1 Ghz. Windows task manager shows 4.8 Ghz or 5.1 Ghz depending on it's mood.

I would definitely say it's a Windows problem then. But you shouldn't be surprised. :rolleyes:

Share this post


Link to post
Share on other sites
firey    3,579

Don't know if this is a bug or a feature but the Windows 8 Task Manager always shows frequency higher than CPU-Z.

When I do CPU intensive task, it shows 5.10 Ghz frequency which is obviously wrong as my i5-3550 has maximum frequency limit of 4.10 Ghz.

Anyone noticed this? Clean re-install nor updating BIOS helped.

the newer intel cores have "Turbo Boost". Which will underclock your CPU automagically during low loads. During more CPU intensive tasks it will bring it up to speed. It's possible that when CPUz is launched it doesn't have much load and as such you see a lower speed, whereas I am assuming Windows 8 can take that into account and show the maximum, as well as the current.

Share this post


Link to post
Share on other sites
Hum    6,929

This is a feature -- called EgoBoost :shifty:

Share this post


Link to post
Share on other sites
neo1911    795

This is a feature -- called EgoBoost :shifty:

Definitely no:

Look here. CPU under full load.

3lgp2.jpg

Share this post


Link to post
Share on other sites
HawkMan    5,117

Right click the graph and change to logical processors, it might be it does something weird in how it calculates with multiple cores.

Share this post


Link to post
Share on other sites
ILikeTobacco    839

Definitely no:

Look here. CPU under full load.

3lgp2.jpg

Question... whats the multiplier for under what you pointed at

Share this post


Link to post
Share on other sites
neo1911    795

Multiplier is 39 or in rare cases it does hit 41.

Changing to logical processors does nothing.

Share this post


Link to post
Share on other sites
dwLostCat    983

If you've got the system overclocked then yes, it's probably just showing the max speed under TurboBoost. When only one or two cores are active it'll boost the speeds. http://en.wikipedia.org/wiki/Intel_Turbo_Boost

Share this post


Link to post
Share on other sites
neo1911    795

If you've got the system overclocked then yes, it's probably just showing the max speed under TurboBoost. When only one or two cores are active it'll boost the speeds. http://en.wikipedia....tel_Turbo_Boost

i5-3550 is Non-K edition. It cannot be overclocked.

Share this post


Link to post
Share on other sites
dwLostCat    983

Ahh. Well, it looks like Windows reports frequency based on only some variables. I'd dig around more but I haven't really slept in two days, time to fix that :p :)

Share this post


Link to post
Share on other sites
HappyGamer21    0

i5 with turbo boost disabled in BIOS

Share this post


Link to post
Share on other sites
remixedcat    2,765

152x dBPowerAmp conversion @100%@4cores

post-361542-0-79070300-1357236937.jpg

Share this post


Link to post
Share on other sites
ndoggfromhell    34

post-10903-0-85420400-1357237543.png

My Xeon is doing the same

post-10903-0-85420400-1357237543.png

Share this post


Link to post
Share on other sites
HappyGamer21    0
post-476442-0-24899600-1357269382.png

Share this post


Link to post
Share on other sites
ArialBlue    395

You guys don't know that your CPU doesn't run at full power all the time? :/

Share this post


Link to post
Share on other sites
linsook    149

You guys don't know that your CPU doesn't run at full power all the time? :/

they're talking about the cpu being reported going above spec.

  • Like 1

Share this post


Link to post
Share on other sites
Mr. Gibs    3,863
i5-3550 is Non-K edition. It cannot be overclocked.

That has absolutely nothing to do with it. Turbo Boost doesn't require a K series processor and is enabled on most of the I-series processors. Basically if it detects that a running program isn't multi-core optimized it shuts off some (1, 2, or even 3) of the cores and overclocks the remaining cores.

For example, my processor is 1.73 but with turbo boost enabled (on 1 core for this example) it rises to 2.93.

What's weird though is Intel says your CPU has a max turbo frequency of 3.7, but Windows is reporting 4.1/5.1 :/ Maybe your motherboard/BIOS is reporting the wrong CPU?

Share this post


Link to post
Share on other sites
neo1911    795

^^ Motherboard and Bios are reporting the exact CPU which I purchased. It's just that Windows Task Manager reports incorrect frequency compared to CPUz or any other CPU freq monitoring program.

This issue has nothing to do with overclocking. The new Task Manager in Windows 8 is incapable of reading correct CPU speeds in some cases. I call this Windows bug.

Share this post


Link to post
Share on other sites
farmeunit    454

People replying about Speedstep, try reading again. Looking at the pictures will help explain, also. That's what they're there for.

That being said, I've not seen that, but I generally use slightly older processors. Maybe it's the way the newer ones are seen by the OS?

Share this post


Link to post
Share on other sites
yowanvista    103

Disable Intel Speedstep/Eist in your bios.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.