Sign in to follow this  

Intel SSD Toolbox wants Superfetch enabled

Recommended Posts

DrJohnSmitherson    131

I just got my first ssd recently and I thought I read online that Superfetch should be turned off.

I downloaded the Intel SSD Drive Toolbox to update my ssd and Optimize it and under System Tuner it recommends that Superfetch be enabled.

Should I have it on or off?

Thanks!

EDIT: Using Win8 btw

Share this post


Link to post
Share on other sites
Mr. Gibs    3,863

Windows should automatically disable superfetch if it detects an SSD.

Be default, Windows 7 will disable Superfetch, ReadyBoost, as well as boot and application launch prefetching on SSDs with good random read, random write and flush performance. These technologies were all designed to improve performance on traditional HDDs, where random read performance could easily be a major bottleneck. See the FAQ section for more details.

http://blogs.msdn.com/b/e7/archive/2009/05/05/support-and-q-a-for-solid-state-drives-and.aspx

So I say you should keep it disabled.

Share this post


Link to post
Share on other sites
DrJohnSmitherson    131

Windows should automatically disable superfetch if it detects an SSD.

http://blogs.msdn.co...drives-and.aspx

So I say you should keep it disabled.

I am on Win8 though, has anything changed since then?

Share this post


Link to post
Share on other sites
Salty Wagyu    59

My Intel SSD Toolbox (3.1.2) on Windows 7 recommends Superfetch be disabled, not sure why yours says different?

post-250813-0-66998900-1357254457.png

Share this post


Link to post
Share on other sites
+PeterUK    63

Unless your SSD is not the boot drive for the OS?

Share this post


Link to post
Share on other sites
streetw0lf    202

Go to Administrative Tools | Defragment and Optimize Drives. See if your SSD is labeled a Solid State Drive. If it's labeled a Hard Disk Device then this might be your problem. I had my SSD drive show up as a HDD at one point.

Share this post


Link to post
Share on other sites
Mr. Gibs    3,863

I am on Win8 though, has anything changed since then?

Nope. Superfetch is unnecessary on SSDs because they load programs/files instantly regardless of where they're stored on the drive.

Share this post


Link to post
Share on other sites
DrJohnSmitherson    131

Go to Administrative Tools | Defragment and Optimize Drives. See if your SSD is labeled a Solid State Drive. If it's labeled a Hard Disk Device then this might be your problem. I had my SSD drive show up as a HDD at one point.

It is labeled as an SSD, and my boot drive

Share this post


Link to post
Share on other sites
Simon-    490

I just set one up yesterday with Windows 7, mine said to disable it so I did. I remember that the UEFI Setup had an option to change the port between HDD and SSD, I don't know if this makes a difference. If not this, maybe post a screenshot?

Share this post


Link to post
Share on other sites
ruhgster    2

I also just got an SSD and did some research, because of the way Superfetch works with an SSD in windows 8(different from Windows 7 apparently), it does not cause wear and is recommended to be left on.

Share this post


Link to post
Share on other sites
DrJohnSmitherson    131

Or off. That user says disabling it will have no effect.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.